goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 98891
Top-Poster: Johannes_B (5059)

Wir begrüßen unseren neuesten Benutzer fretschi.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

biblatex-sbl:

 

aasaa00
Forum-Fortgeschrittener
Forum-Fortgeschrittener

Beiträge: 54
Anmeldedatum: 01.03.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 16.08.2019, 00:16     Titel: biblatex-sbl:
  Antworten mit Zitat      
Ich verwende biblatex-sbl und wenn in den Fußnoten mehrere Verweise auf Werke eines Autors aufeinanderfolgen, setzt mit biblatex-sbl "Ders." bzw. "Dies." stets klein - wie kann ich es auf Großschreibung stellen?
In meinem MWE weiß ich nicht, warum mir "Ders." überhaupt nicht angzeigt wird - ich hoffe aber, dass trotzdem die Frage klar ist und bedanke mich vorab für jede Hilfe.

Code • Öffne in Overleaf

    \RequirePackage[patch]{kvoptions}
    \documentclass[openany]{book} %headsepline
   
    \usepackage{filecontents}
    \begin{filecontents}{\jobname.bib}
    @mvbook{Gehrke.19,
      author = {Gehrke, Hans-Joachim
},
      title = {Geschichte der Antike. Ein Studienbuch},
      location = {Stuttgart},
      edition = {2},
      date = {2019}
    }
   
    @incollection{Krause.19,
     author={Krause, Jens-Uwe
},
     gender = {sm},
     title={Die Spätantike (284-565 n. Chr.)},
     editor = {Gehrke, Hans-Joachim and Schneider, Helmuth},
     date = {2019},
     booktitle = {Geschichte der Antike. Ein Studienbuch},
     location = {Stuttgart},
     keywords = {sekundaer},
     pages={429--499},
     edition={5},
    }
   
    @article{Krug.19,
 author = {Krug, Alexandra
},
   gender = {sm},
 date = {2019},
 title = {The Time},
journaltitle = {Revue Today},
shortjournal = {RT},
volume = {18,1},
pages = {9--38},
}
   
    \end{filecontents}
   
    \usepackage[ngerman]{babel} %Kommentar
   
   
    \usepackage[autostyle=true,german=quotes]{csquotes}
    %\usepackage[german=guillement]{csquotes}
    \usepackage[style=sbl,backend=biber,sblfootnotes=false,ibidpage=true,sorting=nyvt,url=false,isbn=false,doi=false,clearlang=false,uniquename=false]{biblatex}
    \addbibresource{\jobname.bib}
   
    \begin{document}
    \null\vfill
    Filler text \autocite{Gehrke.19}.
    Filler text \autocite{Gehrke.19}.
    Filler text \autocite{Krause.19}.
    Filler text \autocite{Krause.19}.
        Filler text \autocite{Krug.19}.
    Filler text \autocite{Krug.19}.
    \printbibliography
    \end{document}
 
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 16.08.2019, 07:42     Titel:
  Antworten mit Zitat      
Wenn das Beispiel das Problem nicht zeigt, dann ist es leider kein gutes InfoMinimalbeispiel. Bitte versuch immer, ein Beispiel zu zeigen, dass das Problem auch reproduziert. In dem Fall hier wären aufgrund der Regeln für "Ders." wohl zwei unterschiedliche Werke mit derselben Autorin sinnvoll.

In
Code • Öffne in Overleaf
\RequirePackage[patch]{kvoptions}
\documentclass[openany]{book}
\usepackage[ngerman]{babel}
\usepackage[autostyle=true,german=quotes]{csquotes}
\usepackage[style=sbl, backend=biber,
  sorting=nyvt, uniquename=false,
  ibidpage=true, sblfootnotes=false,
  url=false, isbn=false, doi=false, clearlang=false
]{biblatex}


\addbibresource{biblatex-examples.bib}

\begin{document}
\null\vfill
Filler text \autocite{knuth:ct:a}.
Filler text \autocite{knuth:ct:b}.
Filler text \autocite{sigfridsson}.
Filler text \autocite{knuth:ct:a,knuth:ct:b}.
\printbibliography
\end{document}

bekomme ich "ders."/"Ders." allerdings nicht immer kleingeschrieben sondern zumindest für meinen Geschmack recht konsistent den üblichen Regeln der Orthographie folgend.

aasaa00
Forum-Fortgeschrittener
Forum-Fortgeschrittener

Beiträge: 54
Anmeldedatum: 01.03.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 16.08.2019, 11:57     Titel:
  Antworten mit Zitat      
Auch in deinem Beispiel wird mir "Ders" nicht angezeigt und ich weiß nicht warum. Hier ist ein Link zu dem, was mir im Overleaf angezeigt wird:

https://ibb.co/HTvz0f4
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 16.08.2019, 14:59     Titel:
  Antworten mit Zitat      
Bei Overleaf läuft Version 0.8.1 von biblatex-sbl vom 2017/01/15. Aktuell ist Version 0.11 (2018-12-13). Da bekommt man "ders.". In der Tat findet sich in dem Important Changes-Abschnitt der Dokumentation unter Version 0.9 (2018-05-20) der Hinweis Use ibid and idem by default. In der alten Version von Overleaf ist "ders." also noch nicht aktiviert. Man kann mit ibidtracker=constrict nachhelfen und zumindest ein bisschen "ders." bekommen. Allerdings hat die aktuelle Version etwas mehr "ders." als das, was Du so bekommst.

Denk darüber nach, ein aktuelles, lokales System zu installieren anstatt Overleaf zu nutzen. Oder versuch Overleaf zu überzeugen, Dir ein aktuelles System zur Verfügung zu stellen. Theoretisch kannst Du auch versuchen, die Dateien von biblatex-sbl auf CTAN zu Deinem Overleaf-Projekt hochzuladen und hinzuzufügen und so auf eine neuere Version von biblatex-sbl umzusteigen, aber das muss nicht unbedingt klappen, da hier einige Pakete involviert sind.

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de