goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 97672
Top-Poster: Johannes_B (5054)

Wir begrüßen unseren neuesten Benutzer davidebond.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Fehler beim Kompilieren

 

ThoRie
Forum-Fortgeschrittener
Forum-Fortgeschrittener

Beiträge: 83
Anmeldedatum: 12.05.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 13.05.2019, 23:51     Titel: Fehler beim Kompilieren
  Antworten mit Zitat      
Ich habe da mal eine sehr spezielle Frage.
Hat schon mal jemand die folgende Fehlermeldung gesehen und das Problem lösen können?
    ! TeX capacity exceeded, sorry [main memory size=3000000].
    <argument> \@structureframebackground
    l.285 \end{finalframe}
    If you really absolutely need more capacity,
    you can ask a wizard to enlarge me.
    Here is how much of TeX's memory you used:
    56227 strings out of 492942
    1236975 string characters out of 3135393
    3000000 words of memory out of 3000000
    58911 multiletter control sequences out of 15000+200000
    135357 words of font info for 211 fonts, out of 3000000 for 9000
    1145 hyphenation exceptions out of 8191
    76i,18n,121p,1139b,2940s stack positions out of 5000i,500n,10000p,200000b,50000s


Also so wie ich das verstehe, will der Texmaker hier wohl mehr RAM nutzen als er darf. Aber ich bin mir zum einen nicht sicher darüber und zum anderen habe ich keine Ahnung, wie ich das beheben soll. Die Priorität des Programms ist schon maximal und etwas anderes habe ich nicht offen :/
Private Nachricht senden Benutzer-Profile anzeigen

Bartman
Forum-Meister
Forum-Meister


Beiträge: 1664
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: ---
     Beitrag Verfasst am: 14.05.2019, 00:35     Titel:
  Antworten mit Zitat      
Nicht der Editor möchte mehr Speicher nutzen, sondern pdfLaTeX. Falls nötig, müsste der Speicher manuell über ein Argument beim Programmaufruf eingestellt werden. Bei manchen Zeichnung mit pgfplots wird die Fehlermeldung auch durch ungünstige Einstellung der Optionen verursacht. Der Wechsel zu LuaLaTeX kann ein Ausweg sein.

Zuletzt bearbeitet von Bartman am 16.05.2019, 02:01, insgesamt einmal bearbeitet
Private Nachricht senden Benutzer-Profile anzeigen

ThoRie
Forum-Fortgeschrittener
Forum-Fortgeschrittener

Beiträge: 83
Anmeldedatum: 12.05.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 14.05.2019, 09:11     Titel:
  Antworten mit Zitat      
Okay, also das mit LuaLaTeX habe ich jetzt mal versucht. Das kommt aber nicht als Lösung in frage, da er auf diese Weise zum einen keine Umlaute erkennt und mir zum anderen meine ganze Formatierung zerhaut :/

Wie kann ich das mit dem Programmaufruf einstellen?
Private Nachricht senden Benutzer-Profile anzeigen

ThoRie
Forum-Fortgeschrittener
Forum-Fortgeschrittener

Beiträge: 83
Anmeldedatum: 12.05.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 14.05.2019, 13:49     Titel:
  Antworten mit Zitat      
Also, ich habe jetzt mal nachgesehen und eine "Anleitung" direkt in der Dokumentation von Miktex 2.9 gefunden. Dort steht auf Seite 11:


    You can control a number of run-time parameters (in particular, array sizes) on the command-line or in
    a configuration file.
    Some of the more interesting paramaters:
    main_memory Total words of memory available, for TeX, METAFONT, and MetaPost.
    extra_mem_bot Extra space for large TeX data structures: boxes, glue, breakpoints, et al.
    font_mem_size Words of font info available for TeX.
    See Chapter 10, Run-Time Defaults, for a complete list of the TEXMF run-time parameters.
    Here is a typical example of a configuration file:
    main_memory=2000000
    extra_mem_bot=2000000
    font_mem_size=2000000
    The name of the configuration file is that of the engine (e.g., miktex-pdftex) or format (e.g, miktexpdflatex).
    You use the --edit-config-file option of initexmf to edit the configuration file, e.g.:
    > initexmf --edit-config-file=pdflatex
    >

Nun bin ich aber kein Programmierer und weiß nicht wo ich das eingeben muss. Soll heißen: Ich brauche wirklich bitte eine Detailierte Anleitung, wo ich da was wie eingeben muss :/
Private Nachricht senden Benutzer-Profile anzeigen

ThoRie
Forum-Fortgeschrittener
Forum-Fortgeschrittener

Beiträge: 83
Anmeldedatum: 12.05.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 14.05.2019, 14:08     Titel:
  Antworten mit Zitat      
Okay, hat sich geklärt.

Ich bin gerade einem Kommilitonen über den Weg gelaufen, der wusste, wie das geht.
Ich schreib mal schnell hier die Anleitung rein, damit andere mit diesem Problem, vielleicht besser klar kommen Smile

    1. Öffnen der Miktex Console.
    2. Auswählen des Kommando-Fensters.
    3. Eingabe: initexmf --edit-config-file=pdflatex.
    4. Eingabe im neuen Fenster: main_memory=50000000
    extra_mem_bot=5000000

    5. Speichern und fertig.


Eventuell müssen die Zahlen für den individuellen Fall angepasst werden. Das sind jetzt nur die, die ich mir habe einstellen lassen.
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de