Jureco-Stil: Jahreszahl aus Zitat entfernen

Erstellung eines Literaturverzeichnisses mit BibTeX, Biber, BibLaTeX und Co.


Firefighter90
Forum-Newbie
Forum-Newbie
Beiträge: 3
Registriert: So 12. Aug 2018, 15:39

Jureco-Stil: Jahreszahl aus Zitat entfernen

Beitrag von Firefighter90 »

Hallo liebe Leute,

für meine Abschlussarbeit brüte ich über einem Problem bzgl. des Auftauchens der Jahreszahl im Literaturverzeichnis sowie in Zitaten. Mit dem Stil jureco aus dem Jurabib-Paket bin ich eigentlich schon auf einem sehr guten Wege. Im Literaturverzeichnis taucht die Jahreszahl hinter den Autoren auf, so wie es sein soll.

Jedoch möchte ich, dass diese in einem Zitat nicht automatisch mitgenannt wird! Ein Zitat im Fließtext soll nur lauten "Nachname und Nachname".
(Jahreszahl füge ich manuell in den Text ein, da die Uni mal Klammern drumrum, mal ein Komma davor fordert.)

Hier mein Minimalbeispiel:

Code: Alles auswählen

\documentclass[a4paper, 12pt]{scrreprt}
\usepackage[paper=a4paper, left=25mm, right=25mm, top=30mm, bottom=20mm, headsep=12.5mm]{geometry}

\usepackage[ngerman]{babel}
\usepackage[ansinew]{inputenc}
\usepackage{blindtext}

\usepackage[authorformat=and, authorformat=abbrv, dotafter=bibentry]{jurabib} %Zitationspaket
\renewcommand{\bibfnfont}{} %Vorname nicht fett
\renewcommand{\biblnfont}{} %Nachname nicht fett
\renewcommand{\bibefnfont}{} %dito für Herausgeber
\renewcommand{\bibelnfont}{}
\renewcommand{\bibbtasep}{, } %richtige Trennung von Autoren im Literaturverzeichnis
\renewcommand{\bibbfsasep}{, }
\renewcommand{\bibbstasep}{, }
\renewcommand{\bibansep}{. } %Trennungszeichen nach Autor
\renewcommand{\bibatsep}{. } %Trennungszeichen nach Titel
\setlength{\jbbibhang}{1.25cm} %Einzug der zweiten Zeile eines Eintrags


\begin{document}

\tableofcontents
\clearpage

\chapter{Erstes Kapitel}
\section{Erstes Unterkapitel}

Hallihallo, hiermit teste ich die Zitierweise nach \cite{gg90}, um zu sehen, wie die Jahreszahl verarbeitet wird.~\\
\blindtext

\clearpage

\addcontentsline{toc}{section}{Literatur}
\bibliography{literatur}
\bibliographystyle{jureco}

\end{document}
Durch das Fehlen von authorformat=year dürfte die Jahreszahl doch im Zitat nicht mehr auftauchen, sie tut es aber trotzdem. Auch durch Deklaration eines shortauthor in der .bib-Datei löst sich das nicht. Weiß von euch jemand eine Möglichkeit?

Schöne Grüße,
Firefighter
:)

PS: Der Eintrag im Literaturverzeichnis sieht exakt so aus, wie er sein muss, daher würde ich ungern auf natbib, biblatex etc umsteigen. Es geht rein um die Jahreszahl im Zitat.
Dateianhänge
literatur.bib
Dies ist die Datei mit den Literaturdaten.
(246 Bytes) 125-mal heruntergeladen

Gast

Off-Topic

Beitrag von Gast »

[d]jurabib[/d] hat nie Version 1 erreicht, wird seit 14 Jahren nicht mehr gepflegt und ist auch sonst ziemlich speziell. Ich fürchte fast, dass es nicht leicht wird, jemanden zu finden, der sich damit noch gut auskennt.

BTW: Option ansinew für inputenc ist fast so antiquiert. Achte beim Hinzufügen neuer Dateien zu dieser Vorlage unbedingt darauf, den Editor korrekt einzustellen. Alle mir bekannten, aktuellen LaTeX-Editoren verwenden nämlich in der Voreinstellung utf8. Das führt dann mit \usepackage[ansinew]{inputenc} zu Codierungsfehlern und teilweise auch zu Fehlermeldungen, wenn man den Editor nicht explizit umstellt.

Verwende außerdem keinesfalls \\ am Ende eines Absatzes – eigentlich im normalen Text überhaupt nicht. Richtige Absätze macht man mit Leerzeile im Quelltext oder \par. \clearpage unmittelbar vor \chapter ist übrigens überflüssig. Und das Literaturverzeichnis fügt man bei Verwendung von [d]scrreprt[/d] normalerweise einfach per Option bibliography=totoc ins Inhaltsverzeichnis ein. Und dann wird das auch korrekt ein Kapiteleintrag.

Firefighter90
Forum-Newbie
Forum-Newbie
Beiträge: 3
Registriert: So 12. Aug 2018, 15:39

Beitrag von Firefighter90 »

[i]bibliography=totoc[/i] habe ich auch in der Dokumentenklasse so stehen, ich wollte das Minimalbeispiel bloß so einfach wie möglich halten, gleiches gilt für \\ im Fließtext, aber das ist alles offtopic ;)

Ursprünglich hatte ich auch nicht jurabib verwendet. Es zeichnete sich aber nach langen Recherchen hier im Forum ab, dass sich damit die Vorgaben der Uni am einfachsten und genauesten einstellen lassen.

Gast

Beitrag von Gast »

jurabib hat natbib-ähnliche Befehle, vielleicht reichen Dir also schon \citep, \citet, \citealt und \citealp, um Deinen Univorgaben mit Komma und Klammer gerecht zu werden. Wenn alle Stricke reißen, gibt es \citeauthor, das nur den Autor ausgibt.

Meiner Meinung nach ist es aber akut Käse, sich einen halbautomatischen Zitierstil hinzuwurschteln, bei dem man neben \citeauthor noch manuell das Jahr angeben soll. Dann kann man es auch fast gleich lassen.

Heutzutage würde ich zur Erstellung von Literaturverzeichnissen und merkwürdigen von Lehrstühlen geforderten und drakonisch durchgesetzten Zitiervorgaben meist biblatex mit biber empfehlen. Da gehen viele Sachen leichter als früher bei BibTeX und auch bei jurabib, obwohl es auch dort schwierig werden kann, total bekloppte Vorgaben umzusetzen.

Code: Alles auswählen

\documentclass[a4paper, 12pt]{scrreprt}
\usepackage[ngerman]{babel}
\usepackage[utf8]{inputenc}

\usepackage[authorformat=and, authorformat=abbrv, dotafter=bibentry]{jurabib} %Zitationspaket
\renewcommand{\bibfnfont}{} %Vorname nicht fett
\renewcommand{\biblnfont}{} %Nachname nicht fett
\renewcommand{\bibefnfont}{} %dito für Herausgeber
\renewcommand{\bibelnfont}{}
\renewcommand{\bibbtasep}{, } %richtige Trennung von Autoren im Literaturverzeichnis
\renewcommand{\bibbfsasep}{, }
\renewcommand{\bibbstasep}{, }
\renewcommand{\bibansep}{. } %Trennungszeichen nach Autor
\renewcommand{\bibatsep}{. } %Trennungszeichen nach Titel
\setlength{\jbbibhang}{1.25cm} %Einzug der zweiten Zeile eines Eintrags

\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@Book{gg90,
  title     = {Dies ist der Testtitel -- Nur ein einfacher Test},
  publisher = {Phantasie-Verlag},
  year      = {1990},
  author    = {Vincent Crabbe and Gregory Goyle},
  address   = {Lummerland},
shortauthor = {Crabbe und Goyle},
}
\end{filecontents}

\begin{document}
\cite{gg90}

\citep{gg90}

\citet{gg90}

\citealt{gg90}

\citealp{gg90}

\citeauthor{gg90}

\bibliographystyle{jureco}
\bibliography{\jobname}
\end{document}
Egal wie beispielig das Beispiel war, den Hinweis, dass ~\\ eigentlich nie das macht, was man machen sollte, kann ich mir hier nicht verkneifen.

Gast

Beitrag von Gast »

Ach noch was:

Code: Alles auswählen

shortauthor = {Crabbe and Goyle},
sollte hier überflüssig sein und ist nur ein Einfallstor für Fehler. Das solltest Du also idealerweise weglassen.

Firefighter90
Forum-Newbie
Forum-Newbie
Beiträge: 3
Registriert: So 12. Aug 2018, 15:39

Beitrag von Firefighter90 »

Danke, danke, danke!!! :D
Mit den Befehlen \citep, \citet usw. klappt es ohne großen Aufwand genau so, wie es sein soll! Leider tauchen sie in einer mit vorliegenden jurabib-Dokumentation nicht auf.

Aber was soll, Thema beantwortet :)

Gast

Beitrag von Gast »

In v0.6 sind sie in der deutschen [d]jbgerdoc[/d] und der englischen [d]jbendoc[/d] jeweils in Abschnitt 4.5 kurz vor Abschnitt 5 auf Seite 8 bzw. 7 erklärt. In der deutschen Version ist die zugehörige Tabelle etwas länger.

LatexAnfänger34
Forum-Newbie
Forum-Newbie
Beiträge: 5
Registriert: Mi 11. Nov 2020, 02:46

Re: Jureco-Stil: Jahreszahl aus Zitat entfernen

Beitrag von LatexAnfänger34 »

Danke für die ganzen Beispiele bezüglich des Zitieren. Nach denen habe ich schon lange gesucht!


Antworten