Markdown ist deaktiviert

Benutzeravatar
Stefan Kottwitz
Admin
Admin
Beiträge: 2187
Registriert: Di 8. Jul 2008, 00:39
Kontaktdaten:

Markdown ist deaktiviert

Beitrag von Stefan Kottwitz »

Hallo zusammen,

ich habe heute Markdown im Forum vorerst deaktiviert.

Ab und zu fiel es ja mal auf: da Markdown-Kürzel auch in Code-Blöcken interpretiert werden, kann das die Darstellung im Code-Editor verfälschen. Das kann ich leider nicht verhindern, Markdown weiß einfach nicht, ob es sich in einer Code-Umgebung befindet.

Code-Editor und Compiler und Code-Korrektheit ist wichtiger als die schöne Eingabe mit Markdown. Einige sehr aktive Forum-Mitglieder werden es vielleicht vermissen, auch ich. Dafür kriegt man keine unerwartet merkwürdigen Fehler mehr, wenn man Zeichen wie > im Code hat und Markdown das als Quoting interpretiert etc.

Einige Posts, in denen mittlerweile Markdown verwendet wurde, werden jetzt natürlich ohne Markdown gerendert. Darüber mache ich mir auch Gedanken. Ich weiß, Moewe verwendet es gern (sorry!). @MoeWe: Dafür hab ich das gewünschte Abstellen des URL-Verkürzens erledigt... und frühere Posts mit Dreifach-Backticks zeigen den Code auch immer noch als Editor-Block an (Beispiel), Link-Syntax ist in früheren Posts auch immer noch richtig dargestellt (Beispiel).

Sobald ich eine Lösung gefunden habe, baue ich Markdown gern wieder ein.

Ich hoffe, das ärgert euch nicht so. Ich bin damit selber nicht glücklich. Ich hoffe auf Euer Verständnis.

Als Referenzen für den Hintergrund (auch als Bookmarks, um da später wieder zu schauen, ob sich da was an Verbesserung tut): Stefan