goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

BibLaTeX gibt Fehlermeldungen; Problem mit Packageeinbindung

 

DerArbeitenschreiber
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 26.03.2017, 19:17     Titel: BibLaTeX gibt Fehlermeldungen; Problem mit Packageeinbindung
  Antworten mit Zitat      
Guten Abend.
Beim Versuch ein eigenes Literaturverzeichnis zu erstellen, bin ich anscheinend auf technische Probleme gestoßen. Sehen wir uns erst einmal das Beispiel an.

Code • Öffne in Overleaf

\documentclass{article}

\usepackage[ngerman]{babel}% Recommended
\usepackage[babel, german=quotes]{csquotes}% Recommended

\usepackage[style=numeric,backend=biber]{biblatex}

\bibliography{quellen}% Syntax for version

\begin{document}
   Toller Text aus meinem Lieblingsbuch\footcite{FotobuchWeltmeere} das ich soeben Zitiert habe.
   
   
   \printbibliography  

\end{document}
 


Ich möchte eigentlich nur einmal mein Literaturverzeichnis sehen. Das Footcite mache ich nur, weil manche Quelle behauptet, dass man zuerst Zitieren müsste damit eine Quelle im Verzeichnis erscheint. Nun, leider wirft gerade dieses Zitieren Probleme auf:

Zuerst einmal einen Blick auf das Dokument ohne das Zitat Kommando. Laut Meldung läuft der Prozess flüssig und problemlos ab. Es ist kein Literaturverzeichnis zu sehen (nicht einmal eine Überschrift)
Mit dem Zitat aber wird anscheinend mehrere Male hintereinander compiled, bevor ich letzlich mit einer weiteren Meldung "Prozess endete normal" abgewiesen werde. Darüber versteckt sich eine Fehlermeldung seitens BibTeX':

Code • Öffne in Overleaf

This is BibTeX, Version 0.99d (MiKTeX 2.9 64-bit)
The top-level auxiliary file: document.aux
I found no \citation commands---while reading file document.aux
I found no \bibdata command---while reading file document.aux
I found no \bibstyle command---while reading file document.aux
(There were 3 error messages)
 


Der PDF Output erstellt in der Tat eine Fußnote - Leider steht in dieser lediglich der Identifier FotobuchWeltmeere. Vom Literaturverzeichnis findet man weiterhin keine Spur.
Was ich für besonders seltsam erachte: Meine Umgebung "TeXStudio" meldet mir, nachdem ich über die Packagenamen csquotes und biblatex hovere, dass beide dieser Packages nicht gefunden wurden! Da stellen sich mir zwei Fragen:
Erstens, warum werden die fehlenden Packete nicht gleich mithilfe des MiKTeX Paketmanagers nachinstalliert?
Zweitens, warum weiß die IDE trotzdem, welche Kommandos zu welchem Package gehören, und markiert diese dementsprechend, wenn ich die usepackage Kommandos entferne?

Ich hoffe jemand hat eine Idee, dieses Problem zu lösen. Sollte es relevant sein, ist hier noch meine .bib Datei vorzufinden:

Code • Öffne in Overleaf

@book{FotobuchWeltmeere,
   author="Skerry, Brian and Arthus-Bertrand, Yann",
   title = "Der Mensch und die Weltmeere",
   year = "2013",
   translator = "Antoinette Gittinger and Ursula Held",
   publisher = "Knesebeck",
   location = "München",
   addendum = "Deutsche Erstausgabe",
   origlanguage = "langfrench"
}
 

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 26.03.2017, 19:29     Titel:
  Antworten mit Zitat      
Wenn 'der Prozess flüssig und problemlos ab[läuft]', dann sollten die Pakete Paket auf CTANbiblatex und Paket auf CTANcsquotes schon installiert und gefunden werden. Ich weiß nicht, was TeXstudio Dir beim Hovern anzeigt, aber wenn das Dokument bei LaTeX ohne Probleme (damit meine ich Fehlermeldungen; Warnungen bekommst Du sicher beim ersten Durchlauf, da kann man die aber noch ignorieren) durchläuft, dann darfst Du davon ausgehen, dass die Pakete sehr wohl 'gefunden werden'.

Dein eigentliches Problem ist, dass Du statt Paket auf CTANBiber BibTeX über Dein Dokument laufen lässt. Wenn Du backend=biber hast, dann musst Du auch Biber laufen lassen. Wie Du Deinen Editor (TeXstudio) dazu bringst, steht in Biblatex with Biber: Configuring my.....avoid undefined citations, die deutsche Version dieser Sammlung ist in den wichtigen Hinweisen, die Du gründlich lesen solltest, verlinkt.

BTW: Vielen Dank für das sorgfältig wirklich aufs Minimale reduzierte InfoMinimalbeispiel und die direkt mit angegeben Fehlermeldungen. Damit ist das Problem doch gleich viel schneller untersucht.

DerArbeitenschreiber
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 26.03.2017, 20:46     Titel:
  Antworten mit Zitat      
Vielen Dank für die Aufklärung.
Leider ist das Problem noch nicht gelöst. Ich habe biber nun in TeXStudio eingestellt, und erhalte über dem sauber laufenden Prozess eine neue Fehlermeldung:

Code • Öffne in Overleaf

Fehler: Eine Kommandoersetzung ungültig
    Eltern-Befehl: bibliography
    Hauptbefehl: bibliography
 


Ich habe nun auch einmal den Befehl \addbibresource{quellen.bib} ausprobiert, da dieser wohl moderner sein soll. Es ändert sich nichts. Weiterhin wird das Programm scheinbar mehrmals ausgeführt.

Während biber Anfangs, als ich TeXStudio eben noch nicht konfiguriert hatte, eine .blg Datei auslieftere, bleibt diese nunmehr aus.

Übrigends, da es in den verlinkten Materialien angesprochen wurde:
Ich habe auch versucht, per Kommandozeile mein Dokument mit biber zu verarbeiten. Nun..
"Der Befehl biber ist entweder falsch geschrieben oder konnte nicht gefunden werden." Das ist äußerst seltsam, denn biber ist ja offensichtlich installiert; wo sonst kommen die Fehlermeldungen her?

Außerdem: Nach einem kurzen Blick in den Befehle Tab bei der Konfiguration von TeXStudio, sehe ich, dass bei dem Dateipfad zu Biber <unbekannt> steht.
Nach etwas Suche habe ich einfach mal auf gut Glück biber.exe % in die Zeile gepastet. Die Fehlermeldung verschwindet dadurch, alles ist sauber.. Aber sie verschwindet auch wenn ich LoLxD in das Feld eintrage, also hat das wohl nicht viel zu sagen. Nun wird das Programm übrigens nur ein mal ausgeführt.

Ich weiß jetzt nicht, ob es noch einen Fehler in meinem Dokument/TexStudio Setup gibt, oder ob ich tatsächlich Biber, welches normalerweise in MikTeX inbegriffen sein sollte, installieren muss.. Soweit ich das gesehen habe, sind die Installationsvorgänge in LaTeX ja unverständlich kompliziert.

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 27.03.2017, 07:54     Titel:
  Antworten mit Zitat      
Nö, Installation ist ganz einfach. Paketmanager starten, Paket auswählen oder über die Suche suchen und dann auswählen. Installieren, fertig.

Update ist bei Multi-User-Installationen von MiKTeX ein wenig kompliziert, weil man immer sowohl ein Update über die Admin-Version des Update-Managers machen sollte als auch über die normale (User-Version) des Update-Managers. Hat man das einmal verstanden, ist es eigentlich auch ganz einfach.

Wenn man an einem Single-User-Rechner MiKTeX installiert, kann man sich das vereinfachen, indem man MiKTeX nicht für alle Anwender, sondern nur für diesen einen Anwender installiert. Dann gibt es auch nur noch einen Paketmanager und einen Update-Manager. Oder man installiert einmal als Admin einfach alles (und deinstalliert alle User-Pakete) und macht dann Updates auch nur noch über den Admin-Update-Manager.

Bei TeX-Live wird bereits in der Voreinstellung alles installiert.

Es gibt abgesehen von nicht korrekter Konfiguration des Editors (wie das richtig geht, findet man über den Link in den wichtigen Hinweisen) bei der biber-Installation zwei typische Fehler:
  • Aufgrund von total veralteten Tipps aus dem Internet wird eine manuelle Installation durchgeführt, die entweder von vornherein nicht zum System oder biblatex passt oder bei der nächsten Version von biblatex veraltet und dann vom unerfahrenen Computeranwender nicht mehr beherrscht werden kann.
  • biber ist im Admin-Paketmanager installiert, biblatex wurde aber später on-the-fly vom User-Paketmanager installiert. Die Versionen passen jetzt nicht zusammen und der Anwender versteht nicht, dass er sowohl einmal ein MiKTeX-Update mit dem Admin-Paketmanager als auch mit dem User-Paketmanager durchführen muss.

u_fischer
Forum-Meister
Forum-Meister

Beiträge: 3400
Anmeldedatum: 22.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 27.03.2017, 10:39     Titel:
  Antworten mit Zitat      
Konzentriere dich nicht zu sehr auf die Meldungen von texstudio. Das Programm ist manchmal etwas zu übereifrig und gibt verwirrende Meldungen aus. Wenn du testen willst, ob biber da ist: Gehe zum tools-Menü und dort auf "Terminal öffnen". Gib dort dann

biber --version

ein und drücke enter.
_________________

Ulrike Fischer
www.troubleshooting-tex.de
Private Nachricht senden Benutzer-Profile anzeigen

Vollidiot #12
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 27.03.2017, 14:46     Titel: Installieren von biber?
  Antworten mit Zitat      
u_fischer hat Folgendes geschrieben:
Gehe zum tools-Menü und dort auf "Terminal öffnen". Gib dort dann

biber --version

ein und drücke enter.


Wie schon gesagt, wird das Command "biber" nicht vom Terminal erkannt. Also scheint biber nicht installiert zu sein.

Irgendein Gast hat Folgendes geschrieben:

Nö, Installation ist ganz einfach. Paketmanager starten, Paket auswählen oder über die Suche suchen und dann auswählen. Installieren, fertig.

Wenn es doch immer so einfach wäre. Man sehe sich mal das Packet picins an, welches der Paketmanager bei mir nicht anständig installiert kriegt - aus welchem Grund auch immer, der Fehler trat bisher nur bei diesem Paket auf.
Angeregt von deiner Idee habe ich aber trotzdem versucht, mit dem Packagemanager außerhalb von TeXStudio zu arbeiten. Beim installieren von picins gibt er mir zum Beispiel "Unknown archive file size." zurück. Nun gut; andere Packages gehen ja zum Glück.

Zurück zum Thema: Biber ist dort jedenfalls nicht zu finden. Das würde mich auch wundern, denn eigentlich ist biber doch ein standalone Programm, das im Hintergrund genutzt wird, oder etwa nicht?
Ich finde einen Download auf [url]dieser Website[/url], der mir einem .exe Installer für Biber 2.6 anbietet. Dieser soll aber nur mit BibLaTeX 3.5 zusammen funktionieren!

Ich würde ja einfach mal auf gut Glück probieren, biber.exe zu installieren, um zu schauen ob ich die passende Version erwischt habe. Dazu musste ich jetzt erstmal cygWin herunterladen und installieren, denn damit läuft der Installer wohl - leider werde ich nun mit dem Fehler "Das Programm kann nicht gestartet werden, da cygwin.dll auf dem Computer fehlt" abgespeist. Natürlich habe ich schon probiert, sowohl cygWin64bit als auch 32bit zu installieren, ohne Erfolg.

Ich habe langsam das Gefühl, dass dieses Thema hier in "Software" verschoben werden müsste, denn genau das wird wohl das Problem sein.

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 27.03.2017, 15:03     Titel:
  Antworten mit Zitat      
Nein, nein, nein. Bitte lade Biber nicht manuell herunter und versuche nicht, es selbst zu installieren. Das wurde Dir aber doch schon explizit gesagt.

Deine Annahme, dass es im Paketmanager nicht dabei ist, ist schlichtweg falsch. (Auch einige andere Tools/standalone-Programme sind dort zu finden. Es gibt dort nicht nur .sty-Pakete.) Bevor du fortfährst, mache ein Update mit 'MikTeX Update' zunächst im User- und dann im Admin-Modus ('MikTeX Update (Admin)'). Dann öffnest Du den Package Manager (wohl besser im Admin-Modus) und suchst in der Suchmaske ('Name') nach 'biber', ich finde da zur Zeit genau ein Paket: miktex-biber-bin-x64, je nach Version heißt das vielleicht nach dem letzten Bindestrich anders. Dieses Paket solltest Du installieren. Danach machst Du nochmal (sicher ist sicher) ein Update. Dann sollte zumindest biber --version funktionieren.

DerArbeitenschreiber
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 27.03.2017, 18:32     Titel: Fortschritt
  Antworten mit Zitat      
Danke soweit.
Ich hätte ja gerne die ganzen Packages bei mir geuptdated.. aber leider ist der MikTeX Update Manager entweder grausig programmiert, aus irgendwelchen Gründen falsch konfiguriert (falls sowas überhaupt gehen sollte), oder ich bin doch nicht klug genug einen Computer richtig zu verwenden. Jedenfalls ist es so, dass der Update Manager den Button "Select All" ausgegraut hat, und ich jedes Kästchen einzeln anklicken müsste.. und das muss doch wohl wirklich nicht sein..
Wer's mir nicht glaubt, darf sich einmal dieses Bildschirmfoto hier ansehen:


[spoiler]

[/spoiler]

Wenn ich übrigends versuche, ein manuell angeklicktes Kästchen wieder dezuselecten, kriege ich den Fehler "This package is currently installed for all users. Only the admin variant of the wizard can update this package."

Wie auch immer, nachdem ich testweise irgendein Package geuptdated habe und nochmal im Packetmanager gesucht habe, fand ich tatsächlich biber. Womöglich war ich vorher schon zu unfähig, biber bei wenigstens einem von drei Malen richtig einzutippen.

Die Version in der Kommandozeile gibt mir biber version: 2.7 zurück. Nachdem ich TeXStudio noch einmal konfiguriert habe, wird auch biber erkannt und ich kann wohl loslegen.


Tatsächlich funktioniert biber jetzt, und das ist sehr schön. Zumindest kann ich damit einen Beispielcode einwandfrei kompilieren!

Bei meinem speziellen Beispiel gibt es aber zwei Probleme:
Das Minimalbeispiel am Threadanfang habe ich nicht verändert, und auch die Datenbank bleibt gleich.
Beim Compilen stößt LaTeX erstens auf den Fehler "Undefined Control Sequence" auf Zeile 15 (direct nach \printbibliography). Nach testweisem Löschen von Einträgen komme ich zu dem Schluss, dass der Eintrag location = "München", für dieses Problem sorgt. Ohne ihn gibt es keine Meldungen. Es ist auch offensichtlich, dass da etwas nicht stimmen kann; es wird nämlich "Mfffdfffdnchen" gedruckt.
Weiterhin wird bei mir "fromlangfrench" statt "aus dem Französischen" gedruckt. Während ich, nachdem ich München gelöscht habe, keine Fehlermeldungen erhalte, bekomme ich MIT München in der Datenbank auch hierzu eine Warnung: "Bibliography string 'fromlangfrench' undefined(biblatex) at entry 'FotobuchWeltmeere'"

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 27.03.2017, 18:45     Titel: Re: Fortschritt
  Antworten mit Zitat      
DerArbeitenschreiber hat Folgendes geschrieben:
Wenn ich übrigends versuche, ein manuell angeklicktes Kästchen wieder dezuselecten, kriege ich den Fehler "This package is currently installed for all users. Only the admin variant of the wizard can update this package."

Die Meldung ist doch eindeutig! Für Pakete, die über den Admin-Paketmanager installiert sind, muss man für das Update auch den Admin-Updatemanager verwenden. Siehe auch: http://golatex.de/viewtopic,p,91855.html#91855

Bei einer echten Mulit-User-Installation würde sich der Admin bedanken, wenn Hinz und Kunz seine Dateien mal eben ersetzen könnten.

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 27.03.2017, 18:49     Titel:
  Antworten mit Zitat      
Wenn Du Dateien in UTF8-Kodierung verwendest, solltest Du entweder
Code • Öffne in Overleaf
\usepackage[utf8]{inputenc}
oder eine Engine mit nativer UTF8-Unterstützung verwenden.

Vielleicht solltest Du Dir einmal eine gute LaTeX-Einführung besorgen und die gründlich durcharbeiten.

Neues Thema eröffnen Neue Antwort erstellen Gehe zu Seite 1, 2  Weiter



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2017 goLaTeX.de