Probleme mit dem Package

Alles rund um das System für Windows.
w.zeiml
Forum-Newbie
Forum-Newbie
Beiträge: 2
Registriert: Mi 15. Jan 2020, 11:34

Probleme mit dem Package

Beitrag von w.zeiml »

Liebe Forum-Mitglieder,

ich habe ein Problem mit der Dokumentenklasse "Uebungsblatt".

Package-Dokumentation:
http://www.bakoma-tex.com/doc/latex/ueb ... tt-doc.pdf

Ich habe wie in der Beschreibung folgendes erledigt:
- Das AkkTex Bundle runtergeladen (www.AkkTeX.org)
- Dieses Bundle in den MikTex-Ordner verschoben und in der MikTex-Console die Pakete upgedatete (Refresh file name database)
- Ich habe die lv.tex Datei wie beschrieben in einen Überordner angelegt und dann versucht im selben Order ein Übungsblatt zu erstellen. Dies geschieht laut Beschreibung einfach mit...

\documentclass{uebungsblatt}
\begin{document}
...
\end{document}

Leider erhalte ich hier eine Menge Fehlermeldungen... Ein Minimal-Beispiel ist hier nicht notwendig, da es ehr darum geht die Dokumentenklasse zum Laufen zu bringen...

Hat jemand Erfahrung mit diesem Package? Was hab ich falsch gemacht?

LG W.Z.
Dateianhänge
Laut MikTex Console wurde das AkkTex Paket eingebunden
Laut MikTex Console wurde das AkkTex Paket eingebunden
01.JPG (36.58 KiB) 473 mal betrachtet
Fehlermeldungen...
Fehlermeldungen...
Fehler_01.JPG (137.51 KiB) 475 mal betrachtet

oft gesehener

Beitrag von oft gesehener »

Mit einen Screenshot von ein paar Fehlermeldungen aus dem Editor ist es leider sehr schwer, etwas vernünftiges zu sagen. Es sieht für mich aber so aus, als wäre die Klasse durchaus installiert würde aber einen Fehler melden. Um mehr sagen zu können, bräuchte ich durchaus ein Minimalbeispiel und die zugehörige log-Datei. Grundsätzlich ist es immer besser ein Minimalbeispiel anzugeben und die Fehlermeldungen komplett aus der log-Datei zu kopieren statt irgendwelche Screenshots anzufertigen. Das macht auch nicht wirklich mehr Arbeit. Dafür kann man sich viele Rückfragen und Diskussionen sparen und kommt oft schneller zu einem definitiven Ergebnis statt solcher Wischi-Waschi-Antworten wie dieser.

BTW: Kann es sein, dass es sich bei dem Paket um uebungsblatt handelt? In dem Fall würde ich einfach empfehlen, nicht irgendwo irgendwas runterzuladen und irgendwie herumzuschieben, sondern das Paket einfach über die MiKTeX Console zu installieren, wie das für Pakete, die als MiKTeX-Paket verfügbar sind, in der Regel die beste Lösung ist.

In dem Fall würde ich von dem ganzen aber eher abraten. So lädt beispielsweise uebungsblatt.sty tatsächlich inputenc mit Option latin1. Da die Codierung der Datei nicht von der Verwendung des Pakets uerbungsblatt, sondern von Einstellungen des Editors abhängig ist, ist das Unfug und Probleme mit der Voreinstellung aktueller LaTeX-Editoren sind vorprogrammiert. Ich würde daher eher zu einem modernen Paket wie xsim raten.

Ratgeber

Re: Probleme mit dem Package

Beitrag von Ratgeber »

Klassen und Pakete für Übungsblätter gibt es auf CTAN schon genug. Die funktionieren dann auch ohne lästiges Gefrickel nebenbei und sind auch nicht so veraltet.

Naja

Re: Probleme mit dem Package

Beitrag von Naja »

Ratgeber hat geschrieben:Klassen und Pakete für Übungsblätter gibt es auf CTAN schon genug.
Das sind eher Klassen für Prüfungen. Es gibt auch Pakete für Übungen. Das bereits erwähnte xsim ist in beiden Bereichen zu finden.
Ratgeber hat geschrieben:Die funktionieren dann auch ohne lästiges Gefrickel nebenbei und sind auch nicht so veraltet
Das gilt allerdings nicht für alle Pakete auf CTAN und weder für alle Pakete in der Übersicht für Prüfungen noch in der Übersicht für Übungen. In letzterem Bereich ist schließlich auch das Paket uebungsblatt zu finden, wie man leicht feststellen kann. Mit derartigen Pauschalurteilen wäre ich also vorsichtig. Ich würde eher sagen, dass sich unter den dort gelisteten Paketen auch besser gepflegte und empfehlenswertere Pakete von Leuten finden, die wirklich Ahnung vom Paketeschreiben haben. Das bereits genannte xsim gehört mit Sicherheit dazu.

w.zeiml
Forum-Newbie
Forum-Newbie
Beiträge: 2
Registriert: Mi 15. Jan 2020, 11:34

Vielen Dank!

Beitrag von w.zeiml »

Vielen Dank schon mal für die Rückmeldungen. Entschuldigt, dass ich dem Minimalbeispiel nicht nachgekommen bin. Bin absoluter Neuling und wüsste jetzt auch nicht, wie ich so ein Mininmalbeispiel exportiere,...

Ich seh mir das Paket xsim mal etwas genauer an,... das andere Paket dürfte so seine Schwierigkeiten haben,...

Danke nochmal! Liebste Grüße W.Z.

Gast

Beitrag von Gast »

Wie man ein Minimalbeispiel erstellt, steht in der Minimalbeispiel-Anleitung, die hier schon mehrfach verlinkt wurde. Das ist dort so ausführlich erklärt, dass sich sogar schon Leute darüber beschwert haben, es wäre zu ausführlich. Und trotzdem beschweren sich auch immer wieder Leute, dass sie nicht wüssten, wie sie ein Minimalbeispiel erstellen sollen.

Exportieren muss man das dann nicht extra. Man fügt es hier einfach per Copy&Paste in die Frage ein und markiert es entsprechend. Wobei ich gerade sehe, dass sogar die Art der Markierung, die hier verwendet wird, bereits in der Minimalbeispiel-Anleitung erwähnt wird, aber nicht ganz so ausführlich wie hier.

Du bist übrigens nicht der erste Anfänger. Gehe also ruhig davon aus, dass die meisten hier im Forum sich irgendwann da durch kämpfen mussten und für vieles Anleitungen (wie die beiden verlinkten) vorhanden sind. Auch auf die Idee, sie bräuchten kein Minimalbeispiel sind schon viele gekommen und bei fast allen mündete das in einer ähnlichen Diskussion oder hat sich sonst als großer Irrtum herausgestellt.

Antworten