goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 100866
Top-Poster: Johannes_B (5067)

Wir begrüßen unseren neuesten Benutzer k-S.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Style alphabetic ergänzt ein +, warum?

 

poeddl
Forum-Newbie
Forum-Newbie

Beiträge: 2
Anmeldedatum: 16.01.20
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 16.01.2020, 13:39     Titel: Style alphabetic ergänzt ein +, warum?
  Antworten mit Zitat      
Hallo,
ich bin blutiger Anfänger, was Latex angeht, darum entschuldigt bitte meine zwei vielleicht dummen Fragen.

1. Wenn ich mittels biber / biblatex einen Verweis in meinem Text angeben möchte mittels Stil alphabetic, dann erscheinen immer die drei ersten Buchstaben des Autos (Nachname), dann ein + und schließlich die Jahreszahl der Veröffentlichung. Woher kommt dieses + und wie bekomme ich es weg?
In diesem Fall (siehe unten) also [Kra+13], ich erwarte aber [Kra13]

2. Wenn ich eine Quelle zitieren möchte mit einem anderen Stil, beispielsweise authoryear, wie kann ich dort
    a) die runden Klammern zu eckigen machen und
    b) das u.a., wenn es sich um mehrere Autoren handelt weglassen? (nur aus Interesse)


Anbei mein Code.
Ich würde mich über eine Hilfestellung sehr freuen, leider konnte ich in der Dokumentation nichts finden, was meine Fragen beantwortet.

Viele Grüße und einen schönen Tag! Smile

EDIT: Ich habe gerade herausgefunden, dass das + dadurch zustande kommt, dass es mehrere Autoren gibt.
Gibt es eine Möglichkeit das zu unterbinden?


Code
\documentclass[a4paper, 11pt]{scrartcl}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[ngerman]{babel}
\usepackage{lmodern}
\usepackage{amsmath,amssymb,amstext}
\usepackage{graphicx}

\usepackage[babel, german=guillemets]{csquotes}
\usepackage[backend=biber, style=authoryear]{biblatex}
\addbibresource{Quellen/Masterarbeit.bib}

\title{Märchen und andere Geschichten}
\author{Max Mustermann}
\date{\today{}, Berlin}

\begin{document}

Nach \cite{Kramer2013} ist das so.

\printbibliography
\end{document}
 



Code
@Book{Kramer2013,
  title         = {Integrale Sicherheit von Kraftfahrzeugen: Biomechanik - Simulation - Sicherheit im Entwicklungsprozess
},
  publisher     = {Springer Fachmedien Wiesbaden},
  year          = {2013},
  author        = {Kramer, F. and Franz, U. and Lorenz, B. and Remfrey, J. and Sch{\"o}neburg, R.},
  series        = {ATZ/MTZ-Fachbuch},
  isbn          = {9783834826084},
}
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 16.01.2020, 14:03     Titel:
  Antworten mit Zitat      
Klammern ersetzen geht übrigens mit biblatex-ext sehr einfach. Das hat Moewe AFAIK erst kürzlich erklärt.

Bartman
Forum-Meister
Forum-Meister


Beiträge: 2011
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: ---
     Beitrag Verfasst am: 16.01.2020, 14:11     Titel:
  Antworten mit Zitat      
Der Gast meint vermutlich diesen Beitrag.

Ändere den Befehl \labelalphaothers, um das Pluszeichen zu entfernen.

Seit dem August 2019 darfst Du für den Stil authoryear die Option nohashothers verwenden.
Private Nachricht senden Benutzer-Profile anzeigen

poeddl
Forum-Newbie
Forum-Newbie

Beiträge: 2
Anmeldedatum: 16.01.20
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 19.01.2020, 15:05     Titel:
  Antworten mit Zitat      
@Bartman
Hättest du evtl. ein Codebeispiel, wie ich das nohashoters einbinden muss?
Meine Versuche sind kläglich gescheitert und bei Google finde ich nicht sonderlich viel.

Danke für deine Mühe!
Private Nachricht senden Benutzer-Profile anzeigen

Bartman
Forum-Meister
Forum-Meister


Beiträge: 2011
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: ---
     Beitrag Verfasst am: 19.01.2020, 15:18     Titel:
  Antworten mit Zitat      
Das ist eine Option des Pakets biblatex. Sie ist in dessen Dokumentation zu finden.
Private Nachricht senden Benutzer-Profile anzeigen

MoeWe
Forum-Century
Forum-Century

Beiträge: 112
Anmeldedatum: 30.08.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 19.01.2020, 15:19     Titel:
  Antworten mit Zitat      
nohashothers allein bringt keinen großen sichtbaren Effekt, man braucht noch zusätzlich etwas Arbeit (z.B. https://tex.stackexchange.com/q/262612/35864). Was genau möchtest Du denn jetzt erreichen? In Deinem Eingangsbeitrag sind ja mehrere Dinge erwähnt.

Wie das + bei style=alphabetic weg geht hatten wir ja schon
Code
\documentclass[ngerman]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{lmodern}
\usepackage{babel}
\usepackage{csquotes}

\usepackage[style=alphabetic, backend=biber]{biblatex}

\renewcommand*{\labelalphaothers}{}

\addbibresource{biblatex-examples.bib
}


\begin{document}
\autocite{sigfridsson,aksin}
\printbibliography
\end{document}
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2020 goLaTeX.de