[T1]{fontenc} produziert kein

Redefinition von Makros, Definition eigener Befehle sowie neuer Umgebungen


losgehts

[T1]{fontenc} produziert kein

Beitrag von losgehts »

Hallo allerseits,

sobald ich

Code: Alles auswählen

\usepackage[T1]{fontenc}
verwende, wird in der Pdf-Datei ein Zeichen erzeugt, dass ein wenig wie ein scharfes S aussieht, aber (vom pdf-Viewer "summatra") nicht über die Suchfunktion gefunden werden kann (andere Viewer habe ich nicht getestet). Auch wenn ich aus dem erzeugten Pdf heraus kopiere, wird statt dem ß ein ÿ (U+00FF) kopiert. Ich würde mir U+00DF (ß) wünschen.

Mein Minimalbeispiel:

Code: Alles auswählen

\documentclass{scrartcl}
\usepackage[ngerman]{babel}
\usepackage[T1]{fontenc} 

\begin{document}
Das scharfe S \ss wird nicht gefunden. Und dießes auch nicht. Aber das ö ist nüt a Probläm.
\end{document}
Die tex-Datei ist in utf-8 codiert und ich arbeite mit Miktex 2.9 (habe heute nochmals alle Pakete aktualisiert) und benutze pdflatex.exe.

Ich hoffe, ich habe alles wichtige aufgeführt, ansonsten bitte einfach nachfragen!

Weiß jemand Abhilfe, ich möchte gerne eine durchsuchbare pdf-Datei?

Auch selinput

Code: Alles auswählen

\documentclass{scrartcl}
\usepackage[ngerman]{babel}
\usepackage{selinput}
\SelectInputMappings{
	adieresis={ä},
	germandbls={ß},
}
\usepackage[T1]{fontenc} 

\begin{document}
Das scharfe S \ss wird nicht gefunden. Und dießes auch nicht. Aber das ö ist nüt a Probläm.
\end{document}
habe ich ausprobiert, das führt bei mir zum selben Problem.

Herrscht nur bei mir das Problem? Weiß jemand Rat?

Vielen Dank im Voraus!

Viele Grüße,
Ulrich

Gast

Beitrag von Gast »

Getestet mit pdflatex unter (aktuellem) TeX Live 2019 und mit okular: ß wird problemlos gefunden und auch als solches aus der Datei kopiert: „Das scharfe S ßwird nicht gefunden. Und dießes auch nicht. Aber das ö ist nüt a
Probläm.”

Aber du kannst ja mal cmap probieren. Vielleicht hilft das bei dir.

Ratgeber

Höhere Qualität

Beitrag von Ratgeber »

Eine andere Schrift könnte das Problem beseitigen. An erster Stelle steht da erst mal Latin Modern. Liegt vielleicht aber auch einer möglicherweise veralteten Version von »Sumatra PDF« liegen.

losgehts

[T1]{fontenc} produziert kein scharfes S => gelöst

Beitrag von losgehts »

Hallo,

vielen Dank für eure Antworten!

cmap funktioniert bei mir und auch

Code: Alles auswählen

\usepackage{lmodern}

Ich entscheide mich für lmodern - einfach aus dem Bauch heraus :-).

Vielen Dank für eure Hilfe!

Viele Grüße,
Ulrich

Antworten