Hyperref und Pdfpages

Inhalt, Abbildungen, Tabellen, Quellcodes und andere Verzeichnisse


karl-heinz
Forum-Anfänger
Forum-Anfänger
Beiträge: 49
Registriert: Sa 14. Mär 2009, 17:50

Hyperref und Pdfpages

Beitrag von karl-heinz »

Hi,

ich suche nach einer Möglichkeit, meine aus mehreren pfds bestehende Bewerbung, erstellt mit verschiedenen Dokumentenklassen, zu einem pdf zusammenzufügen, und gleichzeitig Hyperlinks zu den einzelnen Teilen zu haben. Genauer: Ich habe ein Deckblatt, auf welchem die einzelnen Teile der Bewerbung aufgeführt sind (im Beispiel: dok1, dok2, dok3), und möchte halt die Liste der Bewerbungsteile auf dem Deckblatt zu den entsprechenden Teilen verlinken.

Ich habe ein wenig mit dem Paket pdfpages rumprobiert, komm aber irgendwie nicht auf nen grünen Zweig, weil ich die Hypertext-Otions in der pdfpages-Doku schlichtweg nicht verstehe und entsprechend keinen Ansatzpunkt habe... Hat da jemand eine Idee?

Liebe Grüße und danke

Karl-Heinz

[code]
\documentclass{minimal}

\usepackage{pdfpages}
\usepackage{hyperref}

\begin{document}

\begin{itemize}
\item dok1 % wenn man im pdf dann hier draufklickt, soll man entsprechend zum dok1 kommen
\item dok2
\item dok3
\end{itemize}

\includepdf[pages={1}]{dok1.pdf}
\includepdf[pages={1}]{dok2.pdf}
\includepdf[pages={1}]{dok3.pdf}
\end{document}
[/code]

esdd
Forum-Meister
Forum-Meister
Beiträge: 2491
Registriert: So 7. Feb 2010, 16:36

Beitrag von esdd »

Hallo,

hier ist ein Vorschlag:

Code: Alles auswählen

\documentclass{article} 

\usepackage{pdfpages} 
\usepackage{hyperref} 

\begin{document} 

\begin{itemize} 
  \item \hyperlink{dok1.pdf.1}{dok1}
  \item \hyperlink{dok2.pdf.1}{dok2}
\end{itemize} 

\includepdf[pages={1},link=true]{dok1}
\includepdf[pages={1},link=true]{dok2}
\end{document}
Mit der Option link=true werden die eingefügten Seiten zu Sprungzielen für Hyperlinks. Die Marken lauten dabei "<dateiname>.<seitennummer>".
Gruß
Elke

karl-heinz
Forum-Anfänger
Forum-Anfänger
Beiträge: 49
Registriert: Sa 14. Mär 2009, 17:50

Beitrag von karl-heinz »

Hi,

super, klappt (wenn ich auch die eingefügten pdfs auf jeden Fall im gleichen Verzeichnis wie die tex-Datei haben muss), jetzt hab ich das mit diesen "Marken" auch glaube ich verstanden...

Allerdings werden jetzt die anderen Hyperref-Links (zu urls) der eingefügten pdfs ausgestellt, gibt es eine Möglichkeit, das die weiterhin funktionieren?

Alles Gute

Karl-Heinz

BTW: Warum wird mein Beispielcode nicht so schön dargestellt wie bei allen anderen, was mach falsch?

sudo
Forum-Guru
Forum-Guru
Beiträge: 459
Registriert: Mi 3. Okt 2012, 11:32

BBCode

Beitrag von sudo »

Hast du zufällig den BBCode deaktiviert? (Eine der Checkboxes bei den Nachrichtoptionen) Dann sieht das bei mir auch so aus:

[code]Hallo Welt![/code]

Ansonsten könnte ich mir nur vorstellen, das dein Browser da vielleicht herumpfuscht.

esdd
Forum-Meister
Forum-Meister
Beiträge: 2491
Registriert: So 7. Feb 2010, 16:36

Beitrag von esdd »

Hallo,

die einzufügenden pdfs können auch in einem Unterverzeichnis liegen. In dem Fall kann die Option linkname hilfreich sein.

Code: Alles auswählen

\begin{itemize} 
  \item \hyperlink{test.1}{dok1}
  \item \hyperlink{Dokumente/dok2.pdf.1}{dok2}
\end{itemize} 

\includepdf[pages={1},link=true,linkname=test]{Dokumente/dok1}
\includepdf[pages={1},link=true]{Dokumente/dok2}
In der Dokumentation von pdfpages steht, dass Links in den pdfs beim Einfügen verloren gehen. Außerdem ist da ein Hinweis auf das Paket pax.
Gruß
Elke

Gast

http links funktionieren, aber keine https links

Beitrag von Gast »

%test_1 hat https:// und http:// links
Daraus möchte ich nur die erste Seite behalten und benütze /includepdf - das neue Dokument test_2: hier funktioneren nur die http:// links, aber nicht die https://
Gibt es dafür eine Lösung?



\documentclass[paper=a4,paper=landscape,pagesize]{scrartcl}

\usepackage{pdfpages}
\usepackage{hyperref}
\hypersetup{
pdftitle={test_2},
pdfmenubar = true,
linkcolor=blue,
urlcolor=blue,
colorlinks=true,
}


\begin{document}
\includepdf[pages={1}, link=true]{test_1}
\end{document}

Antworten