Zeitangabe in URL-Quelle funktioniert nicht Thema ist als GELÖST markiert

Inhalt, Abbildungen, Tabellen, Quellcodes und andere Verzeichnisse


ichbinneu

Zeitangabe in URL-Quelle funktioniert nicht

Beitrag von ichbinneu »

Guten Tag,

ich möchte eine online-Quelle referenzieren. Biblatex 3.8
Der Eintrag in der .bib-Datei

@misc{oeis,
	url = "",
    urldate = "2021-09-24T14:25:00",
}

Dieser ergibt mir:
[Oei] URL: https://oeis.org/A129802.
Lasse ich die Zeitangabe weg, erscheint aber:
[Oei] URL: https://oeis.org/A129802 (besucht am 24.09.2021).

Hier mein MWE:

\documentclass[ngerman, fontsize=11pt, DIV=15, BCOR = 10mm, parskip=half-, twoside]{scrartcl}
\begin{filecontents}{quellen.bib}
@misc{oeis,
	url = "",
    urldate = "2021-09-24T14:25:00",
}
\end{filecontents}
\usepackage{babel}% sonst ist Option ngerman bei \documentclass sinnlos
\usepackage{amsthm}
\usepackage{amsmath}
\usepackage[backend=bibtex, style = alphabetic, natbib=true,  urldateusetime=true]{biblatex}
	\addbibresource{quellen.bib}


\begin{document}

Man findet die Folge unter \cite{oeis}

\printbibliography
\end{document}
Zuletzt geändert von Stefan Kottwitz am Sa 25. Sep 2021, 09:49, insgesamt 1-mal geändert.
Grund: quellen.bib als filecontents-Umgebung eingefügt für direkte Übersetzbarkeit im Forum-LaTeX-Compiler

Benutzeravatar
u_fischer
Forum-Meister
Forum-Meister
Beiträge: 4127
Registriert: Do 22. Nov 2012, 11:09
Kontaktdaten:

Re: Zeitangabe in URL-Quelle funktioniert nicht

Beitrag von u_fischer »

verwende biber. bibtex als Backend kann diverse Dinge nicht.


MoeWe
Forum-Meister
Forum-Meister
Beiträge: 622
Registriert: Fr 30. Aug 2019, 15:35
Kontaktdaten:

Re: Zeitangabe in URL-Quelle funktioniert nicht

Beitrag von MoeWe »

In der Tat. Das ist auch einer der Gründe, warum biblatex seit Jahren bei der Nutzung von backend=bibtex, die folgende Warnung ausgibt

Package biblatex Warning: Using fall-back BibTeX(8) backend:
(biblatex)                functionality may be reduced/unavailable.

Wichtige Funktionen, die sich mit vertretbaren Aufwand mit BibTeX nachbilden lassen, werden durchaus nach BibTeX portiert, aber es ist eben nicht alles so leicht nachzubilden.

So unterstützt BibTeX nur das einfache YYYYY-MM-DD/YYYY-MM-DD-Format und nicht die von Biber unterstützten Erweiterungen aus ISO 8601 wie Zeit, Jahreszeiten/Semester/Quartale/..., Unsicherheits- und Ungenauigkeitsmarker etc. Ich gehe davon aus, dass die überwältigende Mehrheit der Nutzer*innen aber mit YYYY-MM-DD/YYYY-MM-DD auskommt, daher lohnt es sich meiner Meinung nach nicht, den Aufwand zu investieren, auch die anderen Funktionen mühsam in BibTeX nachzubilden (schon der aktuelle Code ist nicht von Pappe).

Ich sehe heutzutage eigentlich fast keine guten Gründe mehr, mit biblatex noch backend=bibtex, statt backend=biber, zu nutzen. Sieh dieses Problem doch als Gelegenheit, den Schritt zu Biber zu wagen.


ichbinneu

Re: Zeitangabe in URL-Quelle funktioniert nicht

Beitrag von ichbinneu »

Ok, aber einfach

backend = biblatex

durch

backend = biber

zu ersetzen scheint nicht zu gehen. Ich kenne mich LaTeX und so leider gar nicht aus.
Ich hab' ja eine fertige .bib-Datei.
Was muss ich denn nun tun, wenn ich halt biber nutzen möchte?


MoeWe
Forum-Meister
Forum-Meister
Beiträge: 622
Registriert: Fr 30. Aug 2019, 15:35
Kontaktdaten:

Re: Zeitangabe in URL-Quelle funktioniert nicht

Beitrag von MoeWe »

Du solltest backend=bibtex, durch

backend=biber,

ersetzen und musst dann beim Kompilieren auch Biber statt BibTeX laufen lassen.

Wie letzteres geht, hängt davon ab, wie genau Du Dein Dokument kompilierst (z.B. über welchen Editor). Bei Overleaf muss man beispielsweise gar nichts ändern. Für viele Editoren findest Du Hilfe bei https://www.texwelt.de/fragen/1909/wie- ... nem-editor und https://tex.stackexchange.com/q/154751/35864.

Wenn es dann immer noch nicht geht, dann sollten LaTeX oder Biber mit einer Fehlermeldung erklären, warum es nicht geht. Sieh in der .log-Datei und der .blg-Datei nach.


ichbinneu

Re: Zeitangabe in URL-Quelle funktioniert nicht

Beitrag von ichbinneu »

Ok, ich habe mein Texniccenter gemäß https://texwelt.de/fragen/1909/wie-verw ... nem-editor eingestellt und es scheint zu gehen, bis auf zwei Dinge.

1) Für die oeis wird nur ein [] angezeigt
2) Wagstaff wird überhaupt nicht erzeugt.

\documentclass[ngerman, fontsize=11pt, DIV=15, BCOR = 10mm, parskip=half-, twoside]{scrartcl}
\usepackage[backend=biber, bibencoding=utf8, style = alphabetic, natbib=true,  urldateusetime=true]{biblatex}
\addbibresource{quellen.bib}
\begin{filecontents}{quellen.bib}
@book{wag,
	author = "Samuel S. Wagstaff, Jr.",
	title = "The Joy of Factoring",
	publisher = "The American Mathematical Society",
	year = "2013",
	address = "Rhode Island",
}

@misc{oeis,
	url = "https://oeis.org/A129802",
	urldate = "2021-09-24T14:25:00",
}
\end{filecontents}
\usepackage{babel}% sonst ist Option ngerman bei \documentclass sinnlos
\usepackage{amsthm}
\usepackage{amsmath}

\begin{document}

Man findet die Folge unter \cite{oeis} und das Buch unter \cite{wag}

\printbibliography
\end{document}

MoeWe
Forum-Meister
Forum-Meister
Beiträge: 622
Registriert: Fr 30. Aug 2019, 15:35
Kontaktdaten:

Re: Zeitangabe in URL-Quelle funktioniert nicht

Beitrag von MoeWe »

Der gewählte Stil alphabetic baut das Label aus author/editor/translator+date/year zusammen. Da der Eintrag oeis keines dieser Felder hat, gibt es folglich auch nichts, woraus biblatex das Label zusammenbasteln könnte. Ich schlage vor, die passenden Metadaten von der Seite abzulesen.

Zumindest hier im Forum wird bei wag auch etwas angezeigt. Dennoch solltest Du den Namen anders formatieren, damit er richtig verarbeitet wird. Siehe https://tex.stackexchange.com/q/557/35864.

Mit

\documentclass[ngerman, fontsize=11pt, DIV=15, BCOR = 10mm, parskip=half-, twoside]{scrartcl}

\usepackage{babel}
\usepackage{csquotes}

\usepackage[backend=biber, style = alphabetic, natbib=true,  urldateusetime=true]{biblatex}
\begin{filecontents}{\jobname.bib}
@book{wag,
  author    = {Wagstaff, Jr., Samuel S.},
  title     = {The Joy of Factoring},
  publisher = {The American Mathematical Society},
  year      = {2013},
  address   = {Providence},
}
@inreference{oeis:a129802,
  title      = {A129802},
  subtitle   = {Possible bases for {Pepin's} primality test for {Fermat} numbers},
  author     = {Max Alekseyev},
  date       = {2007-12-29},
  booktitle  = {The On-Line Encyclopedia of Integer Sequences},
  editor     = {N. J. A. Sloane},
  editortype = {founder},
  url        = {https://oeis.org/A129802},
  urldate    = {2021-09-24T14:25:00},
}
\end{filecontents}
\addbibresource{\jobname.bib}

\begin{document}
Man findet die Folge unter \autocite{oeis:a129802}
und das Buch unter \autocite{wag}

\printbibliography
\end{document}

geht es bei mir (und auch hier im Forum).


ichbinneu

Re: Zeitangabe in URL-Quelle funktioniert nicht

Beitrag von ichbinneu »

Ok, dann schaue ich gleich nochmal bei mir. Vielen Dank für die Hilfe!


Antworten