Fehler: The key '/tikz/line width' requires a value.

Tabellen und Grafiken erstellen und anordnen


M0M0
Forum-Anfänger
Forum-Anfänger
Beiträge: 24
Registriert: So 24. Nov 2019, 18:59

Fehler: The key '/tikz/line width' requires a value.

Beitrag von M0M0 »

Ich habe gestern die neuste TeXLive Version installiert, nun führt folgender Code zu einem Fehler:

Code: Alles auswählen

\documentclass{article}
\usepackage{chemfig}

\newcommand{\bondwidth}{0.06642 em} 
\setchemfig{bond style= line width = \bondwidth}

\begin{document}
	\chemfig{*6(-=-=-=)}
\end{document}

Die Fehlermeldung lautet:

Code: Alles auswählen

! Package pgfkeys Error: The key '/tikz/line width' requires a value. I am going to ignore this key.

Mit alten Versionen lief es hingegen problemlos durch, line width wird ja auch ein Wert zugeteilt. Dadurch kann ich im Moment an keinem Projekt sinnvoll weiterarbeiten.. Falls hier keiner eine schnelle Lösung kennt: Was ist denn der korrekte Weg um seien TeXLive Installation auf eine ältere Version zu downgraden?


M0M0
Forum-Anfänger
Forum-Anfänger
Beiträge: 24
Registriert: So 24. Nov 2019, 18:59

Re: Fehler: The key '/tikz/line width' requires a value.

Beitrag von M0M0 »

Ok, ich habe die Lösung selbst gefunden..

Code: Alles auswählen

\setchemfig{bond style= {line width = \bondwidth}}

Anstelle von

\setchemfig{bond style= line width = \bondwidth}

funktioniert, es muss also im Vergleich zu alten Versionen eine zusätzliche Gruppierung gesetzt werden


Antworten