PGF Contour Plot - Beim Übergang zu Achsen sind die Tic Labels weg

Tabellen und Grafiken erstellen und anordnen


Rolli
Forum-Guru
Forum-Guru
Beiträge: 345
Registriert: Mi 15. Feb 2017, 08:50
Wohnort: Mittelfranken

PGF Contour Plot - Beim Übergang zu Achsen sind die Tic Labels weg

Beitrag von Rolli »

Hi,

Bug oder Feature?

Code: Alles auswählen

\documentclass{scrartcl}
\usepackage{pgfplots}
\pgfplotsset{compat=1.17}
\begin{document}
\begin{tikzpicture} 
   \begin{axis} [
%      axis x line = middle,
%      axis y line = middle,
      domain=0:5, y domain=0:5,
      enlargelimits, 
      view={0}{90},
      samples=80,
      ] 
      \addplot3 [ 
         contour gnuplot={
            levels={0}
         } 
      ]
         { x^y - y^x }; 
   \end{axis} 
\end{tikzpicture}
\end{document}

Das macht prinzipiell das Gewünschte, wie erwartet. Wenn ich die beiden Kommentare bei den axis line entferne, sind die Tic Labels weg.
Wieso?
Wie kriege ich die wieder her?
Das Problem tritt mit pdflatex und lualatex auf.

Gruß vom Rolli


Gast

Beitrag von Gast »

Code: Alles auswählen

%    axis x line = middle,
%    axis y line = middle,
    axis lines = middle,

scheint zu funktionieren.


Rolli
Forum-Guru
Forum-Guru
Beiträge: 345
Registriert: Mi 15. Feb 2017, 08:50
Wohnort: Mittelfranken

Re: PGF Contour Plot - Beim Übergang zu Achsen sind die Tic Labels weg

Beitrag von Rolli »

D'accord. Bin ich nicht selber drauf gekommen. Danke für die schnelle Hilfe.

Ich melde es mal an Christian F.

Gruß vom Rolli


Antworten