Problem mit Kopf- und Fußzeilen

Layout von Seiten, Rändern, Fusszeilen, usw, modifizieren


Eicer

Problem mit Kopf- und Fußzeilen

Beitrag von Eicer »

Hallo Forum,
ich versuche, mein erstes Latex-Dokument zu schreiben und habe durch einzelne Code-Schnipsel aus dem Forum folgenden Beispiel-Code zusammengebaut:

\documentclass[fontsize=12pt,a4paper,book,BCOR=8mm,DIV=calc,twoside,toc=chapterentrywithdots,noonelinecaption, parskip=half]{scrbook}
\usepackage[ngerman]{babel}
\usepackage[T1]{fontenc}
\usepackage[latin1]{inputenc}
\usepackage{textcomp}
\usepackage{blindtext}
\usepackage{imakeidx}
\usepackage{setspace}
\usepackage[markcase=noupper, headsepline, ]{scrlayer-scrpage}
\date{\today}
\title{Familienbuch}
\makeindex[name=orte,title={Ortsregister},columnseprule]
\makeindex[name=namen,title={Namensregister},columnseprule]
\makeindex[name=personen,title={Personenregister},columnseprule]
\begin{document}
\thispagestyle{empty}
\maketitle
\newpage 
\thispagestyle{empty}
\tableofcontents
\ohead{}
\ofoot{\pagemark}
\ohead{\headmark}
\newpage 
\chapter{Familienindex}
Test-Text
\end{document}

Ich möchte gern, dass auf Titelblatt und Inhaltsverzeichnis keine Kopf- und Fußzeilen erscheinen, danach soll im äußeren Kopf die Kapitelbezeichnung und im Fuß die Seitenzahl erscheinen. Ich erhalte aber nach dem Inhaltsverzeichnis eine leere Seite, wo die Kopf- und Fußzeile schon gesetzt ist. Dafür fehlt auf der 1. Seite mit Inhalten die Kopfzeile. Was mache ich hier verkehrt? Bin für jeden Tipp dankbar.

Vielen Dank,
Eicer


Grummelgast

Re: Problem mit Kopf- und Fußzeilen

Beitrag von Grummelgast »

\documentclass[fontsize=12pt,headsepline,BCOR=8mm,DIV=calc,twoside,toc=chapterentrywithdots,captions=nooneline, parskip=half]{scrbook}% Unbekannte und veraltete Optionen entfernt/ersetzt, Voreinstellungen entfernt, headsepline global gesetzt
\usepackage[ngerman]{babel}
\usepackage[T1]{fontenc}
\usepackage{blindtext}
\usepackage{imakeidx}
\usepackage{setspace}
\usepackage{scrlayer-scrpage}
\automark[chapter]{chapter}
\title{Familienbuch}
\makeindex[name=orte,title={Ortsregister},columnseprule]
\makeindex[name=namen,title={Namensregister},columnseprule]
\makeindex[name=personen,title={Personenregister},columnseprule]
\AfterTOCHead{\thispagestyle{empty}\pagestyle{empty}}
\AfterStartingTOC{\cleardoubleemptypage}
\begin{document}
\maketitle
\tableofcontents
\chapter{Familienindex}
\Blindtext[10]
\end{document}

Warum es richtig ist, dass auf der Kapitelanfangsseite kein Kopf steht und wie man das ggf. entgegen besseren Wissens ändern kann, liest du bitte in der KOMA-Script-Anleitung nach (Stichwort: \chapterpagestyle). Falls du im Kopf abwechselnd Kapitel und Abschnitt haben willst, kannst Du scrlayer-scrpage und \automark auch komplett leer lassen.

Alle neu verwendeten Anweisungen und Optionen sind in der KOMA-Script-Anleitung erklärt. Bitte nachlesen!

Alle mir bekannten LaTeX-Editoren sind übrigens auf UTF-8 voreingestellt. LaTeX ebenfalls. Der Online Editor hier ebenfalls. Vorlagen, die noch latin1 setzen, gehören in die Tonne. Wer behauptet, dass das unter Windows zu verwenden ist, lag noch nie wirklich richtig. Dem sollte man daher grundsätzlich misstrauen. Insgesamt lässt man inputenc heutzutage am besten weg und codiert sein Dokument einfach UTF-8.


Eicer

Re: Problem mit Kopf- und Fußzeilen

Beitrag von Eicer »

Hallo Grummelgast,
vielen Dank für die schnelle Antwort. Wie schon geschrieben, ist dies mein erstes Dokument, das ich überhaupt mit Latex schreibe, und ich habe mir aus dem Forum Sachen zusammengesucht, die nach und nach meine Vorstellungen umsetzen. Das Problem war ja auch nicht, dass auf der 1. Seite eines Kapitels Kopf- und Fußzeile erschienen, sondern dass in meinem Beispiel nach dem Inhaltsverzeichnis noch eine leere Seite auftauchte, wo als Kopfzeile noch Inhaltsverzeichnis stand.
Die Koma-Script-Anleitung hatte ich vorher auch schon gefunden, aber für einen Anfänger ist sie schwer zu verstehen; da könnten ruhig mehr Beispiele drin sein, die Schritt für Schritt den Aufbau erklären. Ich werde aber suchen, Deine neuen Latex-Befehle zu vestehen.
Latin1 habe ich deshalb verwendet, weil ich bei UTF-8 nur Sonderzeichen in der PDF erhalten habe, da meine Tex-Datei über VBA erzeugt wird und Excel kein UTF-8 kann. Dass UTF-8 generell vorzuziehen ist, weiß ich, aber in diesem Fall musste ich auf Latin-1 ausweichen.
Nochmals vielen Dank. Mein Problem sollte jetzt gelöst sein.

Eicer


Grummelgast

Re: Problem mit Kopf- und Fußzeilen

Beitrag von Grummelgast »

Eicer hat geschrieben:
Mo 12. Apr 2021, 07:53

Problem war […] dass in meinem Beispiel nach dem Inhaltsverzeichnis noch eine leere Seite auftauchte, wo als Kopfzeile noch Inhaltsverzeichnis stand.

Kopf- und Fußzeile auf der Vakatseite lag maßgeblich daran, dass die Warnung über die Verwendung einer veralteten Option ignoriert wurde. Wie sich zeigt, lohnt es sich also, solche Warnungen zu beachten. Mit dem expliziten \cleardoubleemptypage bereits am Ende des Verzeichnisses, würde es aber auch mit der veralteten Option nicht mehr auftreten. :wink:


Grummelgast

Off-Topic: Excel kann UTF-8

Beitrag von Grummelgast »

Bezüglich Excel und UTF-8 gibt es diverse Möglichkeiten:

Da man per VBA eigentlich alles "fernsteuern" kann, kann man sicher auch die Codierung beim Speichern über zusätzliche Einstellungen manipulieren. Den letzten Link habe ich angegeben, weil man CSV-Dateien auch sehr schön mit pgfplots und pgfplotstable verarbeiten kann.

Davon unabhängig verwendet Excel in der Voreinstellung nicht Latin-1, sondern (abhängig vom locale) ansinew o. ä.

Disclaimer: Auf meinem Rechner gibt es keinerlei proprietäre Software.


Eicer

Re: Problem mit Kopf- und Fußzeilen

Beitrag von Eicer »

Vielen Dank für die Links. Ich werde das Ganze mal testen. Ich erzeuge allerdings keine CSV-Datei, sondern per Makro die tex-Datei mit den Inhalten aus Excel. Ob dort auch UTF-8 verwendet werden kann, muss ich mal testen. Leider kann man sich ja nicht aussuchen, welche Software der Arbeitgeber einem installiert...


Eicer

Re: Problem mit Kopf- und Fußzeilen

Beitrag von Eicer »

Guten Morgen,
mit dem Makro im letzten Link kann ich meine erzeugte tex-Datei nach UTF-8 konvertieren und somit auf latin-1 verzichten. Es funktioniert bestens.
Nochmal vielen Dank,
Eicer


Benutzeravatar
KOMA
TeX-Entwickler
TeX-Entwickler
Beiträge: 2754
Registriert: Fr 4. Jul 2008, 17:28
Kontaktdaten:

Re: Problem mit Kopf- und Fußzeilen

Beitrag von KOMA »

Ich denke, ob Du für Deine Lösungen bei Dir latin1 (oder besser ansinew) verwendest oder nicht, spielt keine große Rolle. Die Dateien extra umzukodieren bringt eigentlich nur etwas, wenn man XeLaTeX oder LuaLaTeX verwenden will.

Für Fragen in Foren ist latin1/ansinew dagegen eher ungünstig. Ob die Online-Kompiliermöglichkeit damit klar kommt, weiß ich nicht. Problematisch ist, wenn zwar \usepackage[latin1]{inputenc} in der Datei steht, beim Kopieren aus dem Forum die Datei aber in Wirklichkeit UTF8-kodiert wird. Das kann dann nicht nur zu Darstellungsfehlern im Viewer, sondern auch zu Fehlern beim LaTeX-Lauf führen. Ich bin solche Dinge zwar gewohnt, aber ehrlich gesagt, nervt es mich trotzdem jedes Mal – hauptsächlich, weil ich es doch inzwischen gewohnt sein und entsprechend routinemäßig einen Blick darauf haben müsste, also wegen meiner eigenen Dummheit.

Auf meinen Rechnern gibt es übrigens proprietäre Software. Excel gehört allerdings nicht dazu, aber beispielsweise die Software für die virtuelle Maschine, die ich zum Ausführen von Excel verwenden würde. :wink:


Antworten