Mysteriöse Ziffer im Inhaltsverzeichnis

Schriftbild, Absätze und Auflistungen einstellen
empio

Mysteriöse Ziffer im Inhaltsverzeichnis

Beitrag von empio »

Hallo zusammen,
Ich habe ein Problem in meinem Inhaltsverzeichnis: Dort tritt bei einem Kapitel aus irgendwelchen Gründen eine unnötige Zahl auf. Zudem ist das ganze Kapitel etwas versetzt im Verzeichnis aufgelistet.
Leider schaffe ich es nicht einen Screenshot vom pdf hier einzufügen. Deshalb rekonstuiere ich das pdf hier qualitativ:

1 Einleitung .......................................1
2 Theoretischer Hintergrund ................3
310Methoden .................................10

Die Seitenzahl hat (10) hat sich also einfach in den Titel des Kapitel eingeschlichen.

Code: Alles auswählen

\documentclass[a4paper,12pt,headsepline]{scrartcl}

\usepackage[utf8]{inputenc}
\usepackage{graphicx}
\usepackage[german]{babel}
\usepackage[right]{eurosym}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage{color}
\usepackage{amsmath}
\usepackage{amssymb}
\usepackage{upgreek}
\usepackage{multirow}
\usepackage[table,xcdraw]{xcolor}
\usepackage{url}
%\usepackage{hyperref}

\usepackage{geometry}
\geometry{left=2.8cm, right=2.8cm, top=2.5cm, bottom=3cm}

\usepackage{verbatim}
\usepackage{fancybox}
\usepackage{capt-of}
\usepackage{microtype} 


\usepackage{setspace}
\usepackage[version=4]{mhchem}






\usepackage{fancyhdr}

%Kopf-und Fusszeile
\pagestyle{fancy}
\fancyhf{}
\fancyhead[L]{\nouppercase{\leftmark}} %Kopfzeile links
\fancyhead[C]{} %zentrierte Kopfzeile
\fancyhead[R]{\thepage} %Kopfzeile rechts
\renewcommand{\headrulewidth}{0.4pt} %obere Trennlinie
\fancyfoot[C]{\thepage} %Seitennummer
\renewcommand{\footrulewidth}{0.4pt} %untere Trennlinie

%Bildunterschriften
\usepackage[labelfont={bf,sf},font={small},%
  labelsep=space]{caption}
 \setcapindent{0.2cm}





\bibliographystyle{apalike}
\RequirePackage[%
natbib=true,%
citestyle=authoryear,%
bibstyle=authoryear,%
maxnames=2,%
minnames=1,%
backend=bibtex,]



\begin{document}



\input{00_deckblatt}



\newpage
\thispagestyle{empty}
\tableofcontents{}
\newpage




\onehalfspacing

\section{Einleitung}
	\input{02_problem}
	\input{03_thema}
	\input{12_ziel}
\section{Theoretischer Hintergrund}
	\input{04.1_sanierung}
	\input{04.2_ion_partitioning}
	\input{04.3_supersaturation}
	\input{04.4_struktur}
	\input{04.5_wachstum}
	\input{17_kristallografie}	

	\input{05_methoden} 
\section{Resultate und Diskussion}	
	\input{07_ausfaellungsprodukte}
	\input{08_xrd}
	\input{09_ftir}
	\input{10_sem_edx}
	\input{06_auflosung_magnesit}
	\input{11_afm}
	\input{15_identification_newphase}
	\input{13_schlussfolgerung}	
\newpage
\input{16_eid}

	
\newpage



\addcontentsline{toc}{section}{Literaturverzeichnis}
\renewcommand\refname{Literaturverzeichnis}
\bibliography{99_literatur.bib}

\newpage
\thispagestyle{empty} % erzeugt Seite ohne Kopf- / Fusszeile


\end{document}
Kann mir da jemand weiterhelfen?
[/img]

Gast

Beitrag von Gast »

Das Problem ist mit dem gezeigten Code nicht reproduzierbar, weil das leider kein vollständiges Minimalbeispiel nach Anleitung ist.

Ich kann allerdings schon einmal sagen, dass

Code: Alles auswählen

\RequirePackage[%
natbib=true,%
citestyle=authoryear,%
bibstyle=authoryear,%
maxnames=2,%
minnames=1,%
backend=bibtex,]
kein korrekter Code ist. Vermutlich sollte da biblatex geladen werden, wozu allerdings \usepackage verwendet werden sollte und auch das Argument mit dem Paketnamen fehlt. Allerdings wäre biblatex auch nicht kompatibel mit der \bibliographystyle-Angabe.

In dem Code liegt noch mehr Problempotential. So warnt die verwendete Klasse sicher nicht ohne Grund vor der Verwendung von fancyhdr und gibt dabei übrigens auch eine Alternative mit aus.

Das Paket capt-of ist bei Verwendung von scrartcl komplett überflüssig.

Ich glaube auch nicht wirklich, dass du noch nach alter Rechtschreibung schreibst. Also ist german als Option zu babel wohl durch ngerman zu ersetzen.

Es ist auch nicht wirklich sinnvoll color zu laden, wenn man ohnehin xcolor lädt.

Um das Literaturverzeichnis ins Inhaltsverzeichnis aufzunehmen, verwendet man besser Option bibliography oder Option toc. Siehe dazu die KOMA-Script-Anleitung.

apalike ist übrigens für Dokumente in Deutsch weitgehend ungeeignet. Nicht nur deshalb würde ich in der Tat zu biblatex raten.

Insgesamt sieht mir das nach einem Fall für »Minimale Vorlage vs. maximale Probleme« aus. Mich würde nicht wundern, wenn das Problem durch ähnlich kruden Code an anderer Stelle verursacht würde.

empio

Beitrag von empio »

Vielen Dank für deine Antwort und die guten Verweise.
Ich habe den Fehler gefunden: In dem Kapitel "kristallografie", weche vor dem im Inhalzsverzeichnis Fehl-Formatierten "Methoden" steht, habe ich eine Fussnote wie folgt eingesetzt:

Code: Alles auswählen

\subsection{Kristallografie von Magnesit \footnote{Die Informationen dieses Abschnittes basieren auf der Quelle von \cite{carbonates_mineralogy}, sofern nicht ausdrücklich auf eine andere Quelle hingewiesen wird.}} \label{kristallografie}
Wenn ich diesen entferne, habe ich das Problem im Inhaltsverzeichnis nicht.
Jetzt muss ich mir nur noch eine gescheite Lösung zu dieser Fussnote einfallen lassen...


Benutzeravatar
u_fischer
Forum-Meister
Forum-Meister
Beiträge: 4036
Registriert: Do 22. Nov 2012, 11:09
Kontaktdaten:

Beitrag von u_fischer »

empio hat geschrieben:Vielen Dank für deine Antwort und die guten Verweise.
Ich habe den Fehler gefunden: In dem Kapitel "kristallografie", weche vor dem im Inhalzsverzeichnis Fehl-Formatierten "Methoden" steht, habe ich eine Fussnote wie folgt eingesetzt:

Code: Alles auswählen

\subsection{Kristallografie von Magnesit \footnote{Die Informationen dieses Abschnittes basieren auf der Quelle von \cite{carbonates_mineralogy}, sofern nicht ausdrücklich auf eine andere Quelle hingewiesen wird.}} \label{kristallografie}
Wenn ich diesen entferne, habe ich das Problem im Inhaltsverzeichnis nicht.
Jetzt muss ich mir nur noch eine gescheite Lösung zu dieser Fussnote einfallen lassen...

Du willst die Fußnote ja nicht im Inhaltsverzeichnis, also verwende das optionale Argument:

\subsection[Text für Verzeichnis]{Text mit Fußnote\footnote{blub}}

Antworten