TeXnicCenter mit Sumatra PDF

Anzeigeprogramme für dvi, ps und pdf wie YAP, Adobe Reader, Ghostview u.a.
Benutzeravatar
Johannes_B
Moderator
Moderator
Beiträge: 5081
Registriert: Do 1. Nov 2012, 14:55
Kontaktdaten:

Beitrag von Johannes_B »

Bevor ich deinen Post lese:

Du benutzt die Version 2 des TXC? Der sollte Sumatra automatisch erkennen und verwenden.

Was meinst du mit, sumatra funktioniert nicht?
TeXwelt - Fragen und Antworten Schaut vorbei und stellt Fragen.
LaTeX-Vorlagen?

Der Weg zum Ziel: Ruhe bewahren und durchatmen, Beiträge und unterstützende Links aufmerksam lesen, Lösungsansätze verstehen und ggf. nachfragen.

esdd
Forum-Meister
Forum-Meister
Beiträge: 2483
Registriert: So 7. Feb 2010, 16:36

Beitrag von esdd »

Geh mal in den Ordner, in dem deine SumatraPDF.exe liegt und klicke mit der rechten Maustaste auf diese. Anschließend wählst du Eigenschaften und schaust, was unter Ort steht. Vermutlich C:\Program Files\...

Gruß
Elke

AufReisen
Forum-Newbie
Forum-Newbie
Beiträge: 4
Registriert: Mo 17. Feb 2014, 17:15

Beitrag von AufReisen »

So, hab mich heute nochmal rangesetzt. Beim Öffnen von TeXnicCenter fiel auf: Automatisch stand überall Program Files statt Programme (also auch unter(La)TeX, da wo im Pfad MikTeX steht), im besten Fall macht TeXnicCenter das automatisch richtig.
Wenn ich jetzt irgendeine Vorlage öffne und mir anzeigen lassen will (F5), kommt die Fehlermeldung: "[ForwardSearch... Der Befehl konnte nicht ausgeführt werden. - und es wird nichts angezeigt.
Das Komische ist: Ich hatte es schon einmal hinbekommen, dass mir zumindest Vorlagen aus dem Internet angezeigt wurden. Wenn ich dann aber zum Beispiel dort meinen Namen eingetragen habe, kam wieder die Fehlermeldung und die Anzeige änderte sich nicht.
Vielleicht mache ich ja irgendetwas anderes falsch, ich habe noch nie mit LateX gearbeitet.
Achso, danke für die schnellen Antworten!

AufReisen
Forum-Newbie
Forum-Newbie
Beiträge: 4
Registriert: Mo 17. Feb 2014, 17:15

Beitrag von AufReisen »

Ich habe nochmal unter Ausgabeprofile definieren in den Viewer geguckt und da stand an einer Stelle (weiter hinten) noch Programme statt Program Files. Das habe ich geändert, aber dadurch hat sich auch noch nichts geändert. Ich habe den Eintrag so erstellt, wie es in How to Sumatra steht. Hätte ich das vielleicht nicht tun sollen? Wenn ja, wo finde ich die Originaleinstellungen?

Benutzeravatar
Johannes_B
Moderator
Moderator
Beiträge: 5081
Registriert: Do 1. Nov 2012, 14:55
Kontaktdaten:

Beitrag von Johannes_B »

Das bringt zwar nichts zur eigentlich Fragestellung, aber: Mit deiner Texdistribution wurde auch ein Editor mit internem Viewer installiert -> Texworks
Dieser ist besonders für Anfänger geeignet, um sich die »ersten Sporen« zu verdienen.

Spáter kannst du auf einen Editor wechseln, der besser/anders erscheint.
Welcher Editor ist für Einsteiger empfehlenswwert?

Und natürlich immer einen Blick in das Dokument von Sepp werfen: Texniccenter und miktex
TeXwelt - Fragen und Antworten Schaut vorbei und stellt Fragen.
LaTeX-Vorlagen?

Der Weg zum Ziel: Ruhe bewahren und durchatmen, Beiträge und unterstützende Links aufmerksam lesen, Lösungsansätze verstehen und ggf. nachfragen.

AufReisen
Forum-Newbie
Forum-Newbie
Beiträge: 4
Registriert: Mo 17. Feb 2014, 17:15

Beitrag von AufReisen »

Danke, Johannes. Mit TeXworks kann ich immerhin arbeiten, auch wenn er bei der pdf-Ausgabe langsam ist. Was da jetzt mit TeXnicCenter und Sumatra falsch läuft - keine Ahnung.

TeXStarter

TexnicCenter 2.02 / SumatraPDF 2.4

Beitrag von TeXStarter »

AufReisen hat geschrieben:Hallo,

also erstmal hoffe ich, dass ich im richtigen Thread lande ^^
Ich wollte jetzt auch mal mit LaTeX arbeiten für meine Bachelorarbeit, hab mir SumatraPDF geholt und es funktioniert nicht.
Ich habe TeXnicCenter 2.02 Stable (32bit), SumatraPDF v2.4 und habe mir im TeXnicCenter ein neues Ausgabeprofil erstellt, wo die Pfade auch mit Programme statt Program Files stehen. Nach der Anleitung How to Sumatra steht jetzt beim Viewer unter Pfad der Anwendung C:\Programme\SumatraPDF\SumatraPDF.exe -inverse-search ""C:\Programme\TeXnicCenter\TEXCNTR.EXE" /ddecmd "[goto(’%f’,’%l’)]’"", ansonsten hab ich alles rüberkopiert, was in How to Sumatra steht,a ber das meiste stand schon vorher richtig.
Wenn ich jetzt ein neues Projekt starte und mir irgendeine Vorlage nehme und zum Beispiel einen Titel und meinen Namen einsetze und auf Ausgabe betrachten klicke, bekomme ich die Fehlermeldung:
[ForwardSearch...
Der Befehl konnte nicht ausgeführt werden.

Es wird nichts angezeigt. Ach so, ich verwende Windows Vista. Auf die Apostrophe und die Leerzeichen in den Quellangaben habe ich auch geachtet. Über eine Antwort würde ich mich sehr freuen.

Hallo,
Ich habe auch Texniccenter Version 2.02 Stable (64bit) und SumatraPDF v2.4 und bekomme es einfach nicht hin richtig einzustellen, es kommt beim Kompilieren immer der Fehler [ForwardSearch("%bm.pdf²,²%Wc",%l,0)] konnte nicht ausgeführt werden. Ich erhalte ein PDF, dass in Sumatra geöffnet wird, aber wenn ich dann hineinklicke, öffnet sich erneut TexnicCenter um dann mit der Fehlermeldung " C:\Program Files(x86)\Sumatra.... enthält eine falsche Pfadangabe " wieder zu schließen.
Ich habe nochmal nachgeschaut, in meinen ganzen Latex-Dateinamen kommt kein einziges Leerzeichen vor...

Meine Einstellung in Summatra zur Inverssuche ist: "C:\Program Files\TeXnicCenter\TeXnicCenter.exe"/ddecmd "[goto(’%f’,’%l’)]’"

In Texniccenter (Ausgabeprofile) habe ich folgendes eingestellt:
Pfad des (la)TeX-Compilers:
C:\Program Files\MiKTeX 2.9\miktex\bin\x64\pdflatex.exe
Argumente, die an den Compiler übergeben werden sollen:
-synctex=-1 -max-print-line=120 -interaction=nonstopmode "%wm"
Pfad des BibTeX-Compilers:
C:\Program Files\MiKTeX 2.9\miktex\bin\x64\bibtex.exe
Argumente, die an BibTex übergeben werden sollen:
"%tm"
Pfad des MakeIndex-Compilers:
C:\Program Files\MiKTeX 2.9\miktex\bin\x64\makeindex.exe
Argumente, die an MakeIndex übergeben werden sollen:
"%tm.idx" -t "%tm.ilg" -o "%tm.ind"

Bei Vorbearbeitung und Nachbearbeitung habe ich nichts eingestellt.

Bei Viewer habe ich folgendes eingestellt:
Pfad der Anwendung:
"C:\Program Files (x86)\SumatraPDF\SumatraPDF.exe" -inverse-search ""C:\Program Files\TeXnicCenter\TeXnicCenter.exe"/ddecmd "[goto(’%f’,’%l’)]’""
Projektausgabe betrachten:
DDE-Kommando
Kommando: [Open("%bm.pdf",0,1,1)]
Server: SUMATRA
Thema: Control
Suche in Ausgabe:
DDE-Kommando
Kommando: [ForwardSearch("%bm.pdf","%Wc",%l,0)]
Server: SUMATRA
Thema: Control
Vor Compilierung Ausgabe schließen: Nicht schließen


Habe schon mehrere verschiedene Einstellungen ausprobiert, jedoch hat es nie funktioniert, vielleicht sieht einer von euch den Fehler und kann mir die richtigen Einstellungen sagen.

Vielen Dank schonmal;)

TeXStarter

Beitrag von TeXStarter »

Kann mir niemand weiterhelfen??

TeXStarter

Beitrag von TeXStarter »

Immer noch niemand? :(

PICnico

Beitrag von PICnico »


Antworten