PDF erzeugen scheitert unerklärlich Thema ist als GELÖST markiert

Fragen und Probleme, die nicht den obigen Kategorien zugeordnet werden können


Benutzeravatar
Stefan Kottwitz
Admin
Admin
Beiträge: 2187
Registriert: Di 8. Jul 2008, 00:39
Kontaktdaten:

Re: PDF erzeugen scheitert unerklärlich

Beitrag von Stefan Kottwitz »

Super, dass es geholfen hat! Recherche ist manchmal nicht einfach, schön dass es hier im Forum kundige Leute gibt, ich hätte das nicht gefunden.

Stefan


Benutzeravatar
KOMA
TeX-Entwickler
TeX-Entwickler
Beiträge: 2860
Registriert: Fr 4. Jul 2008, 17:28
Kontaktdaten:

Re: PDF erzeugen scheitert unerklärlich

Beitrag von KOMA »

@MNSTR: Es mag Dich nicht erfreuen, aber in der Tat ist es nach meiner langen Erfahrung so, dass man bei LaTeX ohne Anleitung-Lesen auf Dauer nicht auf einen gründen Zweig kommt. Auch eine ausführliche LaTeX-Einführung ist tatsächlich extrem hilfreich. So gesehen mag Grummelgasts Kommentar hart sein, aber leider eben die harte Wahrheit.

Ob man in der LaTeX-Einführung erfährt, dass \ProvidesPackage in der Tat ein eindeutiger Hinweis ist, dass es sich bei einer Datei um ein LaTeX-Paket handelt (für Klassen wäre der entsprechende Hinweis \ProvidesClass) weiß ich nicht. Dass Pakete die Endung .sty haben, sollte aber drin stehen. Das lernst Du mit der Zeit. Und wenn Du eine verlinkte Seite, wie die von Grummelgast (die ich nie gefunden hätte, aber sehr nützlich finde) nicht verstehst, solltest Du das übrigens nicht übergehen, sondern gezielt Fragen dazu stellen. Denn, dass eine verlinkte Seite Teil einer Antwort ist, hat natürlich zwei Seiten. Die eine ist, dass ein Helfer durchaus erwarten darf, dass sie genauso gründlich gelesen wird, wie der Rest der Antwort. Die andere ist, dass man dann natürlich dazu genauso weiter nachfragen darf, wie zum Rest der Antwort.

Jedenfalls sollte es genügen fixpdfx.sty in das Arbeitsverzeichnis zu kopieren. Da es vor pdfx geladen werden muss und das innerhalb der Klasse geladen wird, kann man es aber nicht einfach mit \usepackage laden, sondern müsste es noch vor der Klasse mit \RequirePackage laden. Das ist so ein Sonderfall, den Anfänger kaum wissen können. Man könnte natürlich vorübergehend auch eine Kopie der Klassendatei (umbenennen nicht vergessen!) editieren und \RequirePackage{fixpdfx} vor \RequirePackage{pdfx} einfügen.

Aber in Deinem Fall dürfte die einfachste Lösung sein, erst einmal pdfa abzuschalten. Wie hat Grummelgast ja erklärt. Und in wenigen Tagen hat dann hoffentlich auch MiKTeX das tuda-ci-Update mit dem Workaround. Bei TeX Live gehe ich davon aus, dass es morgen oder übermorgen verfügbar ist, nachdem Marei schreibt, dass sie heute eine entsprechende Release veröffentlicht hat. Bei MiKTeX dauert es meist etwas länger.

Und weil die einfachste Lösung ausnahmesweise quasi Aussitzen ist, habe ich fixpdfx bisher auch nicht selbst getestet.


Benutzeravatar
KOMA
TeX-Entwickler
TeX-Entwickler
Beiträge: 2860
Registriert: Fr 4. Jul 2008, 17:28
Kontaktdaten:

Re: PDF erzeugen scheitert unerklärlich

Beitrag von KOMA »

In TeX Live ist das Update von tuda-ci inzwischen angekommen und das oben gezeigte Minimalbeispiel funktioniert. Das tuda-ci-Paket von MiKTeX dürfte demnächst aktualisiert werden. Unter dem Link kann jeder selbst verfolgen, ob dort Version 3.17 verfügbar ist – und in der MiKTeX Console natürlich ebenfalls.


Benutzeravatar
KOMA
TeX-Entwickler
TeX-Entwickler
Beiträge: 2860
Registriert: Fr 4. Jul 2008, 17:28
Kontaktdaten:

Re: PDF erzeugen scheitert unerklärlich

Beitrag von KOMA »

Inzwischen ist auch für MiKTeX das Update erschienen. Damit sollte das Problem gelöst sein.


MNSTR
Forum-Newbie
Forum-Newbie
Beiträge: 6
Registriert: Di 27. Jul 2021, 11:50

Re: PDF erzeugen scheitert unerklärlich

Beitrag von MNSTR »

KOMA hat geschrieben:
Do 29. Jul 2021, 09:44

Inzwischen ist auch für MiKTeX das Update erschienen. Damit sollte das Problem gelöst sein.

Ich war gestern leider beschäftigt, wollte aber nochmal kurz antworten.
Ich habe Grummelgasts Kritik durchaus verstanden und viele der Punkte waren korrekt, ich habe an manchen Stellen einfach den Wald vor lauter Bäumen nicht gesehen - retrospektiv ist in die Dokumentation von pdfx und tuda zu schauen wirklich naheliegend. Bis kurz vorher dachte ich einfach, dass das Problem an meinem Code liegt, oder meiner Installation und nicht daran, dass LaTeX selbst durch einen Bugfix den PDF/A Teil von pdfx zerschossen hat.
Die Kritik war berechtigt, ich fand die Art wie es geschrieben war in meiner Überforderung einfach etwas hart, das ist alles.

Das .sty wusste ich, auf requirepackage wäre ich z.b. wahrscheinlich sehr lange nicht gekommen.

Ich habe versucht eine "konkrete" Frage zum Link zu stellen, die war aber halt relativ allgemein mit "wie implementiert man den Code den ich da sehe" weil ich darin keine Zeile verstanden habe und nicht weiter erklärt wird, wie der fix funktioniert. Sicherlich keine gute Frage, aber gezielter ging für mich in dem Moment einfach nicht. Wobei ich zumindest die Paketstruktur hätte früher bemerken können.

Das Problem in tuda sollte mit Marei's workaround temporär gelöst sein.

Ich möchte zum Ende des Threads aber nochmal herausstellen, was Grummelgast mittig im Thread gepostet hatte, ich aber für zukünftige Leser für wichtig halte:
die Einstellung pdfa=false in tuda hat das Problem einfach aus dem Weg geräumt. Bis zur Abgabe der Thesis ist das PDF/A Format sowieso nicht notwendig, mein größter Lerneffekt ist also für die Zukunft die Optionen des verwendeten Pakets weiter zu erkunden, da findet sich mehr als ich dachte.

Danke nochmal an Alle!


Antworten