\cite auf JabRef-Eintrag will nicht

Fragen und Probleme, die nicht den obigen Kategorien zugeordnet werden können


voll-LaTex-Neuling
Forum-Anfänger
Forum-Anfänger
Beiträge: 24
Registriert: So 21. Mär 2021, 22:35

\cite auf JabRef-Eintrag will nicht

Beitrag von voll-LaTex-Neuling »

Hallo zusammen,

ich habe in JabRef zwei Einträge macht. Den Ersten vor ein paar Tagen, den Zweiten heute. Vor ein paar Tagen hatte ich auch schon Schwierigkeiten bzw. es hat ewig gedauert bis ich endlich auf den ersten Eintrag mit \cite{name} verweisen konnte. So richtig brauchbare Informationen waren im Internet nicht zu finden. Sicherlich ist hier der Ein oder Andere, welcher schon des öfteren mit JabRef gearbeitet hat.

Was muss ich genau tun, nach dem ich in JabRef einen Eintrag gemacht habe und jetzt im LaTex Dokument darauf verweisen möchte?
PS: In einer Anleitung stand etwas von, ich müsse vorher noch in JabRef etwas aktualisieren. Ich weiss nur weder was noch wo. Zumindest ist offensichtlich nichts zu sehen und in den Befehlen unter den Menüpunkten auch nicht.

Vielen Dank im voraus


gast.

Re: \cite auf JabRef-Eintrag will nicht

Beitrag von gast. »

Diese Frage gehört nach Sonstige Tools oder nach Literaturverzeichnis. Wenn du mit JabRef deine Literaturdatenbank verwalten willst, solltest du dessen Anleitung lesen.

Ich empfehle, das Literaturverzeichnis in LaTeX mit biblatex und biber zu realisieren, wie das auch in den wichtigen Hinweisen zur Erstellung eines Literaturverzeichnisses erklärt wird. Dazu sollte man in JabRef die bib-Datei UTF8 codieren. Aktuelle Versionen von JabRef unterstützen das problemlos.


Benutzeravatar
Stefan Kottwitz
Admin
Admin
Beiträge: 2187
Registriert: Di 8. Jul 2008, 00:39
Kontaktdaten:

Re: \cite auf JabRef-Eintrag will nicht

Beitrag von Stefan Kottwitz »

Wo liegt denn eigentlich das Problem?

Landet der Eintrag in der .bib-Datei? Dann hat Jabref ja wohl seine Arbeit gemacht und den Rest macht biblatex/biber.

Taucht er nicht in der .bib-Datei auf? Dann kann man bei Jabref suchen. Ich habe das nie verwendet, doch da gibt es sicher auch eine Anleitung dafür.

Will nur sagen, anhand obigen wüsste man, wo zu suchen ist. Dann in so einem Fall auch gern Logfiles posten (.log, .blg, ...) Die Anfrage ist ansonsten recht allgemein, wenn kein spezifisches Problem bekannt ist.

Stefan


voll-LaTex-Neuling
Forum-Anfänger
Forum-Anfänger
Beiträge: 24
Registriert: So 21. Mär 2021, 22:35

Re: \cite auf JabRef-Eintrag will nicht

Beitrag von voll-LaTex-Neuling »

Ich habe die Lösung gefunden, auch wenn ich nicht wirklich verstanden habe, warum das so ist.

Mein Code in der Präambel anfangs:

% Literaturangaben und -verwaltung
%\usepackage{multibib}
\usepackage{hyperref}
\usepackage[backend=biber, style=alphabetic,]{biblatex} %Literaturverwaltung benötig
\addbibresource{Literaturdatenbank.bib} %Dateiname der gesammelten Literatur (gleiches Verzeichnis)
\usepackage{csquotes}
%\bibliographystyle{unsrt}
%	 \bibliographystyle{alpha}
%\bibliography{DokumentBiblio_brt}

Gast hatte diesen Link hier gepostet: viewtopic.php?f=15&t=11964 (Wichtige Hinweise: Erstellung von Literaturverzeichnissen) und in diesem war folgendes Beispiel angegeben:

\documentclass{article}
\usepackage{biblatex}
\addbibresource{MeineLiteratur.bib}
\begin{document}

\parencite{aristotle:physics}
\cite{wilde}
\printbibliography
\end{document}

Im Vergleich zu meinem hatte das \usepackage{biblatex} gefehlt. Das hatte ich anfangs so einsortiert:

% Literaturangaben und -verwaltung
%\usepackage{multibib}
\usepackage{biblatex}
\usepackage{hyperref}
\usepackage[backend=biber, style=alphabetic,]{biblatex} %Literaturverwaltung benötig
\addbibresource{Literaturdatenbank.bib} %Dateiname der gesammelten Literatur (gleiches Verzeichnis)
\usepackage{csquotes}
%\bibliographystyle{unsrt}
%	 \bibliographystyle{alpha}
%\bibliography{DokumentBiblio_brt}

Das führte aber zu einem ganz komischen Verhalten. Ohne es erklären zu können, habe ich einfach Mal probiert das \usepackage{biblatex} direkt über die Zeile \addbibresource{Literaturdatenbank.bib} zu setzen, also so:

% Literaturangaben und -verwaltung
%\usepackage{multibib}
\usepackage{hyperref}
\usepackage[backend=biber, style=alphabetic,]{biblatex} %Literaturverwaltung benötig
\usepackage{biblatex}
\addbibresource{Literaturdatenbank.bib} %Dateiname der gesammelten Literatur (gleiches Verzeichnis)
\usepackage{csquotes}
%\bibliographystyle{unsrt}
%	 \bibliographystyle{alpha}
%\bibliography{DokumentBiblio_brt}

Und es gab zumindest keine Fehler mehr. Und zusätzlich ist mein Problem damit auch behoben. Möchte ich an einer bestimmten Stelle auf ein Buch verweisen und nutze dafür \cite{... werden mir jetzt entsprechend Vorschläge gemacht, die vorher nicht angezeigt wurden.

Danke unbekannter Gast.


MoeWe
Forum-Meister
Forum-Meister
Beiträge: 621
Registriert: Fr 30. Aug 2019, 15:35
Kontaktdaten:

Re: \cite auf JabRef-Eintrag will nicht

Beitrag von MoeWe »

Schon in dem ersten gezeigten Codeblock wird biblatex explizit mit \usepackage[backend=biber, style=alphabetic,]{biblatex} geladen. Ein zusätzliches \usepackage{biblatex} ist aus TeXnischer Sicht nicht nötig und kann sogar zu Problemen führen, da ein Paket nicht mehrfach mit unterschiedlichen Optionen geladen werden darf (der berühmte option clash; wobei das wiederholte Laden ohne Optionen erlaubt, aber trotzdem unschön, ist).

% Fehler: bitte nicht nachmachen
\usepackage{biblatex}
\usepackage[backend=biber, style=alphabetic,]{biblatex}

wie im dritten Codeblock ist ein Fehler.

% unnötig und unschön, aber wenigstens kein Fehler
\usepackage[backend=biber, style=alphabetic,]{biblatex}
\usepackage{biblatex}

wie im vierten Block hingegen ist nur unschön.

Für LaTeX ist

\usepackage[backend=biber, style=alphabetic,]{biblatex}

allein völlig ausreichend und korrekt.

Du beschreibst in Deinem Beitrag die Auto-Vervollständigung, die aber kein Feature von LaTeX, sondern von Deinem Editor ist. Dein Editor muss, um die Vervollständigung anbieten zu können, Deine Präambel analysieren. Diese Analyse findet normalerweise aber "außerhalb" von TeX mittels Textanalyse (z.B. via RegEx) des Präambelcodes statt. LaTeX ist da als Programm nicht involviert. Es kann manchmal sein, dass der Editor mit validen und völlig korrekten TeX-Code nicht ganz klarkommt, da der Editor den Code eben nicht mit LaTeX analysiert. In dem Fall solltest Du Dich an die Entwickler*innen des Editors wenden und idealerweise nicht versuchen mit zweifelhaften LaTeX-Code/Idiomen den Editor zufriedenzustellen.

Ich konnte auf die Schnelle nicht sehen, welchen Editor Du nutzt. Ich würde aber eigentlich erwarten, dass alle Editoren, die von sich behaupten, LaTeX zu unterstützen, nur mit \usepackage[backend=biber, style=alphabetic,]{biblatex} klarkommen und nicht noch das überflüssige \usepackage{biblatex} benötigen sollten.

Möglicherweise hilft es auch (nicht nur dem Editor, sondern auch der Übersicht und damit Dir), wenn Du die auskommentierten Zeilen, die sich auf BibTeX-Literaturverzeichnisse beziehen, ganz aus der Präambel herausnimmst.

----

Zuletzt sei noch erwähnt, dass hyperref bis auf wenige Ausnahmen eigentlich als letztes Paket geladen werden sollte. Es sollte hier nach biblatex und csquotes kommen.


Antworten