Brief DIN5008A

Klassen und Pakete zur einfachen Umsetzung individueller Vorstellungen


Klaus12
Forum-Anfänger
Forum-Anfänger
Beiträge: 10
Registriert: Mi 12. Aug 2015, 18:20

Brief DIN5008A

Beitrag von Klaus12 »

Hallo,

ich probiere zur Zeit die Klasse scrlttr2 vom KOMA script aus. Ich möchte für den Style das lco DIN5008A verwenden, dieses wurde mittlerweile reguläre zu KOMA script hinzugefügt. Wenn ich ein minimal Beispiel nach Handbuch erstelle kommt es im erzeugten PDF zu einem Fehler. Name und Adresse des Absenders werden auch auf der linken Seiten zusammen mit dem Empfänger übereinander angezeigt. Ich habe im DIN5008A.lco nachgeschaut, da ich vermutet habe das lochpos nicht stimmt, aber mit 10mm sieht es normal aus.

Hat jemand eine Idee was den Fehler verursacht?
Danke für eure Hilfe.
Dateianhänge
document.tex
(660 Bytes) 70-mal heruntergeladen
document.pdf
(35.23 KiB) 72-mal heruntergeladen

Gast

Beitrag von Gast »

Sieht für mich nach einem Fehler bei der Ausgabe der Rücksendeadresse aus. Da scheint irgendwie die Umdefinierung von \\ für die Bedürfnisse der Rücksendeadresse zu fehlen. Mit backaddress=false funktioniert es auch tatsächlich. Am besten schreibst du einen Bug-Report. Fehler können laut Anleitung direkt an den Autor oder auf komascript.de gemeldet werden.

Gast

Beitrag von Gast »

Als Workaround funktioniert auch ein explizites

Code: Alles auswählen

        \setkomavar{backaddress}{Peter Musterfrau, Hinter dem Tal 2, 54321 Musterheim}
Es scheint da aber noch ein Bug drin zu sein. Wenn man nämlich eine Versandart setzt, wird die Adresse nicht mehr oben, sondern unten im Adressfeld ausrichtet. Du solltest also auf jeden Fall einen Bug melden, wenn du das verwenden willst.

Klaus12
Forum-Anfänger
Forum-Anfänger
Beiträge: 10
Registriert: Mi 12. Aug 2015, 18:20

Beitrag von Klaus12 »

Kohm hat mich auf https://komascript.de/release3.29 verwiesen. D.h. ein Fix wird mit der nächsten Version ausgeliefert.

Auch ein

Beitrag von Auch ein »

Anonymous hat geschrieben:Es scheint da aber noch ein Bug drin zu sein. Wenn man nämlich eine Versandart setzt, wird die Adresse nicht mehr oben, sondern unten im Adressfeld ausrichtet. Du solltest also auf jeden Fall einen Bug melden, wenn du das verwenden willst.
Das ist übrigens kein Bug und braucht deshalb auch nicht gemeldet zu werden. Stattdessen ist es so, dass wenn specialmail leer ist, der nach DIN5008 vorgesehene Bereich für Zusatzzeilen nicht durch specialmail belegt wird, sondern von der per \begin{letter}{…} angegebenen Adresse mit belegt wird. Sobald man aber specialmail auch nur für eine Zeile nutzt, wird der komplette nach DIN5008 vorgesehene Bereich für Zusatzzeilen für specialmail reserviert und die Adresse beginnt an der Position, die nach DIN5008 für Adresszeilen vorgesehen ist. Wer specialmail nicht verwendet, aber will, dass die Adresse immer erst unter dem Bereich für die (drei) Zusatzzeilen beginnt, kann sich einfach eine DIN5008A+.lco schreiben, die erst DIN5008A.lco lädt und im Fall einer leeren Variable specialmail dann \setkomavar{specialmail}{~} ausführt.

Antworten