Installation nicht freier Schriften in Texlive unter Linux

Alles rund um das System für Linux, Mac & Windows.
nixversteh
Forum-Meister
Forum-Meister
Beiträge: 500
Registriert: Di 10. Aug 2010, 09:47
Wohnort: Wrestedt

Installation nicht freier Schriften in Texlive unter Linux

Beitrag von nixversteh »

Moin liebe User,
http://www.golatex.de/viewtopic.php?p=2 ... 1e8d5412da
ich habe nach dieser Anleitung versucht, die nicht freien Schriften zu installieren. Bis zum Punkt "Die Installation der Fonts" klappt es, dann gibt das Terminal "getnonfreefonts: Befehl nicht gefunden." aus.
Hat jemand einen Tipp?
Danke
Der aus Büchern erworbene Reichtum fremder Erfahrung heißt Gelehrsamkeit. Eigene Erfahrung ist Weisheit. Das kleinste Kapital von dieser ist mehr wert, als Millionen von jener.
(Gotthold Ephraim Lessing)

Benutzeravatar
u_fischer
Forum-Meister
Forum-Meister
Beiträge: 4036
Registriert: Do 22. Nov 2012, 11:09
Kontaktdaten:

Re: Installation nicht freier Schriften in Texlive unter Lin

Beitrag von u_fischer »

nixversteh hat geschrieben:Moin liebe User,
http://www.golatex.de/viewtopic.php?p=2 ... 1e8d5412da
ich habe nach dieser Anleitung versucht, die nicht freien Schriften zu installieren. Bis zum Punkt "Die Installation der Fonts" klappt es, dann gibt das Terminal "getnonfreefonts: Befehl nicht gefunden." aus.
Hat jemand einen Tipp?
Ja. Anstatt 7 Jahre alte Anleitungen zu verwenden, nimm das aktuelle Original: https://www.tug.org/fonts/getnonfreefonts/

nixversteh
Forum-Meister
Forum-Meister
Beiträge: 500
Registriert: Di 10. Aug 2010, 09:47
Wohnort: Wrestedt

...

Beitrag von nixversteh »

@Ulrike,

ja, das habe ich mir gedacht, deshalb habe ich bereits vor deinem Post die neue Anleitung versucht, mit gleichem (Miss)Erfolg.
Der aus Büchern erworbene Reichtum fremder Erfahrung heißt Gelehrsamkeit. Eigene Erfahrung ist Weisheit. Das kleinste Kapital von dieser ist mehr wert, als Millionen von jener.
(Gotthold Ephraim Lessing)

nixversteh
Forum-Meister
Forum-Meister
Beiträge: 500
Registriert: Di 10. Aug 2010, 09:47
Wohnort: Wrestedt

...

Beitrag von nixversteh »

... hat niemand einen konstruktiven Rat?
Texlive2017 ist niegelnagelneu aufgespielt und aktuell
Der aus Büchern erworbene Reichtum fremder Erfahrung heißt Gelehrsamkeit. Eigene Erfahrung ist Weisheit. Das kleinste Kapital von dieser ist mehr wert, als Millionen von jener.
(Gotthold Ephraim Lessing)

Gast

Beitrag von Gast »

Da die Installation in wenigen Schritten normalerweise problemlos funktioniert, empfehle ich, einen kompletten Mitschnitt aus dem Terminal hier zu zeigen. Dann können wir genau sehen, was du gemacht hast und wo es in welcher Form schief geht. Das sollte per Copy&Paste einfach zu bewerkstelligen sein.

nixversteh
Forum-Meister
Forum-Meister
Beiträge: 500
Registriert: Di 10. Aug 2010, 09:47
Wohnort: Wrestedt

...

Beitrag von nixversteh »

@Gast.

hier der Terminalausdruck:

martin@xelatex ~ $ su
Passwort:
xelatex martin # cd /home/martin/Downloads
xelatex Downloads # texlua install-getnonfreefonts
Detected System: x86_64-linux
Detected Installation: /usr/local/texlive/2017
Installing texmf-dist/scripts/getnonfreefonts/getnonfreefonts.pl ... [done]
Installing texmf-dist/doc/man/man1/getnonfreefonts.1 ... [done]
Installing texmf-dist/doc/man/man1/getnonfreefonts.man1.pdf ... [done]
md5sum: a9e772165e8fdb620bcf9c75c17facda getnonfreefonts.pl ... [ok]
md5sum: 49be4444054d85b6037d237552a7cea1 getnonfreefonts.1 ... [ok]
md5sum: f825d523d686dbecdc787535b40f09d0 getnonfreefonts.man1.pdf ... [ok]
Fixing File Permissions ... [done]
Creating symlink in 'bin/x86_64-linux' ... [done]
mktexlsr: Updating /usr/local/texlive/2017/texmf-dist/ls-R...
mktexlsr: Done.
xelatex Downloads # getnonfreefonts -a
getnonfreefonts: Befehl nicht gefunden.
xelatex Downloads # sudo getnonfreefonts -a
sudo: getnonfreefonts: Befehl nicht gefunden
xelatex Downloads # sudo -i getnonfreefonts-sys -a
-bash: getnonfreefonts-sys: Kommando nicht gefunden.
xelatex Downloads # getnonfreefonts --help
getnonfreefonts: Befehl nicht gefunden.
xelatex Downloads # getnonfreefonts --all
getnonfreefonts: Befehl nicht gefunden.
xelatex Downloads #
Der aus Büchern erworbene Reichtum fremder Erfahrung heißt Gelehrsamkeit. Eigene Erfahrung ist Weisheit. Das kleinste Kapital von dieser ist mehr wert, als Millionen von jener.
(Gotthold Ephraim Lessing)

Gast

Beitrag von Gast »

Du hast irgendwie eine falsche Anleitung verwendet. getnonfreefonts-sys gibt es nicht mehr. Stattdessen muss man getnonfreefonts mit Option --sys aufrufen (siehe auch die von Ulrike oben verlinkte Seite). Das ist natürlich nur sinnvoll, wenn getnonfreefonts auch gefunden wird. Das wiederum funktioniert nur, wenn das Binary-Verzeichnis von TeXLive (bei dir verm. /usr/local/texlive/2017/bin/x86_64-linux) auch wirklich in PATH eingetragen ist. Außerdem muss man ggf. sudo getnonfreefonts --sys verwenden, wenn nur root Zugriff auf TEXMFMAIN hat.

nixversteh
Forum-Meister
Forum-Meister
Beiträge: 500
Registriert: Di 10. Aug 2010, 09:47
Wohnort: Wrestedt

...

Beitrag von nixversteh »

@Gast,
Moin,

danke für die Antwort, werde es heute testen, muss jetzt weg, Termine.

... mein Pfade:
export PATH=/usr/local/texlive/2017/bin/x86_64-linux:$PATH
export MANPATH=/usr/local/texlive/2017/texmf/doc/man:$MANPATH
export INFOPATH=/usr/local/texlive/2017/texmf/doc/info:$INFOPATH
unset TEXINPUTS
unset TEXMFCONFIG

... habe zigmal alle Varianten (auch mit sudo) mit getnonfreefonts -a, getnonfreefonts --all und getnongreefonts --sys getestet. Keine positive Wirkung
Der aus Büchern erworbene Reichtum fremder Erfahrung heißt Gelehrsamkeit. Eigene Erfahrung ist Weisheit. Das kleinste Kapital von dieser ist mehr wert, als Millionen von jener.
(Gotthold Ephraim Lessing)

Benutzeravatar
u_fischer
Forum-Meister
Forum-Meister
Beiträge: 4036
Registriert: Do 22. Nov 2012, 11:09
Kontaktdaten:

Beitrag von u_fischer »

Dann würde ich mir mal anschauen, was für ein symlink in bin/x86_64-linux erzeugt wurde, und ob das (und die perl-Datei) überhaupt ausführbar ist.

Gast

Beitrag von Gast »

Ersetze mal den Schritt:
texlua install-getnonfreefonts
durch

Code: Alles auswählen

sudo texlua install-getnonfreefonts
. Eigentlich sollte das nicht notwendig sein und ist es bei mir auch nicht. Allerdings hat bei mir der Benutzer, der die Installation durchführt auch Schreibrechte auf der TeX-Live-Installation. Bei mir macht nämlich nicht root die ganze TeX-Live-Administration, sondern das dürfen alle Benutzer der Gruppe texlive.

Übrigens: Wenn man https://tug.org/fonts/getnonfreefonts/i ... nfreefonts per Firefox runter lädt, wird teilweise getnonfreefonts.bin daraus. Also aufpassen, dass man auch wirklich die gerade runter geladene Datei verwendet. Ich nutze zum Runterladen auch unter Linux curl. Das funktioniert bei mir zuverlässiger als wget.

Antworten