TeXStudio Portable: Befehl konnte nicht gestartet werden....

Editoren wie TexWorks, TeXmaker, TeXstudio, TeXnicCenter, Kile, LyX, vi, Emacs und Co.
DENYS
Forum-Newbie
Forum-Newbie
Beiträge: 4
Registriert: Di 22. Sep 2020, 22:29

TeXStudio Portable: Befehl konnte nicht gestartet werden....

Beitrag von DENYS »

Liebe golatex-Community,

seit einiger Zeit verzweifle ich als LaTeX-Novize daran, dass ich aus TexStudio heraus keine Benutzerbefehle starten kann. Dies ist mir aber im Bezug auf die Erstellung von Symbolverzeichnissen extrem wichtig, damit ich nicht jedes Mal in der Windows-Kommandozeile den "makeindex"-Befehl starten muss.

Konkret geht es um folgende Anleitungen (oder in Ähnlicher Form), die ich umsetzen will, um Verzeichnisse mit dem "nomencl"-Paket zu erstellen:

https://texwelt.de/fragen/4942/wie-kann ... matisieren (gleich erster Beitrag):

makeindex testdokument.nlo -s nomencl.ist -o testdokument.nls

Wenn ich diese Befehlkette in dem Command Window eingebe, werden die .nlo und .nls -Datei erstellt und beim ganz normal Kompilieren in TexStudio mit LuaLaTeX erscheinen die Verzeichnisse auch in der PDF.

Wenn ich versuche, die Befehlszeile in dem Editor zu hinterlegen (siehe Screenshot und siehe der eingefügte Link oben mit der Anleitung), um die Aktualisierung der Verzeichnisse zu automatisieren und dann aus dem Editor heraus mit Tools --> Benutzer den Befehl starte, bekomme ich die Fehlermeldung: "Befehl konnte nicht gestartet werden: makeindex Testdokument.nlo -s nomencl.ist -o Testdokument.nls"

Ich habe das mit andern Befehlen ausprobiert, es kommt immer diese Fehlermeldung.

Hätte jemand eine Ahnung, woran es liegen kann?

  • liegt es an den Portable-Versionen von miktex oder Texstudio?
  • fehlen mir weitere Einstellungen im Editor?

Ich arbeite mit LuaLaTeX. Da das kompilieren aber ansonsten reibungslos funktioniert, habe ich kein Minimalbeispiel geliefert, da ich die Vermutung habe, dass es ein Editorproblem ist. Ich bin leider gezwungen, TexStudio Portabel aufgrund fehlender Admin-Rechte zu nutzen.

Um jeden Hinweis wäre ich undenedlich dankbar!

Beste Grüße,
Denys

Dateianhänge
Screenshot 2020-09-22 225936.png
Screenshot 2020-09-22 225913.png
Screenshot 2020-09-22 225849.png

gast

Re: TeXStudio Portable: Befehl konnte nicht gestartet werden....

Beitrag von gast »

Als erstes solltest du überprüfen, ob die Pfadangabe wirklich stimmt. Laut https://tex.stackexchange.com/a/532007 müsste es beispielsweise MikTexPortable statt MikTex_Portable heißen.

Dann ist zu beachten, dass ggf. beispielsweise von den Programmen aufgerufene weitere Programme eventuell so auch nicht gefunden werden, weil diese dann wieder via $PATH gesucht werden. Deshalb ist es sinnvoll, die $PATH-Einstellung (siehe zusätzlicher Suchpfade im zweiten Screenshot) ebenfalls um das entsprechende Binary-Verzeichnis zu erweitern.

Übrigens benötigt man für die Installation von MiKTeX nur für den aktuellen Benutzer keine Admin-Rechte. Die benötigt man nur, wenn man MiKTeX für alle Benutzer installieren will. Ein normal installiertes MiKTeX wiederum sollte eigentlich auch TeXstudio portable selbst finden. Testen kann ich das im Augenblick leider nicht.


DENYS
Forum-Newbie
Forum-Newbie
Beiträge: 4
Registriert: Di 22. Sep 2020, 22:29

Re: TeXStudio Portable: Befehl konnte nicht gestartet werden....

Beitrag von DENYS »

Hallo gast,

vielen Dank für deine Antwort!

Genau der Hinweis mit der PATH-Einstellung war es. Danach hat es sofort funktioniert, vielen Dank!

VG,
Denys


Antworten