Paket "lineno" funktioniert nicht

Editoren wie TexWorks, TeXmaker, TeXstudio, TeXnicCenter, Kile, LyX, vi, Emacs und Co.
Tom Jack

Paket "lineno" funktioniert nicht

Beitrag von Tom Jack »

Werte Forumsmitglieder,

ich arbeite gerade an meiner Abschlussarbeit in Lyx. Ich mag das Programm. Allerdings habe ich gerade ein Problem.

Für das Debugging wäre das Anzeigen von Zeilennummern sehr hilfreich. Deshalb würde ich mir gerne das Paket "lineno" herunterladen und aktivieren.

Mein Tex Live Manager weigert sich dieses Paket herunterzuladen. Der Download- und Updateversuch schlägt immer fehl.

Also wollte ich es auf anderem Wege bewerkstelligen. Im Internet habe ich gelesen, dass es ausreicht die Datei "lineno.sty" in den Ordner der Datei, für die ich eben die Zeilennummern angezeigt sehen will, einzufügen. Des Weiteren soll man in die "Preambl" noch

\usepackage{lineno}

\linenumbers

eintragen.

Das alles habe ich getan. Es funktioniert dennoch nicht.
Habt ihr vielleicht Rat. Was mache ich falsch?

Mit freundlichen Grüßen,
Tom[/t]

Rolli
Forum-Guru
Forum-Guru
Beiträge: 345
Registriert: Mi 15. Feb 2017, 08:50
Wohnort: Mittelfranken

Beitrag von Rolli »

Hast Du nach dem manuellen Kopieren die Paketdatenbank aktualisiert?
Siehe z.B. https://tex.stackexchange.com/questions ... stribution
Ansonsten: Welches Betriebssystem?
Minimalbeispiel, welches den Fehler zeigt?
Logdatei?

Übersetze mal dieses Minimalbeispiel:

Code: Alles auswählen

\documentclass{scrartcl}
\usepackage{blindtext}
\usepackage{lineno}
\begin{document}
\linenumbers
\blinddocument
\end{document}
Geht das?

Gruß vom Rolli

P.S.: Welchen Mirror hast Du im MiKTeX-Updater (falls Du MiKTeX als Übersetzungsengine verwendest) angegeben? Das Repositorium von der FAU Erlangen/Nürnberg scheint nicht mehr zu funktionieren ...

Tom Jack

Beitrag von Tom Jack »

Hallo Rolli,

tut mir Leid, dass ich mich erst jetzt melde. Ich danke dir für deine Auskunft. Aufgrund deiner Informationen versuche ich meine Problem jetzt zu lösen.

Ich arbeite an meiner Diplomarbeit und das erfordert manchmal eine solche Prioritätensetzung, dass man andere Sachen vernachlässigt. Dass ich dir so spät antworte, ist trotzdem unhöflich. Also bitte ich nochmals um Verzeihung. Ich habe mir jetzt den Nachmittag freigehalten, um mein Problem zu beheben.

Ich melde mich wieder, sobald ich das Potential deines Links komplett ausgeschöpft habe und dann auch entsprechend mit einem Minimalbeispiel. Ich hoffe, dass es nicht nötig sein wird. Was der Link sagt, klingt so als könnte das mein Problem sein. Denn im letzten Jahr konnte ich noch Pakete installieren und updaten. Jetzt - trotz keiner offensichtlichen Änderungen an meinem Betriebssystem - läuft es nicht mehr. Ja, auch ich bin ein ahnungsloser unter den PC-Nutzern. Soll heißen, dass ich auch Windowsnutzer bin.

FG,
Tom Jack

Gast

Beitrag von Gast »

Das Paket lineno ist in TeX Live enthalten. Wenn man eine Vollinstallation von TeX Live verwendet (das ist bei Vanilla TeX Live die Voreinstellung), dann ist es bereits installiert:

Code: Alles auswählen

$> kpsewhich lineno.sty
/usr/local/texlive/2018/texmf-dist/tex/latex/lineno/lineno.sty
Für installierte Pakete ist es normal, dass der Paketmanager die Installation verweigert (außer man verwendet Option --reinstall).

Verwendet man das TeX Live aus einer Linux-Distribution sei empfohlen, das Linux-Paket texlive-complete oder texlive-full oder texlive-all (je nach Linux-Distribution) zu installieren. Dann sollte man auch ein ziemlich komplettes TeX Live haben.
Tom Jack hat geschrieben:Mein Tex Live Manager weigert sich dieses Paket herunterzuladen.
Sitzt Du hinter einem Proxy? Wie lautet die Fehlermeldung?
Rolli hat geschrieben:Welchen Mirror hast Du im MiKTeX-Updater
Wäre mir neu, dass der TeX Live Manager mit MiKTeX-Updater arbeitet. ;-)

Tom Jack

Beitrag von Tom Jack »

Hallo wertes Forum und Rolli,

ich habe jetzt den Tex live manager neu installiert, weil ich gemäß deines Links gehandelt habe. Darin heißt es ja, dass von Jahr zu Jahr neue Versionen vom "Tex Live Manager" herausgegeben werden und dann ein Freeze für das Downloaden von Pakten eingestellt wird. Also habe ich den Tex Live Manager neu installiert und das Paket lineno heruntergeladen und installiert. In die Preamble habe ich wieder

\usepackage{lineno}

\linenumbers

eingetragen. Danach Lyx rekonfiguriert, Lyx geöffnet und on top sogar den PC nochmal neugestartet. Läuft leider immer noch nicht.

Zu deinem "P.S.". Ich hatte mal MikTex. Es hat mir Probleme bereitet und deshalb bin ich auf den "Tex Live manager" umgesprungen.

Zu deinem empfohlenen Beispiel mit:


\documentclass{scrartcl}
\usepackage{blindtext}
\usepackage{lineno}
\begin{document}
\linenumbers
\blinddocument
\end{document}

Ich wusste nicht genau, wie ich das implementieren soll. Deshalb habe ich es zweierlei probiert. Zum einen in die Preamble gesetzt und die anderen zwei Befehle (siehe oben) ersetzt. Im zweiten Versuch als Tex Code in das Dokument geschrieben. Hat beides nichts gebracht.

Ich würde dir ja gerne eine Minimalbeispiel schicken, aber es gibt ja jetzt eine neue Hürde. Es tritt also kein Fehler mehr auf, eben außer dem, dass es noch nicht läuft.

FG,
Tom Jack

P.S.: falls du nicht zurückschreiben solltest, fände ich es Schade, aber ich könnte es dir nicht verübeln.

Gast

Beitrag von Gast »

@Gast: danke für die Antwort. Ich habe sie erst gelesen nachdem ich meine letzte Nachricht verfasst hatte.

Ich verwende leider noch kein Linux. Das werde ich ändern. Jeder der es benutzt, zieht es Windows vor. Das hat sicherlich seine Gründe.

Ich bin in einem Uninetz eingeloggt, falls dies deine Frage beantwortet, was ich hoffe.

Ansonsten habe ich ja den aktuellen Stand meines Versuchs zum erfolgreichen Umsetzen des Pakets "lineno" im letzten Beitag näher erläutert.

FG,
Tom Jack[/quote]

Gast

Beitrag von Gast »

Könnt es vielleicht sein, dass lyx nicht auf die Pakete vom Tex Live manager zugreife kann?

Ich habe Lyx und den Tex Live manager beide im gleichen Ordner "Programme" liegen. Ist das so richtig oder muss der Tex Live manager eventuell im Ordner von Lyx installiert sein?

Antworten