Fehler mit \bibliographystyle{unsrt} Thema ist als GELÖST markiert

Erstellung eines Literaturverzeichnisses mit BibTeX, Biber, BibLaTeX und Co.


forgood2
Forum-Anfänger
Forum-Anfänger
Beiträge: 19
Registriert: Do 28. Nov 2019, 23:46

Fehler mit \bibliographystyle{unsrt}

Beitrag von forgood2 »

Moin zusammen, ich versuche das Einbinden von Citavi in mein Literaturverzeichnis.
Ich habe die .bib Datei in Citavi erstellt, soweit kein Problem. Beim implementieren der .bib Datei in mein Inhaltsverzeichnis (Texmaker) gibt es jedoch einen Fehler. ! Package biblatex Error: '\bibliographystyle' invalid.

hier mal ein Auszug aus meiner Masterdatei:

%Dokumentklasse
\documentclass[a4paper,12pt,twoside]{scrreprt}
\usepackage[left= 2.75cm,right = 2.75cm, bottom = 2.5 cm, top= 2cm ]{geometry}
%\usepackage[onehalfspacing]{setspace}
% ============= Packages =============
% Standard Packages
\usepackage[version=4]{mhchem}
\usepackage[demo]{graphicx}
\setcounter{tocdepth}{5}
\usepackage{lscape}
\setcounter{secnumdepth}{5}
\usepackage[utf8]{inputenc}
\usepackage[ngerman]{babel}
\usepackage[ngerman]{varioref}
\usepackage[T1]{fontenc}
\usepackage{graphicx, subfigure}
\graphicspath{{img/}}
\usepackage{lmodern}
\usepackage{color}
\usepackage{transparent}
\usepackage{acronym}
\usepackage{listofsymbols}
\usepackage[onehalfspacing]{setspace}
\usepackage[automark, footsepline, autooneside,plainfootsepline, headsepline]{scrlayer-scrpage}
\usepackage[version=4]{mhchem}
\usepackage{textcomp}
\usepackage{graphicx} 
\usepackage{amsmath}
\renewcommand*\chapterheadstartvskip{\vspace*{-\topskip}}
\usepackage{pdfpages}
\usepackage{grffile}
%Literatur
\usepackage{csquotes}
\usepackage[style=numeric-comp,backend=biber,sorting=none, isbn=false, doi=false,]{biblatex}
\DeclareFieldFormat{title}{#1\isdot}
\renewcommand*{\finentrypunct}{\addspace}
\bibliographystyle{unsrt}
\bibliography{Literatur}[\code]
\begin{document}
\include{12_Literaturverzeichnis}
\printbibliography
\end{document}



die Datei 12_Literaturverzeichnis schaut so aus:

\chapter{Literaturverzeichnis}
\label{sec:Literatur}
\printbibliography[heading=none]



sobald ich schon übersetzte mit biblatex übersetzte kommt folgende Meldung:
i found no \citation commands, i found no \bibdata command, i found no \bibstyle command

Ich habe schon lange nicht mehr mit Latex gearbeitet. Dies war meine alte Vorlage aus dem Studium für meine Abschlussarbeit. Ich freue mich also über eine ausführliche Hilfe :-)


Grummelgast

Re: Fehler mit \bibliographystyle{unsrt}

Beitrag von Grummelgast »

Die Fehlermeldung sagt eigentlich schon was Sache ist: Bei Verwendung von biblatex ist \bibliographystyle eine nicht erlaubte Anweisung. Wie in der Anleitung erwähnt wird, stellt man bei biblatex den Stil via Option ein, was du auch gemacht hast.

Darüber hinaus hast du offenbar auch noch bibtex aufgerufen. Tatsächlich musst du aber biber aufrufen. Siehe dazu den Link »Wie rufe ich biber in meinem Editor auf?« in den wichtigen Hinweisen, in denen die Basics zum Umgang mit biblatex erklärt werden.

Übrigens ist dein Beispiel auch dann noch nicht lauffähig, wenn man die fehlerhafte Anweisung entfernt. Bitte achte künftig darauf. → Minimalbeispiel


Grummelgast

Re: Fehler mit \bibliographystyle{unsrt}

Beitrag von Grummelgast »

BTW: Dass der Code total veraltet ist, sieht man übrigens auch ganz schnell:

\usepackage[utf8]{inputenc} braucht man schon seit April 2018 nicht mehr, also fast drei Jahre.

subfigure ist gnadenlos veraltet und wurde bereits vor Jahrzehnten von einem Nachfolger abgelöst (im Link zu finden).

listofsymbols macht immer mal wieder Probleme. Das Paket hat nie Version 1.0 erreicht und wird seit fast 20 Jahren nicht mehr gepflegt. Es basiert u. a. auf einer total veralteten Version von nomencl.

Abstände stellt man bei KOMA-Script besser mit \RedeclareSectionCommand als durch Umdefinierung von \chapterheadstartvskip ein. Steht sogar ausdrücklich in der Anleitung.

grffile ist inzwischen überholt, das graphicx inzwischen sowohl Dateinamen mit mehreren Suffix als auch mit Leerzeichen selbst beherrscht. In aktuellen Versionen, macht das Ding nichts anderes mehr als graphicx zu laden, was du aber ohnehin bereits mehrfach :shock: tust.


MoeWe
Forum-Guru
Forum-Guru
Beiträge: 461
Registriert: Fr 30. Aug 2019, 15:35
Kontaktdaten:

Re: Fehler mit \bibliographystyle{unsrt}

Beitrag von MoeWe »

Das Verwenden alter Vorlagen hat den entscheidenden Nachteil, dass der Code zum einen alt und damit potenziell veraltet und zum anderen mit für das neue Dokument unnötigen Paketen und Einstellungen besprenkelt ist. Daher mein Tipp: Weg mit der Vorlage, ganz minimal/klein beginnen und nur Pakete und Code zur Präambel hinzufügen, die Du brauchst, und bei denen Du in etwa weißt, warum Du sie brauchst.

Schon beim ersten schnellen Drüberlesen sieht man, dass Du Pakete mehrmals lädst (graphicx, mhchem): Das ist nie eine gute Idee. Lädt man ein Paket einfach nur so mehrmals kann das zur Verwirrung führen, lädt man es mit unterschiedlichen Optionen, dann kann es sogar Fehler geben (Stichwort "option clash"). Ferner solltest Du überprüfen, ob Du wirklich alle geladenen Pakete brauchst (lscape, transparent, textcomp, grffile).

Nun aber zu Deinem eigentlichen Problem: Du mischst zwei Methoden zur Erstellung von Literaturverzeichnissen. Zum einen hast Du mit

\usepackage[style=numeric-comp,backend=biber,sorting=none, isbn=false, doi=false,]{biblatex}
\DeclareFieldFormat{title}{#1\isdot}
\renewcommand*{\finentrypunct}{\addspace}

biblatex-Code da. Zum anderen nutzt Du den BibTeX-Befehl

\bibliographystyle{unsrt}

Und das gibt den Fehler ! Package biblatex Error: '\bibliographystyle' invalid., denn der BibTeX-Befehl \bibliographystyle ist mit biblatex schlicht nicht nutzbar. Die BibTeX-Fehlermeldung, von der Du berichtest, kommt von einem BibTeX-Lauf, der hier nicht angebracht ist, da biblatex mit Biber zusammen verwendet wird.

Du musst Dich für biblatex oder BibTeX entscheiden. Beides auf einmal geht nicht.

Mit biblatex sähe es wohl so aus

\documentclass[ngerman]{scrreprt}
\usepackage[T1]{fontenc}
\usepackage{babel}
\usepackage{csquotes}
\usepackage[backend=biber, style=numeric-comp, sorting=none, isbn=false, doi=false,]{biblatex}
\DeclareFieldFormat{title}{#1\isdot}
\renewcommand*{\finentrypunct}{}

\addbibresource{biblatex-examples.bib}

\begin{document}
Lorem \autocite{sigfridsson}

\printbibliography[title=Literaturverzeichnis, label=sec:Literatur]
\end{document}

kompiliert wird mit Biber (LaTeX, Biber, LaTeX, LaTeX).

Mit BibTeX so

\documentclass[ngerman]{scrreprt}
\usepackage[T1]{fontenc}
\usepackage{babel}

\begin{document}
Lorem \cite{doody}

\bibliographystyle{unsrt}
\bibliography{biblatex-examples}
\end{document}

kompiliert wird mit BibTeX (LaTeX, BibTeX, LaTeX, LaTeX).


forgood2
Forum-Anfänger
Forum-Anfänger
Beiträge: 19
Registriert: Do 28. Nov 2019, 23:46

Re: Fehler mit \bibliographystyle{unsrt}

Beitrag von forgood2 »

okay danke, hat geklappt.
Danke auch für die Tipps bezüglich meiner veralteten Vorlage. Die werde ich zeitnah umsetzen :)


Antworten