Fragezeichen statt Referenz auf Quelle

Erstellung eines Literaturverzeichnisses mit BibTeX, Biber, BibLaTeX und Co.
Tigerino
Forum-Newbie
Forum-Newbie
Beiträge: 4
Registriert: So 12. Jul 2020, 16:29

Fragezeichen statt Referenz auf Quelle

Beitrag von Tigerino »

Hallo! Ich bin absoluter Latex Neuling. Ich habe ein Literaturverzeichnis erstellt und es in meine Latex Dokument eingebunden, doch ich erhate bei \cite{referenz-auf-quelle} immer Fragezeichen.

meine literatur.bib Datei:

Code: Alles auswählen

@Book{kuck,
	author = {Udo Kuckartz},
	title = {Qualitative Inhaltsanalyse. Methoden, Praxis, Computerunterst\"uzung},
	publisher = {Beltz Juventa},
	year = {2018}
}

@online{uni, 
	author = {Carl von Ossietzky Universit\"at Oldenburg},
	title = {Leitbild für die Lehre an der Universit\"aet Oldenburg},
	year = 2020,
	url = {https://uol.de/leitbild-lehre},
	urldate = {22.07.2020}
	
}

@misc{gi,
author = {Gesellschaft für Informatik e.V.},
title = {Empfehlungen f\"ur Bachelor-und Masterprogramme im Studienfach Informatik an Hochschulen},
year = {2016}
}

Mein Latexdokument sieht zu Beginn wie folgt aus:

Code: Alles auswählen

\documentclass[a4paper,titlepage,bibtotoc,liststotoc,final,twoside,openright,cleardoubleempty,BCOR12mm]{scrreprt} % ABGABEFASSUNG

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[ngerman]{babel}
\usepackage{epsfig}
\usepackage{amsmath}
\usepackage{hyperref}
\usepackage{bibgerm}
\usepackage{breakurl}
\usepackage{ae,aecompl}
\usepackage{graphicx}
\usepackage{tabularx}
\usepackage{rotating}
\usepackage{lscape}
\usepackage{subfigure}
\usepackage{setspace}
\usepackage{gradientframe}
\usepackage{pgf-pie}
\usepackage{xcolor}
\usepackage{pgfplots}
\usepackage{comment}
\usepackage{color}
\usepackage{pdflscape}
\usepackage{colortbl}
\usepackage{pgfplots}
\pgfplotsset{compat=1.17}

% Abstände bei Trennzeichen für Zahlen korrekt machen
\mathcode`,="013B
\mathcode`.="613A

% Tex ist kein Zeichenprogramm...
\usepackage{tikz}
\usetikzlibrary{arrows,automata,shapes,topaths}

% Vorlage - Obere Linie, Seitenzahlen
\usepackage{scrpage2}
\pagestyle{scrheadings}
\clearscrheadfoot
\automark[section]{chapter}
\setheadsepline{.4pt}
\ihead[]{\leftmark}
\ohead[]{\rightmark}
\ofoot[\pagemark]{\pagemark}
\onehalfspacing
\setlength\abovecaptionskip{0.8pt}

% Index erstellen
\usepackage{makeidx}
\makeindex

Am Ende kommt:

Code: Alles auswählen

% Literaturverzeichnis...
\bibliographystyle{geralpha} 
\bibliography{literatur}

% Index ausgeben
\newpage
\printindex

Danke!


MoeWe
Forum-Guru
Forum-Guru
Beiträge: 265
Registriert: Fr 30. Aug 2019, 15:35
Kontaktdaten:

Re: Fragezeichen statt Referenz auf Quelle

Beitrag von MoeWe »

Hab leider gerade keine Zeit, mir Deinen Code genauer anzusehen, daher nur schnell die Frage, da ich auf den ersten Blick nichts sehen konnte, was hier für die Bibliographie ein so großes Problem sein sollte: Hast Du BibTeX laufen gelassen?

Ein Dokument mit Bibliographie wie bei Dir muss mit pdfLaTeX, Biber, pdfLaTeX, pdfLaTeX kompiliert werden (oder LaTeX statt pdfLaTeX). Warum ist ganz wunderbar in https://tex.stackexchange.com/q/63852/35864 erklärt. Wie hängt vom Editor ab, die meisten haben eine Schaltfläche und/oder einen Menüeintrag, um BibTeX laufen zu lassen. Eventuell steht da nicht direkt "BibTeX" sondern "Bibliographie-Tool" oder soetwas drauf, es kann also sein, dass Du etwas suchen musst.


Tigerino
Forum-Newbie
Forum-Newbie
Beiträge: 4
Registriert: So 12. Jul 2020, 16:29

Re: Fragezeichen statt Referenz auf Quelle

Beitrag von Tigerino »

Hallo! Ich benutze TexStudio. Wie stelle ich das an? Wenn ich mit Doppelklick auf die literatur.bib gehe öffnet sich ein TEXworks Editor. Danke!


MoeWe
Forum-Guru
Forum-Guru
Beiträge: 265
Registriert: Fr 30. Aug 2019, 15:35
Kontaktdaten:

Re: Fragezeichen statt Referenz auf Quelle

Beitrag von MoeWe »

TeXStudio hat soweit ich weiß, eine Heuristik, die bestimmt, ob BibTeX aufgerufen werden soll. Wenn also alles glatt läuft, dann ruft TeXStudio von sich aus BibTeX auf. Es kann aber durchaus sein, dass das aus irgendwelchen Gründen nicht richtig funktioniert, dann kannst Du BibTeX immer noch über das "Tools"-Menü aufrufen. Entweder über "Tools > Bibliography" (F8), wenn BibTeX Dein Standard-Bibliography-Tool ist, oder explizit über "Tools > Commands > BibTeX".

Beim Durchsehen Deiner Präambel ist mir aufgefallen, dass Du eine Reihe veralteter Pakete nutzt. Es sind aber auch insgesamt recht viele Pakete. Brauchst Du die alle? Weißt Du, was die Pakete, die Du lädst, tun?

Nur ein paar Dinge, die mir auf die Schnelle aufgefallen sind.

  • Brauchst Du epsfig? Eigentlich sollte man das nicht explizit laden.
  • hyperref sollte bis auf wenige dokumentierte Ausnahmen als letztes geladen werden.
  • breakurl brauchst Du höchstwahrscheinlich nicht, es wird nur gebraucht, wenn Du über DVI gehst.
  • ae und aecompl sind heutzutage veraltet.
  • color wird von xcolor geladen. Es reicht also, \usepackage{xcolor}. Das \usepackage{color} kann weg.
  • scrpage2 ist obsolet und inzwischen nicht mehr im normalen KOMA-Script-Bündel auf MikTeX und TeX Live verfügbar. Siehe https://komascript.de/faq_scrpage2_en.

Tatsächlich führt die Sache mit scrpage2 bei mir dazu, dass ich aus Deinem Code kein lauffähiges Beispiel basteln kann. Wenn ich scrpage2 durch den Nachfolger scrlayer-scrpage ersetze, kann ich zumindest eine kompilierbar Datei aufbauen.

Nur auf das für die Bibliographie wesentliche reduziert (beachte, dass ich hier die .bib-Datei mit filecontents erzeuge, das ist nur damit das Beispiel aus nur einer Datei besteht, im echten Leben würde die .bib-Datei auf anderem Wege von außerhalb der .tex-Datei erzeugt und verwaltet), kompiliert

Code: Alles auswählen

\documentclass[a4paper,titlepage,bibtotoc,liststotoc,final,twoside,openright,cleardoubleempty,BCOR12mm]{scrreprt} % ABGABEFASSUNG

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[ngerman]{babel}
\usepackage{amsmath}
\usepackage{bibgerm}

\usepackage{hyperref}

\begin{filecontents}{\jobname.bib}
@Book{kuck,
  author    = {Udo Kuckartz},
  title     = {Qualitative Inhaltsanalyse.
               Methoden, Praxis, Computerunterst{\"u}zung},
  publisher = {Beltz Juventa},
  year      = {2018},
}
@online{uni, 
  author  = {Carl von Ossietzky Universit{\"a}t Oldenburg},
  title   = {Leitbild für die Lehre an der Universit{\"a}t Oldenburg},
  year    = 2020,
  url     = {https://uol.de/leitbild-lehre},
  urldate = {22.07.2020},
}
@misc{gi,
  author = {{Gesellschaft für Informatik e.V.}},
  title  = {Empfehlungen f{\"u}r Bachelor- und Masterprogramme
  	        im Studienfach Informatik an Hochschulen},
  year   = {2016}
}
\end{filecontents}

\begin{document}
\cite{kuck,uni,gi}

\bibliographystyle{geralpha} 
\bibliography{\jobname}
\end{document}

bei mir, wenn ich pdfLaTeX, BibTeX, pdfLaTeX, pdfLaTeX aufrufe. Diese Aufrufe müssen alle auf der Haupt-.tex-Datei erfolgen. Keines dieser Programme wird auf der .bib-Datei ausgeführt. Im Editor sollte daher immer die .tex-Datei und nicht die .bib-Datei im Fokus sein, wenn Du irgendwelche Kompilier-Buttons drückst.

Zuletzt geändert von MoeWe am Fr 24. Jul 2020, 11:37, insgesamt 1-mal geändert.

gast

Re: Fragezeichen statt Referenz auf Quelle

Beitrag von gast »

Tigerino hat geschrieben:
Mi 22. Jul 2020, 19:12

Code: Alles auswählen

\documentclass[a4paper,titlepage,bibtotoc,liststotoc,final,twoside,openright,cleardoubleempty,BCOR12mm]{scrreprt} % ABGABEFASSUNG

Das sind ganz viele total veraltete Optionen dabei. Dazu gibt es auch jeweils eine Warnung, in der auch angegeben ist, wie es richtig geht. Da der KOMA-Script-Autor schon vor einiger Zeit angekündigt hat, KOMA-Script nach und nach von obsoleten Teilen zu befreien, sollte man sich dringend von diesen veralteten Optionen verabschieden. Schau also unbedingt in die log-Datei.

Tigerino hat geschrieben:
Mi 22. Jul 2020, 19:12

Code: Alles auswählen

\usepackage{ae,aecompl}

Das ist eine uralte Krücke aus der Zeit, als es noch keine adäquate Möglichkeit gab, Computer Modern im T1-Encoding zu verwenden. Seit es Latin Modern gibt, braucht man das nicht mehr und muss daher auch nicht mit den Einschränkungen dieser Krücke leben. Ersetze das also besser durch:

Code: Alles auswählen

\usepackage{lmodern}
Tigerino hat geschrieben:
Mi 22. Jul 2020, 19:12

Code: Alles auswählen

\usepackage{subfigure}

Das Paket subfigure wurde vor Jahrzehnten vom Autor selbst ersetzt. Es kann durchaus zu Problemen führen. Nachfolger und Alternative sind unter dem Paketlink angegeben.

Tigerino hat geschrieben:
Mi 22. Jul 2020, 19:12

Code: Alles auswählen

\usepackage{lscape}
\usepackage{pdflscape}

Das Paket lscape wird von pdflscape automatisch geladen. Es ergibt keinen Sinn, es vorher selbst zu laden.

Tigerino hat geschrieben:
Mi 22. Jul 2020, 19:12

Code: Alles auswählen

\usepackage{colortbl}

Zu color und xcolor hast du oben bereits Hinweise erhalten. Bei Verwendung von xcolor sollte man colortbl besser per xcolor-Option table laden lassen. Dabei erweitert und verbessert xcolor dann auch gleich die Möglichkeiten des Pakets.

Tigerino hat geschrieben:
Mi 22. Jul 2020, 19:12

Code: Alles auswählen

\usepackage{pgfplots}
\usepackage{tikz}

pgfplots lädt bereits tikz, so dass man das nicht danach noch selbst zu laden braucht.

Tigerino hat geschrieben:
Mi 22. Jul 2020, 19:12

Code: Alles auswählen

\setlength\abovecaptionskip{0.8pt}

0.8pt sind 0,3mm. Ich habe so meine Zweifel, dass da irgend jemand noch einen Abstand erkennen kann.

Tigerino hat geschrieben:
Mi 22. Jul 2020, 19:12

Code: Alles auswählen

\usepackage{germbib}
\bibliographystyle{geralpha} 

Das Paket germbib hat der Autor schon vor 17 Jahren durch babelbib ersetzt. babelbib wird noch gepflegt, das letzte Update stammt von 2019. Dagegen wird bibgerm AFAIK nicht mehr gepflegt und das letzte Update stammt von 2000. Bei babelbib (das übrigens natbib-kompatibel ist) gibt es übrigens neben babalpha zwei weitere alpha-Versionen zur Auswahl, die sich in der Formatierung der Autoren bezüglich Vorname und Nachname unterscheiden.

Bitte reiche min. die Informationen über die veralteten Pakete auch an denjenigen weiter, der die veraltete Vorlage verteilt.

Übrigens wird auch \usepackage[utf8]{inputenc} seit LaTeX 2018-04-01 nicht mehr benötigt. Allerdings gibt es wohl noch immer Linux-Distributionen, die TeX Live 2017 mit einem älteren LaTeX verteilen, so dass es durchaus ratsam sein kann, diese Zeile noch einige Zeit zu verwenden.


Antworten