Fehler in Aktualisierung bei neu gesetzten Referenzen

Erstellung eines Literaturverzeichnisses mit BibTeX, Biber, BibLaTeX und Co.
Faebs94
Forum-Anfänger
Forum-Anfänger
Beiträge: 17
Registriert: Mi 24. Jun 2020, 09:25

Fehler in Aktualisierung bei neu gesetzten Referenzen

Beitrag von Faebs94 »

Hallo Leute,

ich bin noch gänzlich neu hier und bei LaTeX, also verzeiht mir bitte forenuntypisches Verhalten.

Ich habe folgendes Problem: Immer wenn ich ins Literaturverzeichnis und im Dokument einen neuen Verweis einfüge, taucht dieser nicht auf, es erscheint nur [?] im Text. Auch im Anhang wird der Eintrag nicht hinzugefügt, wenn ich in TexWorks aber auf die Litverzeichnis.bib Datei wechsle, dann ist dort der Eintrag zu finden.

Ebenso sehr merkwürdig scheint mir, dass obwohl ich meinem Verständnis nach eingestellt habe, dass die Referenzen mit Nummern belegt werden sollen, LaTeX Abkürzungen setzt, wie z.B. [Vog] und der Gleichen.

Als Editor benutze ich wie gesagt TexWorks, zur Erstellung, Verwaltung und Hinzufügen neuer Referenzen benutze ich JabRef, dort kopiere ich auch die bibKeys heraus. Wenn ich lange genug rum spiele, probiere, schließe, öffne und neu lade dann ist die Referenz irgendwann da, aber ich verstehe nicht warum und die letzte bekomme ich leider gar nicht zu Gesicht.

Wenn ich meinen Code auf das für euch wichtigste herunterbreche (ich lass die Packages mal alle drin, falls da welche untereinander Probleme machen, da ich blutiger Anfänger bin und immer nur die kopiert und eingefügt habe, die mir die Quellen der jeweiligen Aufgabe gesagt haben) sieht das ganze etwa so aus:

Code: Alles auswählen

\documentclass[bibliography=numbered]{scrreprt}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[ngerman]{babel}
\usepackage{algorithm}
\usepackage{algorithmic}
\usepackage[onehalfspacing]{setspace}
\usepackage{tikz}
\usepackage[headsepline]{scrlayer-scrpage}
\pagestyle{scrheadings}
\usepackage{amsmath}
\usepackage{amsthm}
\usepackage{amssymb}
\usepackage{url}
\usepackage{graphicx}
\usepackage[ngerman]{varioref}
\usetikzlibrary{matrix,fadings,calc,positioning,
				decorations.pathreplacing,arrows}				
\newtheorem{theorem}{Theorem}[section]
\newtheorem{corollary}{Corollary}[theorem]
\newtheorem{lemma}[theorem]{Lemma}

\theoremstyle{definition}
\newtheorem{definition}{Definition}[section]

\definecolor{bluekeywords}{rgb}{0,0,1}
\definecolor{greencomments}{rgb}{0,0.5,0}
\definecolor{redstrings}{rgb}{0.64,0.08,0.08}
\definecolor{xmlcomments}{rgb}{0.5,0.5,0.5}
\definecolor{types}{rgb}{0.17,0.57,0.68}

\usepackage{listings}
\lstset{language=[Sharp]C,
captionpos=b,
numbers=left, %Nummerierung
numberstyle=\tiny, % kleine Zeilennummern
frame=lines, % Oberhalb und unterhalb des Listings ist eine Linie
showspaces=false,
showtabs=false,
breaklines=true,
showstringspaces=false,
breakatwhitespace=true,
escapeinside={(*@}{@*)},
commentstyle=\color{greencomments},
morekeywords={partial, var, value, get, set},
keywordstyle=\color{bluekeywords},
stringstyle=\color{redstrings},
basicstyle=\ttfamily\small,
tabsize=1,
literate={\ \ }{{\ }}1,
}



\usepackage[square,numbers]{natbib}
\bibliographystyle{unsrt}

\automark{section}

\begin{document}

Hier steht dann interessantes und weniger interessantes Zeugs mit Verweisen, wie etwa: \cite{doi:10.1080/01638539809545028}. 

Dann kommt wieder viel anderes Zeugs mit ähnlichen Verweisen und ganz unten dann

\newpage
\bibliography{Litverzeichnis.bib}


\end{document}

Beim Kompilieren habe ich (nach Internetanleitung) folgende Methode benutzerdefiniert und führe diese Reihenfolge durch:

PDFLatex -> Bibtex -> PDFLatex -> PDFLatex -> PDF anzeigen

Wenn das ein simpler Fehler ist, den es schon tausendmal gab, entschuldige ich mich, aber ich habe nichts gefunden, das mir geholfen hat oder es einfach falsch umgesetzt.

BIn für jede Hilfe dankbar :D , beste Grüße
Faebs94


markusv
Forum-Meister
Forum-Meister
Beiträge: 857
Registriert: Do 3. Sep 2015, 17:20
Wohnort: Leipzig

Re: Fehler in Aktualisierung bei neu gesetzten Referenzen

Beitrag von markusv »

Hallo und willkommen im Forum!

Was du beschreibst, ist der normale Durchlauf, um eine Referenz korrekt in LaTeX abzubilden:

Der Ablauf und Sinn dahinter ist im Groben Folgender:
Der erste LaTeX-Lauf identifizert alle \cite{}-Befehle und schreibt diese in eine Datei. bibtex greift dann auf diese Datei zu und verknüpft diese mit deiner Bibliografie und vergibt die richtigen Referenzierungen (numerisch, Autor/Jahr, je nach Einstellung). Durch das noch zweimalige Kompilieren wird sichergestellt, dass alle Einträge im Text und im Literaturverzeichnis richtig sind.

Wenn es keinen driftigen Grund gibt, würde ich auf biblatex und biber umsteigen.

Zu deinem Code kann ich Dir die Lektüre von https://komascript.de/latexvorlage empfehlen. Viele deiner Pakete sind veraltet oder überflüssig.

Wäre Microsoft Word für das Schreiben von Büchern entwickelt worden,
würde es Microsoft Book heißen.

Unkomplizierte und schnelle LaTeX-Hilfe, bspw. Erstellung von Vorlagen und Bewerbungen:
Help-LaTeX@web.de

Faebs94
Forum-Anfänger
Forum-Anfänger
Beiträge: 17
Registriert: Mi 24. Jun 2020, 09:25

Re: Fehler in Aktualisierung bei neu gesetzten Referenzen

Beitrag von Faebs94 »

Danke für die fixe Antwort, hab leider in der Bahn festgesteckt^^

Für die Zukunft werde ich mich da mal bzgl. modernerer Pakete und biblatex/biber umsteigen. Nur leider ist die Arbeit jetzt quasi fast fertig, bis auf ein paar Kleinigkeiten, unter anderem die Verweise und da die Abgabe auch kurz bevor steht, wollte ich es ganz gerne so zumLaufen bekommen, wenn das möglich ist.

Genau deine Erklärung habe ich so auch gefunden und deshalb die Reihenfolge so gesetzt. Jetzt verstehe ich aber leider nicht, warum es dann nicht das tut, was es soll, fehlt doch noch irgendwas?


markusv
Forum-Meister
Forum-Meister
Beiträge: 857
Registriert: Do 3. Sep 2015, 17:20
Wohnort: Leipzig

Re: Fehler in Aktualisierung bei neu gesetzten Referenzen

Beitrag von markusv »

Was genau fehlt denn? Leider ist dein Minimalbeispiel nicht brauchbar, da uns der bib-Eintrag zum cite-Befehl fehlt. Lösche ggf. mal alle Hilfsdateien wie .log, .aux etc. und kompilier dann nochmal komplett neu nach dem vorgegebenen Ablauf. Wenn es dann immer noch nicht funktioniert, poste die .log-Datei hier. Dort werden alle Fehler dokumentiert.

Wäre Microsoft Word für das Schreiben von Büchern entwickelt worden,
würde es Microsoft Book heißen.

Unkomplizierte und schnelle LaTeX-Hilfe, bspw. Erstellung von Vorlagen und Bewerbungen:
Help-LaTeX@web.de

Faebs94
Forum-Anfänger
Forum-Anfänger
Beiträge: 17
Registriert: Mi 24. Jun 2020, 09:25

Re: Fehler in Aktualisierung bei neu gesetzten Referenzen

Beitrag von Faebs94 »

Habe aux und log gelöscht und neu compiliert, aber leider wieder mit gleichem Problem :(

Der bib Eintrag ist der folgende:

@Article{doi:10.1080/01638539809545028,
author = {Thomas K Landauer and Peter W. Foltz and Darrell Laham},
title = {An introduction to latent semantic analysis},
doi = {10.1080/01638539809545028},
eprint = {https://doi.org/10.1080/01638539809545028},
number = {2-3},
pages = {259-284},
url = {https://doi.org/10.1080/01638539809545028},
volume = {25},
journal = {Discourse Processes},
publisher = {Routledge},
year = {1998},
}

und wie gesagt, statt diesen zu referenzieren und im Literaturverzeichnis anzugeben, fehlt dieser dort und im Tetx wird nur [?] eingetragen.

Die anderen Verweise werden korrekt angezeigt, merkwürdigerweise aber nicht mit Nummern, sondern Buchstabenabkürzung (z.B. [Vog]) obwohl ich nach meinem Verständnis Nummerierung im Header eingestellt habe.

Habe in der Log Datei folgenden Vermerk bzgl. der Referenz bzw natbib gefunden:

Package natbib Warning: Citation `doi:10.1080/01638539809545028' on page 26 und
efined on input line 625.

[26

] [27] [28] [29] [30]
chapter 5.

....hier steht dann ein paar warnings bzgl overefull oder underfull boxes und ähnliches....

Package natbib Warning: There were undefined citations.

[94

] (Masterarbeit.aux)

LaTeX Warning: There were undefined references.

)

Werde daraus aber auch nicht viel schlauer :|


markusv
Forum-Meister
Forum-Meister
Beiträge: 857
Registriert: Do 3. Sep 2015, 17:20
Wohnort: Leipzig

Re: Fehler in Aktualisierung bei neu gesetzten Referenzen

Beitrag von markusv »

Meine Bitte war, alle Hilfsdateien zu löschen, .aux und .log waren nur Beispiele.
Also alle von LaTeX erstellten Dateien außer .tex, .bib. Alternativ kannst du die .tex und .bib-Datei einfach in einen neuen Ordner packen und dort neu kompilieren.

Erstelle ich ein echtes Minimalbeispiel mit deiner Beispielreferenz, erhalte ich ohne Probleme nach pdflatex, bibtex, pdflatex, pdflatex die gewünschte Ausgabe:

Code: Alles auswählen

\begin{filecontents}{Litverzeichnis.bib}
	@Article{doi:10.1080/01638539809545028,
		author = {Thomas K Landauer and Peter W. Foltz and Darrell Laham},
		title = {An introduction to latent semantic analysis},
		doi = {10.1080/01638539809545028},
		eprint = {https://doi.org/10.1080/01638539809545028},
		number = {2-3},
		pages = {259-284},
		url = {https://doi.org/10.1080/01638539809545028},
		volume = {25},
		journal = {Discourse Processes},
		publisher = {Routledge},
		year = {1998},
	}
\end{filecontents}
\documentclass[bibliography=numbered]{scrreprt}
\usepackage[T1]{fontenc}
\usepackage[ngerman]{babel}

\usepackage[square,numbers]{natbib}
\bibliographystyle{unsrt}

\begin{document}
\cite{doi:10.1080/01638539809545028}
\bibliography{Litverzeichnis.bib}
\end{document}

Probier ggf. diesen Schnipsel in einem neuen Ordner zu kompilieren und poste bei Fehlern den kompletten Inhalt der .log-Datei hier in der Code-Umgebung.

Wäre Microsoft Word für das Schreiben von Büchern entwickelt worden,
würde es Microsoft Book heißen.

Unkomplizierte und schnelle LaTeX-Hilfe, bspw. Erstellung von Vorlagen und Bewerbungen:
Help-LaTeX@web.de

Faebs94
Forum-Anfänger
Forum-Anfänger
Beiträge: 17
Registriert: Mi 24. Jun 2020, 09:25

Re: Fehler in Aktualisierung bei neu gesetzten Referenzen

Beitrag von Faebs94 »

War da wohl etwas zu ängstlich... Habe jetzt alle Dateien gelöscht gehabt, außer tex, bib und meinem Quellcode, der für den Anhang eingelesen wird, aber leider hat auch das nicht geholfen.

Habe auch das Minimalbeispiel von dir kopiert und laufen lassen, selbes Ergebnis. Las Referenz nur ein [?] und auch kein Verzeichnis am Textende.

Hier der Inhalt der Log Datei des Minimalbeispiels:

Code: Alles auswählen

This is pdfTeX, Version 3.14159265-2.6-1.40.21 (MiKTeX 2.9.7350 64-bit) (preloaded format=pdflatex 2020.4.22)  25 JUN 2020 08:50
entering extended mode
**./ProbeForum.tex
(ProbeForum.tex
LaTeX2e <2020-02-02> patch level 5
L3 programming layer <2020-03-06>

LaTeX Warning: File `Litverzeichnis.bib' already exists on the system.
               Not generating it from this source.

(C:\Users\fabia\AppData\Roaming\MiKTeX\2.9\tex/latex/koma-script\scrreprt.cls
Document Class: scrreprt 2020/04/19 v3.30 KOMA-Script document class (report)
(C:\Users\fabia\AppData\Roaming\MiKTeX\2.9\tex/latex/koma-script\scrkbase.sty
Package: scrkbase 2020/04/19 v3.30 KOMA-Script package (KOMA-Script-dependent b
asics and keyval usage)

(C:\Users\fabia\AppData\Roaming\MiKTeX\2.9\tex/latex/koma-script\scrbase.sty
Package: scrbase 2020/04/19 v3.30 KOMA-Script package (KOMA-Script-independent 
basics and keyval usage)

("C:\Program Files\MiKTeX 2.9\tex/latex/graphics\keyval.sty"
Package: keyval 2014/10/28 v1.15 key=value parser (DPC)
\KV@toks@=\toks15
)
(C:\Users\fabia\AppData\Roaming\MiKTeX\2.9\tex/latex/koma-script\scrlfile.sty
Package: scrlfile 2020/04/19 v3.30 KOMA-Script package (loading files)
))) (C:\Users\fabia\AppData\Roaming\MiKTeX\2.9\tex/latex/koma-script\tocbasic.s
ty
Package: tocbasic 2020/04/19 v3.30 KOMA-Script package (handling toc-files)
\scr@dte@tocline@numberwidth=\skip47
\scr@dte@tocline@numbox=\box45
)
Package tocbasic Info: omitting babel extension for `toc'
(tocbasic)             because of feature `nobabel' available
(tocbasic)             for `toc' on input line 137.
Class scrreprt Info: File `scrsize11pt.clo' used instead of
(scrreprt)           file `scrsize11.clo' to setup font sizes on input line 242
4.

(C:\Users\fabia\AppData\Roaming\MiKTeX\2.9\tex/latex/koma-script\scrsize11pt.cl
o
File: scrsize11pt.clo 2020/04/19 v3.30 KOMA-Script font size class option (11pt
)
)
(C:\Users\fabia\AppData\Roaming\MiKTeX\2.9\tex/latex/koma-script\typearea.sty
Package: typearea 2020/04/19 v3.30 KOMA-Script package (type area)
\ta@bcor=\skip48
\ta@div=\count167
\ta@hblk=\skip49
\ta@vblk=\skip50
\ta@temp=\skip51
\footheight=\skip52
Package typearea Info: These are the values describing the layout:
(typearea)             DIV  = 10
(typearea)             BCOR = 0.0pt
(typearea)             \paperwidth      = 597.50793pt
(typearea)              \textwidth      = 418.25555pt
(typearea)              DIV departure   = -6%
(typearea)              \evensidemargin = 17.3562pt
(typearea)              \oddsidemargin  = 17.3562pt
(typearea)             \paperheight     = 845.04694pt
(typearea)              \textheight     = 595.80026pt
(typearea)              \topmargin      = -25.16531pt
(typearea)              \headheight     = 17.0pt
(typearea)              \headsep        = 20.40001pt
(typearea)              \topskip        = 11.0pt
(typearea)              \footskip       = 47.6pt
(typearea)              \baselineskip   = 13.6pt
(typearea)              on input line 1738.
)
\c@part=\count168
\c@chapter=\count169
\c@section=\count170
\c@subsection=\count171
\c@subsubsection=\count172
\c@paragraph=\count173
\c@subparagraph=\count174
\scr@dte@chapter@maxnumwidth=\skip53
Class scrreprt Info: using compatibility default `afterindent=bysign'
(scrreprt)           for `\chapter on input line 5588.
\scr@dte@section@maxnumwidth=\skip54
Class scrreprt Info: using compatibility default `runin=bysign'
(scrreprt)           for `\section on input line 5598.
Class scrreprt Info: using compatibility default `afterindent=bysign'
(scrreprt)           for `\section on input line 5598.
\scr@dte@part@maxnumwidth=\skip55
Class scrreprt Info: using compatibility default `afterindent=true'
(scrreprt)           for `\part on input line 5607.
\scr@dte@subsection@maxnumwidth=\skip56
Class scrreprt Info: using compatibility default `runin=bysign'
(scrreprt)           for `\subsection on input line 5617.
Class scrreprt Info: using compatibility default `afterindent=bysign'
(scrreprt)           for `\subsection on input line 5617.
\scr@dte@subsubsection@maxnumwidth=\skip57
Class scrreprt Info: using compatibility default `runin=bysign'
(scrreprt)           for `\subsubsection on input line 5627.
Class scrreprt Info: using compatibility default `afterindent=bysign'
(scrreprt)           for `\subsubsection on input line 5627.
\scr@dte@paragraph@maxnumwidth=\skip58
Class scrreprt Info: using compatibility default `runin=bysign'
(scrreprt)           for `\paragraph on input line 5637.
Class scrreprt Info: using compatibility default `afterindent=bysign'
(scrreprt)           for `\paragraph on input line 5637.
\scr@dte@subparagraph@maxnumwidth=\skip59
Class scrreprt Info: using compatibility default `runin=bysign'
(scrreprt)           for `\subparagraph on input line 5647.
Class scrreprt Info: using compatibility default `afterindent=bysign'
(scrreprt)           for `\subparagraph on input line 5647.
\abovecaptionskip=\skip60
\belowcaptionskip=\skip61
\c@pti@nb@sid@b@x=\box46
Package tocbasic Info: omitting babel extension for `lof'
(tocbasic)             because of feature `nobabel' available
(tocbasic)             for `lof' on input line 6883.
\scr@dte@figure@maxnumwidth=\skip62
\c@figure=\count175
Package tocbasic Info: omitting babel extension for `lot'
(tocbasic)             because of feature `nobabel' available
(tocbasic)             for `lot' on input line 6900.
\scr@dte@table@maxnumwidth=\skip63
\c@table=\count176
Class scrreprt Info: Redefining `\numberline' on input line 7069.
\bibindent=\dimen134
) ("C:\Program Files\MiKTeX 2.9\tex/latex/base\fontenc.sty"
Package: fontenc 2020/02/11 v2.0o Standard LaTeX package
)
("C:\Program Files\MiKTeX 2.9\tex/generic/babel\babel.sty"
Package: babel 2020/02/28 3.41 The Babel package

("C:\Program Files\MiKTeX 2.9\tex/generic/babel\switch.def"
File: switch.def 2020/02/28 3.41 Babel switching mechanism
)
*************************************
* Local config file bblopts.cfg used
*
("C:\Program Files\MiKTeX 2.9\tex/latex/arabi\bblopts.cfg"
File: bblopts.cfg 2005/09/08 v0.1 add Arabic and Farsi to "declared" options of
 babel
)
(C:\Users\fabia\AppData\Roaming\MiKTeX\2.9\tex/latex/babel-german\ngerman.ldf
Language: ngerman 2018/12/08 v2.11 German support for babel (post-1996 orthogra
phy)

(C:\Users\fabia\AppData\Roaming\MiKTeX\2.9\tex/latex/babel-german\ngermanb.ldf
Language: ngermanb 2018/12/08 v2.11 German support for babel (post-1996 orthogr
aphy)

("C:\Program Files\MiKTeX 2.9\tex/generic/babel\babel.def"
File: babel.def 2020/02/28 3.41 Babel common definitions
\babel@savecnt=\count177
\U@D=\dimen135

("C:\Program Files\MiKTeX 2.9\tex/generic/babel\txtbabel.def")
\bbl@readstream=\read2
\bbl@dirlevel=\count178
)
Package babel Info: Making " an active character on input line 121.
)))
(C:\Users\fabia\AppData\Roaming\MiKTeX\2.9\tex/latex/natbib\natbib.sty
Package: natbib 2010/09/13 8.31b (PWD, AO)
\bibhang=\skip64
\bibsep=\skip65
LaTeX Info: Redefining \cite on input line 694.
\c@NAT@ctr=\count179
)
("C:\Program Files\MiKTeX 2.9\tex/latex/l3backend\l3backend-pdfmode.def"
File: l3backend-pdfmode.def 2020-03-12 L3 backend support: PDF mode
\l__kernel_color_stack_int=\count180
\l__pdf_internal_box=\box47
)
(ProbeForum.aux)
\openout1 = `ProbeForum.aux'.

LaTeX Font Info:    Checking defaults for OML/cmm/m/it on input line 23.
LaTeX Font Info:    ... okay on input line 23.
LaTeX Font Info:    Checking defaults for OMS/cmsy/m/n on input line 23.
LaTeX Font Info:    ... okay on input line 23.
LaTeX Font Info:    Checking defaults for OT1/cmr/m/n on input line 23.
LaTeX Font Info:    ... okay on input line 23.
LaTeX Font Info:    Checking defaults for T1/cmr/m/n on input line 23.
LaTeX Font Info:    ... okay on input line 23.
LaTeX Font Info:    Checking defaults for TS1/cmr/m/n on input line 23.
LaTeX Font Info:    ... okay on input line 23.
LaTeX Font Info:    Checking defaults for OMX/cmex/m/n on input line 23.
LaTeX Font Info:    ... okay on input line 23.
LaTeX Font Info:    Checking defaults for U/cmr/m/n on input line 23.
LaTeX Font Info:    ... okay on input line 23.


Package natbib Warning: Citation `doi:10.1080/01638539809545028' on page 1 unde
fined on input line 24.

No file ProbeForum.bbl.

Package natbib Warning: There were undefined citations.

[1

{C:/Users/fabia/AppData/Local/MiKTeX/2.9/pdftex/config/pdftex.map}]
(ProbeForum.aux) ) 
Here is how much of TeX's memory you used:
 4215 strings out of 480934
 81109 string characters out of 2909682
 450079 words of memory out of 3000000
 20109 multiletter control sequences out of 15000+200000
 534190 words of font info for 27 fonts, out of 3000000 for 9000
 1141 hyphenation exceptions out of 8191
 43i,6n,72p,10131b,320s stack positions out of 5000i,500n,10000p,200000b,50000s
 <C:\Users\fabia\AppData\Local\MiKTeX\2.9\fonts/pk/ljfour/jkn
appen/ec/dpi600\ecbx1095.pk> <C:\Users\fabia\AppData\Local\MiKTeX\2.9\fonts/pk/
ljfour/jknappen/ec/dpi600\ecrm1095.pk>
Output written on ProbeForum.pdf (1 page, 2979 bytes).
PDF statistics:
 18 PDF objects out of 1000 (max. 8388607)
 0 named destinations out of 1000 (max. 500000)
 1 words of extra memory for PDF output out of 10000 (max. 10000000)

Schonmal zwischendirn ein dickes Danke dir!!!


markusv
Forum-Meister
Forum-Meister
Beiträge: 857
Registriert: Do 3. Sep 2015, 17:20
Wohnort: Leipzig

Re: Fehler in Aktualisierung bei neu gesetzten Referenzen

Beitrag von markusv »

Laut log wird keine bbl-Datei gefunden, was letztlich bedeutet, dass du bibtex nicht richtig ausgeführt hast oder es da einen Fehler gab.

Code: Alles auswählen

No file ProbeForum.bbl.

Findest du die bbl in deinem Ordner bzw. die dazugehörige Log-Datei des bibtex-Laufes mit der Endung .blg?

Wäre Microsoft Word für das Schreiben von Büchern entwickelt worden,
würde es Microsoft Book heißen.

Unkomplizierte und schnelle LaTeX-Hilfe, bspw. Erstellung von Vorlagen und Bewerbungen:
Help-LaTeX@web.de

Faebs94
Forum-Anfänger
Forum-Anfänger
Beiträge: 17
Registriert: Mi 24. Jun 2020, 09:25

Re: Fehler in Aktualisierung bei neu gesetzten Referenzen

Beitrag von Faebs94 »

Wenn ich es richtig sehe, taucht da weder was mit der Endung bbl noch mit blg auf.

Keine Ahnung, ob das hilft, aber die Dateien im Ordner sind folgende:

LVZ.bib
LVZ.bib.bak
LVZ.bib.sav
MA.aux
MA.log
Ma.pdf
Ma.synctex(busy)
MA.synctex.gz
MA.tex
Ma.toc

Und Bilder/Code zum Einlesen

ahh mist, war ja jetzt im falschen Ordner, in dem Ordner mit dem Minimalbeispiel, da sind die bbl und blg Dateien da

der Rest, bis auf die busy Datei, auch wie oben


markusv
Forum-Meister
Forum-Meister
Beiträge: 857
Registriert: Do 3. Sep 2015, 17:20
Wohnort: Leipzig

Re: Fehler in Aktualisierung bei neu gesetzten Referenzen

Beitrag von markusv »

Deine bib-Datei heißt anscheinend LVZ.bib, bibtex sucht in deinem Ordner aber nach einer Litverzeichnis.bib, da du dies mit

Code: Alles auswählen

\bibliography{Litverzeichnis.bib}

festlegst.
Ändere die entsprechende Zeile also zu

Code: Alles auswählen

\bibliography{LVZ}

und probiere es erneut.

Wäre Microsoft Word für das Schreiben von Büchern entwickelt worden,
würde es Microsoft Book heißen.

Unkomplizierte und schnelle LaTeX-Hilfe, bspw. Erstellung von Vorlagen und Bewerbungen:
Help-LaTeX@web.de

Antworten