Seite 1 von 1

Fehlermeldung

Verfasst: Mi 8. Nov 2017, 13:24
von nixversteh
Moin User,

ich bekomme beim Kompilieren neuerdings diese Fehlermeldungen:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!
! LaTeX error: "kernel/command-already-defined"
!
! Control sequence \latinencoding already defined.
!
! See the LaTeX3 documentation for further information.
!
! For immediate help type H <return>.
!...............................................

l.121 \tl_new:N \latinencoding

|'''''''''''''''''''''''''''''''''''''''''''''''
| This is a coding error.
|
| LaTeX has been asked to create a new control sequence '\latinencoding' but
| this name has already been used elsewhere.
|
| The current meaning is:
| macro:->TU
|...............................................

Hier ein Beispielcode:

Code: Alles auswählen

\documentclass[a4paper,10pt]{scrartcl}
\usepackage[ngerman]{babel}
\usepackage{xltxtra}
\setromanfont[Mapping=tex-text]{Linux Libertine O}
\begin{document}
\section{TEST}
bla bla
\end{document}
Vielen Dank für Tipps

Verfasst: Mi 8. Nov 2017, 13:51
von u_fischer
Zeige die log-Datei. \setromanfont ist übrigens veraltet, das heißt schon lange \setmainfont.

...

Verfasst: Mi 8. Nov 2017, 14:08
von nixversteh
... ich habe eine neue Datei von kile erstellen lassen, habe nichts verändert, außer den Autor zu löschen.

EDIT: Wenn ich babel auskommentiere, läuft es???

Off-Topic: Veraltete Pakete

Verfasst: Mi 8. Nov 2017, 14:33
von Gast
In letzter Zeit verwenden wieder viele das veraltete xltxtra. Besser einfach erst einmal nur fontspec und ggf. das eine oder andere zusätzliche Paket wie realscripts.

Verfasst: Mi 8. Nov 2017, 14:37
von Gast

Code: Alles auswählen

\documentclass[a4paper,10pt]{scrartcl}
\usepackage{fontspec}
\usepackage[ngerman]{babel}
\setmainfont[Mapping=tex-text]{Linux Libertine O}
\begin{document}
\section{TEST}
bla bla
\end{document}
funktioniert bei mir. Noch besser ist aber IMHO:

Code: Alles auswählen

\documentclass[a4paper,10pt]{scrartcl}
\usepackage{libertine}
\usepackage[ngerman]{babel}
\begin{document}
\section{TEST}
bla bla
\end{document}

...

Verfasst: Mi 8. Nov 2017, 14:45
von nixversteh
@alle Helfer,

vielen Dank, die Zeilen

Code: Alles auswählen

\usepackage{fontspec}
\usepackage[ngerman]{babel}
müssen in dieser Reihenfolge stehen, dann läuft es bei mir.

Verfasst: Mi 8. Nov 2017, 16:36
von u_fischer
Reihenfolge ändern hilft, aber es sollte dennoch nicht sein und ich werde Will schreiben.

...

Verfasst: Mi 8. Nov 2017, 16:57
von nixversteh
@u_fischer,

vielen Dank

Verfasst: Mi 8. Nov 2017, 17:57
von u_fischer
Es ist tatsächlich schon gemeldet worden und wird mit dem nächsten Update wieder ok sein:

https://github.com/wspr/fontspec/issues/312

...

Verfasst: Mi 8. Nov 2017, 22:38
von nixversteh
@u_fischer,

vielen Dank für deine Rückmeldung