Punkt im Inhaltsverzeichnis nach der Nummerierung

Fragen zum richtigen Zitieren oder zum richtigen Format, dann gehört es hier rein.
Dan

Minimalbeispiel

Beitrag von Dan »

Folgendes Minimalbeispiel zeigt mein Problem.

Code: Alles auswählen

\documentclass{scrbook} 

\begin{document} 
\tableofcontents 
\chapter{Eins} 
\section{Eins} 

\appendix 

%Abbildungsverzeichnis
\listoffigures

%Tabellenverzeichnis
\listoftables

\end{document}

steve
Forum-Anfänger
Forum-Anfänger
Beiträge: 45
Registriert: Mi 9. Jul 2008, 12:59
Wohnort: Magdeburg

Beitrag von steve »

Moin,

das ist ja auch klar, da in deinem Beispiel keine Nummerierung durch einen Buchstaben erfolgt.

Code: Alles auswählen

\documentclass{scrbook}

\begin{document}
\tableofcontents
\chapter{Eins}
\section{Eins}

\appendix
\chapter{Test}
%Abbildungsverzeichnis
\listoffigures

%Tabellenverzeichnis
\listoftables

\end{document}
Gruß
Alex
>> Output written on...

Dan

Beitrag von Dan »

Also bei mir ist listoftables und listoffigures ganz klar mit Buchstaben nummeriert. Im original steht sogar ein
\let\stdchapter\chapter
\def\chapter*#1{\stdchapter{#1}}
\printglossaries%[type=glossar,style=altlist]
\let\chapter\stdchapter

Und auch das ist mit einem Buchstaben nummeriert.

Benutzeravatar
Stefan Kottwitz
Admin
Admin
Beiträge: 2012
Registriert: Di 8. Jul 2008, 00:39
Kontaktdaten:

Beitrag von Stefan Kottwitz »

Hallo Dan,

zeigt obiges Minimalbeispiel wirklich das Problem? Damit sollten nämlich beide Verzeichnisse gar nicht nummeriert werden.
Mit der später angegebenen Redefinition von \chapter* werden sie nummeriert, damit lässt sich das Problem nachvollziehen. Dann liegt das Fehlschlagen des Automatismus vmtl. an diesem Trick. Natürlich hilft hier die pointednumbers-Option. Ich schaue nachher mal nach, warum der Automatismus dann nicht klappt, evtl. schreibt ja auch schon Markus etwas dazu.

Viele Grüße,

Stefan

Benutzeravatar
KOMA
TeX-Entwickler
TeX-Entwickler
Beiträge: 2662
Registriert: Fr 4. Jul 2008, 17:28
Kontaktdaten:

Beitrag von KOMA »

Also zunächst einmal zeigt das Minimalbeispiel das Problem nicht, weil dabei garantiert keine Verzeichnisse nummeriert werden. Erst mit dem zusätzlichen Code bekommt das einen Sinn, wenn man den Code an der richtigen Stelle sinngemäß einbaut - oder statt diesem Hack gleich die passenden KOMA-Script-Optionen setzt.

Das Problem mit dem nicht erkannten Buchstaben bei dem Hack (den man für Abbildungs- und Tabellenverzeichnis bei KOMA-Script nicht braucht) ist, dass der Grouplevel nicht stimmt. KOMA-Script ermittelt zwar, dass der Punkt gesetzt werden müsste, merkt sich das aber bei den Verzeichnissen nicht. Dass das bisher noch niemandem aufgefallen ist, liegt vermutlich daran, dass Verzeichnisse eigentlich keine Anhänge sind und deshalb eigentlich auch nicht nummeriert werden sollten. Ich weiß, es gibt sogar Verlage, die so etwas veröffentlichen, ich muss es aber trotzdem nicht gut finden.

Wie dem auch sei: Das ist ein Bug in KOMA-Script seit Urzeiten. Es wird also nach 3.00RC1 (seit heute verfügbar) auch noch ein 3.00RC2 geben. Mit der svn-Version funktioniert

Code: Alles auswählen

\documentclass[listof=numbered]{scrbook}

\begin{document}
\tableofcontents
\chapter{Test}
\appendix
\listoffigures
\listoftables
\end{document}
jedenfalls jetzt.

Abendwind
Forum-Anfänger
Forum-Anfänger
Beiträge: 32
Registriert: Mi 13. Mai 2009, 10:57

Beitrag von Abendwind »

Hallo

Ich benutze die Dokumentenklasse "scrreprt" und hätte gerne einen Punkt hinter den Gliederungsnummern.

1.
1.1.
1.1.1.

wie bekomme ich das hin?

Wie integriere ich den Befehl?

DonCube
Forum-Guru
Forum-Guru
Beiträge: 292
Registriert: So 29. Jun 2008, 21:17
Wohnort: Bocholt

Beitrag von DonCube »

Solche Punkte werden nicht einfach auf Wunsch eingefügt. Da gibt es nach dem Duden ganz klare Regeln, wann Punkte zu setzen sind und wann nicht. Wenn du dich über diese Regeln dennoch hinwegsetzen möchtest, kannst du dies mit den Optionen im zweiten Beitrag dieses Themas tun.

Code: Alles auswählen

\documentclass[
  pointednumbers,  % Überschriftnummerierung mit Punkt, siehe DUDEN !
 %pointlessnumbers, % Überschriftnummerierung ohne Punkt, siehe DUDEN ! 
]{scrreprt}

\usepackage[ngerman]{babel}
\usepackage{blindtext}

\begin{document}
\tableofcontents
\blinddocument
\end{document} 
Gruß
DonCube
Schau mal hier rein goLaTeX-Wiki, und gaaaanz wichtig Minimalbeispiel

Abendwind
Forum-Anfänger
Forum-Anfänger
Beiträge: 32
Registriert: Mi 13. Mai 2009, 10:57

Beitrag von Abendwind »

Hallo DonCube.

Vielen Dank für diesen Hinweis.
Ich habe mir das Dudenzitat, welches der Koma gepostet hat, durchgelesen und bin zu dem Schluss gekommen, da ich das Abbildungs,-Tabllen,- Abkürzungverzeichnis mit römischen Ziffern nummeriert habe, hinter die Nummerierung ein Punkt gehört.

Kann das jemand bestätigen?

Jay

Punkt im Inhaltsverz. bei Einträgen ohne Nummer

Beitrag von Jay »

Hallo,

wenn ich \appendix verwende gehört ja wie oben geschildert ein Punkt hinter jede Nummer (arabische, römische Ziffern + Buchstaben).

Blöd nur, dass bei mir auch da ein Punkt gesetzt wird, wo keine Nummer steht. So z.B. bei Abbildungs-, Tabellen-, Symbol- und Abkürzungsverzeichnis. Die Nummerierung (1.) geht ja erst ab der Einleitung los.

Minimalbeispiel:

Code: Alles auswählen

\documentclass[12pt,oneside,a4paper]{scrreprt}
\usepackage[german,ngerman]{babel}


\begin{document}

\tableofcontents

\listoffigures    
\addcontentsline{toc}{chapter}{\numberline{}Abbildungsverzeichnis}

\listoftables
\addcontentsline{toc}{chapter}{\numberline{}Tabellenverzeichnis}

\chapter{Einleitung}
	Einleitungstext

 \begin{appendix} \label{anhang}
 
 \chapter{Anhang}	
 	test
 
 \end{appendix}

\end{document} 
Jemand eine Ahnung, warum das so ist und wie man es (regulär, d.h. ohne Tricksen) vermeiden kann?

cliffhanger
Forum-Century
Forum-Century
Beiträge: 137
Registriert: Di 25. Aug 2009, 11:25
Wohnort: Regensburg

Beitrag von cliffhanger »

Hey Jay,

Darf ich mal ganz unverschämt fragen, warum du scrreprt nicht einfach mit der Option "listof=totoc" lädst?

damit werden die Verzeichnisse der Gleitumgebungen automatisch ohne Nummerierung (wenn du Nummerierung auch noch haben willst, "totocnumbered") ins Inhaltsverzeichnis übernommen. Damit sparst du dir, das ganze immer mit

Code: Alles auswählen

\addcontentsline ...
selbst zu veranlassen.

Aber auch mit deinem Code kann ich keine überflüssigen Punkte sehen, es ist lediglich im Inhaltsverzeichnis sehen, dass da vor den Einträgen für die Verzeichnisse Platz freigehalten wird für eine nicht vorhandene Nummerierung. Dieser Platz verschwindet, wenn du die oben genannte Klassenoption verwendest:

Code: Alles auswählen

\documentclass[12pt,oneside,a4paper,listof=totoc]{scrreprt}
\usepackage[german,ngerman]{babel}


\begin{document}

\tableofcontents

\listoffigures    
%\addcontentsline{toc}{chapter}{\numberline{}Abbildungsverzeichnis}

\listoftables
%\addcontentsline{toc}{chapter}{\numberline{}Tabellenverzeichnis}

\chapter{Einleitung}
   Einleitungstext

 \appendix \label{anhang}
 
 \chapter{Anhang}  
    test
 

\end{document}
Gruß
Cliffhanger

PS: Appendix ist keine Umgebung, sondern nur ein Befehl:

Code: Alles auswählen

\appendix

Antworten