goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Zitieren mit footcite

 

dot
Forum-Newbie
Forum-Newbie

Beiträge: 3
Anmeldedatum: 18.03.18
Wohnort: Berlin
Version: ---
     Beitrag Verfasst am: 18.03.2018, 21:35     Titel: Zitieren mit footcite
  Antworten mit Zitat      
Hallo liebe Leute im Forum,

ich hoffe jemand kann mir bei meinem Problem helfen: Ich sitze seit zwei Tagen (!) an dem Versuch in einem Beamer Dokument in Fußnoten zu zitieren. Bisher habe ich immer mit cite zitiert.

Das ist mein letzter Versuch:
Code • Öffne in Overleaf

\documentclass{beamer}
\usepackage[utf8]{inputenc}
\usepackage{amsfonts}
\usepackage[ngerman]{babel}
\usepackage{biblatex}

\usepackage{filecontents}
\begin{filecontents}{Vorlage.bib}
@Book{book,
author = {Autor
},
title = {Titel},
publisher = {Verlag},
year = {2222},
}
\end{filecontents}
\bibliography{Vorlage}

\begin{document}

\begin{frame}
Hi Leute, für diesen Satz will ich einen Quellenverweis. \footcite{book}
\end{frame}

\begin{frame}
\printbibliography
\end{frame}


\end{document}
 


Leider erscheint in der Fußnote "book" anstelle des Quellenverweises. Ein Literaturverzeichnis erscheint auch nicht.

Ich bin dankbar für jede Hilfe!
Private Nachricht senden Benutzer-Profile anzeigen

Bartman
Forum-Meister
Forum-Meister


Beiträge: 1206
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: ---
     Beitrag Verfasst am: 18.03.2018, 23:40     Titel:
  Antworten mit Zitat      
Hast Du die wichtigen Hinweise gelesen? Beachte die Bemerkungen zur blg-Datei.

dot hat Folgendes geschrieben:
Leider erscheint in der Fußnote "book" anstelle des Quellenverweises. Ein Literaturverzeichnis erscheint auch nicht.


Question mark or bold citation key instead of citation number

Ich finde, der voreingestellte Stil numeric ist für Fußnoten nicht sinnvoll.
Private Nachricht senden Benutzer-Profile anzeigen

Johannes_B
Moderator
Moderator


Beiträge: 4929
Anmeldedatum: 01.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 19.03.2018, 08:30     Titel:
  Antworten mit Zitat      
https://en.wikibooks.org/wiki/LaTeX.....s_with_biblatex_and_biber
Dort auch besonders der letzte Abschnitt.
_________________

TeXwelt - Fragen und Antworten Schaut vorbei und stellt Fragen.
LaTeX-Vorlagen?

Der Weg zum Ziel: Ruhe bewahren und durchatmen, Beiträge und unterstützende Links aufmerksam lesen, Lösungsansätze verstehen und ggf. nachfragen.
Private Nachricht senden Benutzer-Profile anzeigen

dot
Forum-Newbie
Forum-Newbie

Beiträge: 3
Anmeldedatum: 18.03.18
Wohnort: Berlin
Version: ---
     Beitrag Verfasst am: 20.03.2018, 15:51     Titel:
  Antworten mit Zitat      
Hallo,

vielen Dank für die Links. Ich habe sie mir alle durchgelesen. Ich habe die Datei durch Latex-Biber (F11)-Latex-Latex geschickt. Ich habe die blg Datei angeschaut. Darin steht folgendes:

This is BibTeX, Version 0.99dThe top-level auxiliary file: golatex2.aux
I found no \citation commands---while reading file golatex2.aux
I found no \bibdata command---while reading file golatex2.aux
I found no \bibstyle command---while reading file golatex2.aux
(There were 3 error messages)

Ich verstehe aber nicht warum das da steht. Der \citation-Befehl ist doch \footcite. Der \bibdata-Befehl ist die Anweisung welche bib-Datei herangezogen werden soll. \bibstyle ist bei Nichtangabe voreingestellt oder?

Das kleine Minimalbeispiel aus dem ersten Link, das man testen soll, ob das System korrekt konfiguriert ist läuft auch nicht.

Und ja, der Stil numeric ist nicht sinnvoll, aber man kann ja \footfullcite benutzen.

Ich habe mich schon echt lange damit beschäftigt. Langsam glaube ich, dass das entweder extrem schwer ist oder ich extrem doof bin (oder beides). Vermutlich bin ich schneller wenn ich meine Fußnoten von Hand mache.

Eine Frage noch: Kann man in Fußnoten zitieren OHNE biblatex/biber zu benutzen?
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 20.03.2018, 16:14     Titel:
  Antworten mit Zitat      
Zitat:
Code • Öffne in Overleaf
This is BibTeX
sagt uns, dass Du BibTeX aufrufst und nicht Biber.

Wenn Du einen Editor benutzt, dann muss man dem häufig erst erklären, dass er statt BibTeX Biber aufrufen soll. Vergleiche Deine Einstellungen man mit https://texwelt.de/wissen/fragen/19.....ch-biber-in-meinem-editor und https://tex.stackexchange.com/q/154751/35864

Ansonsten kann es auch hilfreich sein, von der Kommandozeile zu kompilieren https://texwelt.de/wissen/fragen/34.....eaufforderung-im-terminal die notwenigen Befehle sind
Code • Öffne in Overleaf
pdflatex test
biber test
pdflatex test
pdflatex test
wenn Deine .tex-Datei test.tex heißt.

dot
Forum-Newbie
Forum-Newbie

Beiträge: 3
Anmeldedatum: 18.03.18
Wohnort: Berlin
Version: ---
     Beitrag Verfasst am: 21.03.2018, 13:58     Titel:
  Antworten mit Zitat      
Hallo,

vielen, vielen Dank für Eure Hilfe, es hat endlich geklappt!

Es ging nur mit der Eingabeaufforderung und nur mit meiner richtigen bib-Datei - aber das reicht mir.

Ich wünsche noch einen schönen Tag.
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2018 goLaTeX.de