goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

bibstyle wird nicht gefunden

 

Benni1050
Forum-Newbie
Forum-Newbie

Beiträge: 2
Anmeldedatum: 31.01.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 31.01.2018, 15:29     Titel: bibstyle wird nicht gefunden
  Antworten mit Zitat      
Hallo,

mein Problem taucht ja ähnlich immer wieder auf, bisherige Lösungsvorschläge aus anderen Beiträgen brachten aber nicht den gewünschten Erfolg.

Habe einen eigenen bibstyle mystyle.bbx kreiert und führe in Texmaker F6, F11, F6, F6 aus. Solange mystyle.bbx im selben Verzeichnis wie die tex-Datei liegt, funktioniert alles problemlos. Sobald sich diese unter C:\localtexmf findet, klappt's nicht mehr - die mystyle.bbx würde nicht gefunden (s. Logfile). Der obengenannte Pfad ist in MiKTex als root registriert und "Refresh FNDB" habe ich auch ausgeführt.

Hier mein Beispiel:

Code • Öffne in Overleaf
\documentclass{scrreprt}            
   \usepackage[utf8]{inputenc}
   \usepackage[T1]{fontenc}
   \usepackage[backend=biber,bibstyle=mystyle,citestyle=numeric, giveninits=true]{biblatex}
   \usepackage[german,ngerman]{babel}            
   
\begin{filecontents*}{Testbib.bib}
@BOOKLET{Test,
        editor = "Testherausgeber",
        title = "Test",
        year = 2015,
}
\end{filecontents*}
   
\addbibresource{Testbib.bib}

\begin{document}
   Testtext \cite{Test}
   \printbibliography                          
\end{document}


Woran könnte das noch liegen?

Gruß

Benni

Test_mystyle.log
 Beschreibung:

Download
 Dateiname:  Test_mystyle.log
 Dateigröße:  31.52 KB
 Heruntergeladen:  59 mal
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 31.01.2018, 15:30     Titel:
  Antworten mit Zitat      
Hast Du den Refresh im Admin- oder Nutzer-Modus gemacht?

Nach https://tex.stackexchange.com/a/69484/35864 muss der Tree TDS-kompatibel sein. Dann müsstest Du die Datei nach C:\localtexmf\tex\latex\mybiblatexstyle\ verschieben. Siehe auch http://docs.miktex.org/manual/localadditions.html

Benni1050
Forum-Newbie
Forum-Newbie

Beiträge: 2
Anmeldedatum: 31.01.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 31.01.2018, 16:28     Titel:
  Antworten mit Zitat      
Beide Punkte führten zu dem Problem.

1. Refresh wurde zuvor nicht im Admin-Modus ausgeführt.
2. Weil ich nur C:\localtexmf als TDS-kompatiblen Tree angeben konnte, hatte ich dort auch direkt meine .bbx abgelegt. Diese muss sich aber wie von Dir angegeben in C:\localtexmf\tex\latex\ oder tiefer befinden.

Danke!
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2018 goLaTeX.de