goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Inhaltsverzeichnis beginnt mit 0.1 statt mit 1.1

 

Steffus95
Forum-Newbie
Forum-Newbie

Beiträge: 3
Anmeldedatum: 16.11.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 16.11.2017, 15:51     Titel: Inhaltsverzeichnis beginnt mit 0.1 statt mit 1.1
  Antworten mit Zitat      
Mein Inhaltsverzeichnis nummeriert meine Kapitel alle mit einer 0 vornedran, sprich Kapitel 2 ist im Inhaltsverzeichnis 0.2
Meine Kapitel sind sections, es sind keinerlei chapter vorhanden (das würde mein Problem erklären, da chapter>section) und die documentclass ist report, falls das etwas zur Sache tut.

Hat da jemand eine Idee woran das liegen könnte?

Danke schonmal für die Antworten Smile
Private Nachricht senden Benutzer-Profile anzeigen

markusv
Forum-Meister
Forum-Meister

Beiträge: 564
Anmeldedatum: 03.09.15
Wohnort: Leipzig
Version: ---
     Beitrag Verfasst am: 16.11.2017, 16:03     Titel:
  Antworten mit Zitat      
Hallo und willkommen im Forum.

Du erklärst dein Problem ja quasi selbst: Du hast kein Eintrag auf der chapter-Ebene. Diese ist die höchste Ebene bei report (abgesehen von part, aber für die Nummerierung der Kapitel ist chapter entscheidend). Wenn du keine Kapitel haben möchtest, nimm eine auf Abschnitten basierende Klasse (article oder die, wahrscheinlich für dich besser geeignete, entsprechende KOMA-Script-Klasse scrartcl) oder ersetze deine \section{}-Einträge durch \chapter, \subsection entsprechend durch \section usw.

EDIT: Mit anderen Worten: Latex schaut nicht in deinem Dokument nach, welcher Eintrag der höchste ist, so wie ich anhand deiner Beschreibung dein Denken vermute, sondern hat feste Gliederungsebenen: für report und book chapter.section.subsection..., für article section.subsection.subsubsection ... Da in deinem Dokument noch kein chapter-Eintrag vorliegt, gibt Latex die 0 aus.
_________________

Wäre Microsoft Word für das Schreiben von Büchern entwickelt worden,
würde es Microsoft Book heißen.

Unkomplizierte und schnelle LaTeX-Hilfe, bspw. Erstellung von Vorlagen und Bewerbungen:
Help-LaTeX@web.de
Private Nachricht senden Benutzer-Profile anzeigen E-Mail senden

Steffus95
Forum-Newbie
Forum-Newbie

Beiträge: 3
Anmeldedatum: 16.11.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 16.11.2017, 16:20     Titel:
  Antworten mit Zitat      
Hallo markusv Smile ,

danke für deine Antwort!

section wird auch ohne, dass ich chapter benutze trotzdem nur als zweithöchste Ebene gesehen, verstehe ich das richtig?

Ich habe bereits probiert chapter zu benutzen, allerdings steht dann immer Kapitel 1 eine Zeile über dem Namen des Kapitels, was der Grund war, wieso ich auf section umsteigen will.
Weißt du das eventuell, wie ich das umgehen kann, denn dann könnte ich einfach chapter benutzen und das Problem wäre gelöst.

Alternativ muss ich wohl wirklich die documentclass ändern...
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 16.11.2017, 16:51     Titel:
  Antworten mit Zitat      
Wie mein Vorredner schon geschrieben hat: Nimm entweder:
Code • Öffne in Overleaf
\documentclass{scrreprt}
\begin{document}
\tableofcontents
\chapter{Test}
\end{document}
oder
Code • Öffne in Overleaf
\documentclass{scrartcl}
\begin{document}
\tableofcontents
\section{Test}
\end{document}
oder notfalls
Code • Öffne in Overleaf
\documentclass{article}
\begin{document}
\tableofcontents
\section{Test}
\end{document}

Bei scrreprt hat man die Wahl, ob Kapitel mit Präfixzeile gesetzt werden oder nicht. Kapitel haben aber immer die Eigenschaft, dass sie eine neue Seite beginnen (OK, kann man bei KOMA-Script auch ändern, sollte man aber nicht, dann besser scrartcl verwenden). Die Standardklassen sind dagegen bekannter Maßen unflexibel und braucht diverse Pakete, um die häufig gewünschten Änderungen erreichen zu können.

Steffus95
Forum-Newbie
Forum-Newbie

Beiträge: 3
Anmeldedatum: 16.11.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 16.11.2017, 17:04     Titel:
  Antworten mit Zitat      
Ok alles klar, danke Smile

Kannst du mir noch kurz sagen, wo ich das mit der Präfixzeile einstellen kann?^^
Private Nachricht senden Benutzer-Profile anzeigen

Bartman
Forum-Meister
Forum-Meister


Beiträge: 1313
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: ---
     Beitrag Verfasst am: 16.11.2017, 17:27     Titel:
  Antworten mit Zitat      
Lies auf Seite 100 der KOMA-Script-Anleitung.
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 16.11.2017, 17:35     Titel:
  Antworten mit Zitat      
Steffus95 hat Folgendes geschrieben:
Kannst du mir noch kurz sagen, wo ich das mit der Präfixzeile einstellen kann?^^

Hast Du das scrreprt-Beispiel (beispielsweise via Overlead-Link) ausprobiert? Die Präfixzeile ist in der Voreinstellung bei scrreprt und scrbook aus.

BTW: Ich empfehle nicht nur Seite 100 des scrguide, sondern min. Teil I der Anleitung oder des KOMA-Script-Buchs. Noch wichtiger ist allerdings, dass Du eine LaTeX-Einführung liest (und bitte nicht dieses fragwürdige YouTube-Tutorial).

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2018 goLaTeX.de