goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 98893
Top-Poster: Johannes_B (5059)

Wir begrüßen unseren neuesten Benutzer StefanSchmelz.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Probleme bei urls im Literaturverzeichnis

 

Anouar
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 24.01.2009, 00:48     Titel: Probleme bei urls im Literaturverzeichnis
  Antworten mit Zitat      
Hallo, ich habe ein seltsames problem:

wenn meine url im literaturverzeichnis eine bestimmte (sozusagen kritische) länge hat, wird sie zwar korrekt dargestellt, und ggf. auch korrekt umgebrochen, doch danach sollte nun "besucht:datum" stehen, dies passiert bei der "kritischen" länge jedoch nicht. Stattdessen kann man dort einen teil des kommandos btxurldatecomment lesen.
Code • Öffne in Overleaf

\documentclass[12pt, a4paper,]{scrartcl}
\usepackage[german]{babel}
\usepackage{babelbib}
\usepackage[pdfstartview=FitH, colorlinks]{hyperref}

\begin{document}

Ein Zitat\cite{1}. Zwei Zitate\cite{2}. Drei Zitate\cite{3}.
 
\bibliography{bib}
\bibliographystyle{babalpha}

\end{document}
 


mein literaturverzeichnis, hier bib.bib, sieht folgendermaßen aus:

Code • Öffne in Overleaf

%
@online{1,
author={Xautor
},
title={xxxxx},
url={http://www.xxxxxx.xxx/xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx},
urldate={1.1.0},
}%
@online{2,
author={Yautor
},
title={xxxxx},
url={http://www.xxxxxx.xxx/xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx},
urldate={1.1.0},
}
%
@online{3,
author={Zautor
},
title={xxxxx},
url={http://www.xxxxxx.xxx/xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx},
urldate={1.1.0},
}
 


Die Einträge unterscheiden sich also jeweils um einen Buchstaben, was dazu führt, dass der erste Eintrag im Verzeichnis korrekt dargestellt wird, die anderen beiden aber nicht.
Ich kann diesen Fehler manuell beheben, indem ich die erstellte datei *.bbl folgendermaßen ändere:
Bei den fehlerhaften Einträgen wird hier das \btxurldatecomment durch ein % getrennt, der abgeschnittene Teil erscheint dann (ungewünscht) im Dokument. Füge ich nun die fälschlicherweise getrennten Kommandos zusammen, also zB
Code • Öffne in Overleaf

\btxurldatecomm%
ent
 

zu
Code • Öffne in Overleaf
\btxurldatecomment

, lasse LaTeX noch einmal laufen, passt das Endergebnis.

Liegt der Fehler bei mir? Oder macht hier babelbib den Fehler? Ich bin für jede Hilfe dankbar.
A.

KOMA
TeX-Entwickler
TeX-Entwickler


Beiträge: 2637
Anmeldedatum: 04.07.08
Wohnort: ---
Version: Ich bin hier nicht mehr zu erreichen!
     Beitrag Verfasst am: 24.01.2009, 10:23     Titel:
  Antworten mit Zitat      
Das Problem ist BibTeX. BibTeX will unbedingt nach einer bestimmten Anzahl an Zeichen einen Zeilenumbruch haben. Um den zu erzwingen fügt es ggf. ein »%« am Zeilenende ein, falls an der entsprechenden Stelle kein Leerzeichen stand oder bricht einfach an einem Leerzeichen um. Das ist normalerweise ganz in Ordnung. Es ist aber nicht in Ordnung, wenn LaTeX zuvor in einen Modus versetzt wird, indem en »%« keinen Kommentar mehr einleitet oder das Leerzeichen oder der Zeilenumbruch selbst eine neue Bedeutung hat.

Ich habe bei der KOMA-Script-Anleitung ein ähnliches Problem, das ich mit einer sed-Nachbearbeitung der erzeugten bbl-Datei löse. Im Prinzip liese sich das Problem am besten dadurch lösen, dass man ein BibTeX schreibt, das keinen automatischen Umbruch mehr durchführt, sondern einen kompletten BibTeX-Eintrag in einer Zeile ausgibt. Eventuell können neuere Implementierungen so etwas sogar schon. Damit habe ich mich ehrlich gesagt bisher nicht beschäftigt.
_________________

goLaTeX-Knigge (mit Themen Minimalbeispiel und So stellst Du Deine Frage richtig)
DE-TeX-FAQ, UK-FAQ, l2kurz, l2tabu, CTAN, The TeX Catalogue
KOMA-Script
Ich bin hier nicht mehr zu erreichen!
Private Nachricht senden Benutzer-Profile anzeigen

Anouar
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 24.01.2009, 12:56     Titel: unschöne Lösung gefunden
  Antworten mit Zitat      
danke, dann bin ich ja unschuldig. Ich habe zumindest eine akzeptable Lösung gefunden:

Code • Öffne in Overleaf
@online{2,
author={Yautor
},
title={xxxxx},
url={http://www.xxxxxx.xxx/
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
},
urldate={1.1.0},
}
 


Breche ich die "Probleme" in der bib.bib selber um, sozusagen bevor bibtex das selber macht, muss ich zumindest die *.bbl nicht bei jedem kompilieren verändern, sondern jeden falsch gesetzten eintrag nur einmal bearbeiten. Es sind nur vier bei mir, deswegen ist die Lösung akzeptabel.
Leider kann man beim schreiben der *.bib nicht erkennen (außer man zählt die Buchstaben mit...) welcher eintrag zu problemen führt, also kompilieren, fehler suchen, umbrechen. Oder jeden Eintrag gleich in so kleine stücke umbrechen, das das problem gar nicht erst auftaucht... auch nicht schön.

KOMA
TeX-Entwickler
TeX-Entwickler


Beiträge: 2637
Anmeldedatum: 04.07.08
Wohnort: ---
Version: Ich bin hier nicht mehr zu erreichen!
     Beitrag Verfasst am: 24.01.2009, 15:55     Titel:
  Antworten mit Zitat      
Ich habe gerade mal einen kurzen Blick in die web-Sourcen von BibTeX geworfen und im Change-File bibtex.ch tatsächlich den Hinweis gefunden, dass es eventuell besser wäre, wenn bei der Ausgabe keine zusätzlichen Umbrüche eingefügt würden. Da fragt man sich natürlich, warum das dann trotzdem gemacht wird und man es nicht zumindest abschalten kann. Dann könnten Zeilen immerhin so lang werden, wie der Puffer groß ist (original 1000 Zechen, verbessert 20000 Zeichen).

In bibtex8 zu schauen, habe ich zeitlich noch nicht geschafft. Ich gehe aber davon aus, dass es noch leichter ist, dort ein entsprechenes Feature einzubauen. Wäre vielleicht eine Anfrage wert. Der Umbruch in der Eingabedatei macht einen nämlich von dem verwendeten Literaturstil und der verwendeten Anweisung abhängig. Im Zweifelsfall kann das auch zu einem Leerzeichen in der URL führen. Ob ein Prozent am Ende der ersten Zeile der URL dann dieses Leerzeichen verhindert oder sogar selbst in der URL landet, hängt ebenfalls von den Umständen ab.
_________________

goLaTeX-Knigge (mit Themen Minimalbeispiel und So stellst Du Deine Frage richtig)
DE-TeX-FAQ, UK-FAQ, l2kurz, l2tabu, CTAN, The TeX Catalogue
KOMA-Script
Ich bin hier nicht mehr zu erreichen!
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de