goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 99385
Top-Poster: Johannes_B (5059)

Wir begrüßen unseren neuesten Benutzer naderda.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Zeilenumbruch bei Verwendung von chapterprefixes

 

Minknack
Forum-Newbie
Forum-Newbie

Beiträge: 3
Anmeldedatum: 25.08.15
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 25.08.2015, 14:28     Titel: Zeilenumbruch bei Verwendung von chapterprefixes
  Antworten mit Zitat      
Hallo allerseits!

Ich verwende die Klasse scrbook und möchte die Kapitelüberschriften anpassen. Siehe dazu folgendes Minimalbeispiel:

Code • Öffne in Overleaf
\documentclass[chapterprefix=true]{scrbook}
\usepackage{lipsum}
\usepackage{xcolor}

\setkomafont{chapterprefix}{\LARGE\color{red}}  
\setkomafont{chapter}{\LARGE}

\renewcommand*{\chapterheadstartvskip}{\vskip.2\textheight}
\renewcommand*{\chapterformat}{%
    \raggedleft
    Some Text\\
    \vskip-16pt
    \hrulefill\\
    \raggedright
    \chapapp~\thechapter:
}

\begin{document}
\chapter{My first chapter}
\lipsum[1]
\end{document}
 


Ich möchte allerdings, dass der Kapiteltitel (in schwarz) direkt im Anschluss an "Kapitel 1:" (in rot) erscheint und davor nicht noch einmal umgebrochen wird.

Ich habe bereits eine gefühlte Ewigkeit getüftelt aber keine Lösung gefunden. Die Verwendung von titlesec scheidet aus, da es zur KOMA-Klasse Kompatibilitätsprobleme zu geben scheint,

Weiß jemand Rat?
Private Nachricht senden Benutzer-Profile anzeigen

u_fischer
Forum-Meister
Forum-Meister


Beiträge: 3937
Anmeldedatum: 22.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 25.08.2015, 14:34     Titel:
  Antworten mit Zitat      
Code • Öffne in Overleaf
\documentclass[chapterprefix=true]{scrbook}
\usepackage{lipsum}
\usepackage{xcolor}

\setkomafont{chapterprefix}{\LARGE\color{red}}
\setkomafont{chapter}{\LARGE}

\renewcommand*{\chapterheadstartvskip}{\vskip.2\textheight}
\renewcommand*{\chapterformat}{%
    \raggedleft
    Some Text\\
    \vskip-16pt
    \hrulefill\\
    \raggedright
    \chapapp~\thechapter:
}

\renewcommand*{\chapterheadmidvskip}{}

\begin{document
}
\chapter{My first chapter}
\lipsum[1]
\end{document}

_________________

Ulrike Fischer
www.troubleshooting-tex.de
Private Nachricht senden Benutzer-Profile anzeigen

Minknack
Forum-Newbie
Forum-Newbie

Beiträge: 3
Anmeldedatum: 25.08.15
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 25.08.2015, 14:42     Titel:
  Antworten mit Zitat      
Danke für die Antwort, der Befehl \chapterheadmidvskip funktioniert bei mir allerdings nicht...
Private Nachricht senden Benutzer-Profile anzeigen

Johannes_B
Moderator
Moderator


Beiträge: 5059
Anmeldedatum: 01.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 25.08.2015, 14:43     Titel:
  Antworten mit Zitat      
Und warum nicht? erhältst du eine Fehlermeldung?
_________________

TeXwelt - Fragen und Antworten Schaut vorbei und stellt Fragen.
LaTeX-Vorlagen?

Der Weg zum Ziel: Ruhe bewahren und durchatmen, Beiträge und unterstützende Links aufmerksam lesen, Lösungsansätze verstehen und ggf. nachfragen.
Private Nachricht senden Benutzer-Profile anzeigen

u_fischer
Forum-Meister
Forum-Meister


Beiträge: 3937
Anmeldedatum: 22.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 25.08.2015, 14:44     Titel:
  Antworten mit Zitat      
Dann musst du KOMA updaten. In den KOMA-Versionen von Texlive 2014 und von aktuellen Systemen (miktex/texlive 2015) gibt es ihn.
_________________

Ulrike Fischer
www.troubleshooting-tex.de
Private Nachricht senden Benutzer-Profile anzeigen

Minknack
Forum-Newbie
Forum-Newbie

Beiträge: 3
Anmeldedatum: 25.08.15
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 26.08.2015, 15:21     Titel:
  Antworten mit Zitat      
Das Update auf die aktuelle TexLive-Version brachte die Lösung Smile

Ich hatte bisher die Version von 2013, da gabs den Befehl offenbar noch nicht.
Könnt ihr mir als letztes vllt noch verraten, wie ich es hinbekomme, auch für unnummerierte Kapitel (chapter*, addchap) ein chapterprefix festzulegen?
Private Nachricht senden Benutzer-Profile anzeigen

Noch so einer
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 26.08.2015, 15:43     Titel:
  Antworten mit Zitat      
Sieht für mich so aus, als wolltest Du die Formatierung der Kapitelnummer für etwas missbrauchen, wofür es nicht gedacht ist. Da ich nicht genau weiß, was Du wirklich vor hast, kann ich nur vermuten, dass es so eventuell besser geht:
Code • Öffne in Overleaf
\documentclass[chapterprefix=false]{scrbook}
\usepackage{lipsum}
\usepackage{xcolor}

\setkomafont{chapterprefix}{\LARGE\color{red}}  
\setkomafont{chapter}{\LARGE}

\renewcommand*{\chapterheadstartvskip}{\vskip.2\textheight
  \usekomafont{disposition
}{\LARGE\color{red}
   \raggedleft Some Text\\[-1ex]
   \hrulefill
  }\par
}
\renewcommand*{\chapterformat}{\textcolor{red}{\chapapp~\thechapter:\enskip}}

\begin{document}
\tableofcontents
\chapter{My first chapter}
\lipsum[1]
\end{document}

Jedenfalls gibt es auf komascript.de sogar ein Beispiel mit Linien via \chapterheadstartvskip und \chapterheadendvskip.

So wie ich \chapterlinesformat und \chapterlineswithprefixformat in den KOMA-Script-Quellen verstehe, besteht eventuell die Möglichkeit, das mit der nächsten KOMA-Script-Release auch darüber zu machen. Solange die Anweisungen nicht offiziell dokumentiert sind, ist das aber Spekulation.

Noch so einer
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 26.08.2015, 16:45     Titel:
  Antworten mit Zitat      
In den Infos zur nächsten Release gibt es auch eine erste Doku zu den beiden neuen Befehlen. Demnach dürfte mit der nächsten Version etwas wie:
Code • Öffne in Overleaf
\documentclass[chapterprefix=false]{scrbook}
\usepackage{lipsum}
\usepackage{xcolor}

\setkomafont{chapterprefix}{\LARGE\color{red}}  
\setkomafont{chapter}{\LARGE}

\RedeclareSectionCommand[beforeskip=.2\textheight]{chapter}
\renewcommand*{\chapterformat}{\textcolor{red}{\chapapp~\thechapter:\enskip}}
\renewcommand*{\chapterlinesformat}[3]{%
  {\LARGE\color{red}\raggedleft Some Text\\[-2ex]
    \hrulefill\par}%
  #2#3%
}

\begin{document}
\tableofcontents
\chapter{My first chapter}
\lipsum[1]
\end{document}

funktionieren. Ob das natürlich Deinen Wünschen entspricht, kann ich nicht sagen, vielleicht suchst Du in Wirklichkeit auch eher nach \setchapterpreamble[o]{…}.

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de