goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 99398
Top-Poster: Johannes_B (5059)

Wir begrüßen unseren neuesten Benutzer nf.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

scrlttr2: Fragen zu utf8, phonenamespereator,footsepline u.a

 

malformed
Forum-Fortgeschrittener
Forum-Fortgeschrittener

Beiträge: 65
Anmeldedatum: 05.12.10
Wohnort: ---
Version: Kile 2.1.0, pdfTeX 3.1415926-2.3-1.40.12 (TeX Live 2011), Kubuntu 11.10
     Beitrag Verfasst am: 02.10.2011, 14:35     Titel: scrlttr2: Fragen zu utf8, phonenamespereator,footsepline u.a
  Antworten mit Zitat      
Hallo liebes Forum

nachdem ich Probleme mit der Klasse g-brief hatte, versuche ich ich gerade, auf scrlttr2 umzusteigen. Mir gefällt das Ergebnis auch schon recht gut, allein ein Paar Dinge sind noch offen, für die ich auch nach intensiver Konsultation von Internet, Google und scrguide keine Lösung gefunden habe.

Den Ursprung nahm meine Vorlage aus einer, die ich von der Komaseite heruntergeladen habe und nach und nach modifiziert habe, deshalb weiss ich nicht bei allen Eintragungen genau, was sie bedeuten, ich hoffe jedoch, ihr könnt mir weiterhelfen.

Zunächst, wenn ich den Brief mit utf8 als inputenc mache, erhalte ich den Hinweis
Code • Öffne in Overleaf
Package inputenc Error: Unicode char \u8:�e not set up for use with LaTeX. See the inputenc package documentation for explanation
mit latin1 geht das Beispiel Problemlos durch. Ich habe natürlich Umlaute und ß in Opening und Closing, weiss aber nicht, was genau den Fehler verursacht (notfalls kann ichn natürlich weiterhin latin1 nehmen, wüsste aber gerne, woran es liegt)

Weiterhin habe ich Emailname und phonename umdefiniert:
Code • Öffne in Overleaf
\renewcommand{\phonename}{\ding{38}}

und wüsste nun gerne, ob es eine Möglichkeit gibt, die Doppelpunkte hinter der Bezeichnung zu unterdrücken?

Über der Fußzeile, in der ich Adresse und Bankverbindung ausgebe, hätte ich gerne eine durchgezogene Linie, zwar habe ich footsepline an, aber das wirkt soweit ich das sehe nur auf Folgeseiten und nicht auf der ersten?

Dafür hätte ich gerne auf der Folgeseite einen spezifischen Header, von dem ich nicht weiß, wie ich ihn realisiere: links soll Name und Vorname, in der Mitte das Datum (ausgeschrieben) und rechtes "Seite x" stehen, mit headsepline, kann mir da jemand helfen? Ich habe zumindest \setkomavar{nexthead}{myheadings} verwendet…

Ich versuche nun noch, ein Minimalbeispiel zu machen, und hoffe, ihr könnt mir behilflich sein…

Vielen Dank im Voraus,

malformed

Minimalbeispiel:
Code • Öffne in Overleaf
\RequirePackage{fix-cm}
\documentclass
   [fontsize=12pt,
   paper=a4,
   enlargefirstpage=on,
   pagenumber=headcenter,
   firstfoot=on,
   headsepline=on,
   footsepline=on,
   parskip=half,
   fromalign=right,
   fromphone=on,
   fromrule=aftername,
   fromfax=off,
   fromemail=on,
   fromurl=off,
   fromlogo=off,
   addrfield=on,
   backaddress=on,
   subject=beforeopening,
   locfield=narrow,
   foldmarks=on,
   numericaldate=off,
   refline=narrow,
   draft=false
]{scrlttr2}
\usepackage{cmap}
\usepackage{fixltx2e}
\usepackage[T1]{fontenc}
\usepackage[latin1]{inputenc}
\usepackage[ngerman]{babel}
\usepackage{url}

\setkomafont{fromname}{\footnotesize \scshape}
\setkomafont{fromaddress}{\small}
\setkomafont{pagenumber}{\scshape}
\usepackage{scrpage2}
\usepackage[expansion=true,protrusion=true,tracking=true]{microtype}
\usepackage{pifont}
\usepackage{textcomp}
\begin{document}

\LoadLetterOption{DIN}
\makeatletter
\@setplength{firstheadvpos}{12mm}
\@setplength{firstheadwidth}{\paperwidth}
\ifdim \useplength{toaddrhpos}>\z@
  \@addtoplength[-2]{firstheadwidth}{\useplength{toaddrhpos}}
\else
  \@addtoplength[2]{firstheadwidth}{\useplength{toaddrhpos}}
\fi
\@setplength{foldmarkhpos}{6.5mm}
\makeatother

\setkomavar{fromname}{Ich}
\setkomavar{fromaddress}{Strasse\\ Ort \medskip}
\setkomavar{fromphone}{0000000}
\renewcommand{\phonename}{\ding{38}}
\setkomavar{fromemail}{email@res.se}
\renewcommand{\emailname}{\ding{46}}
\setkomavar{backaddressseparator}{~\ding{166}~}
\setkomavar{signature}{Ich}
\setkomavar{frombank}{xyz bank \\ Konto 0\,000\,000\,000 \\ BLZ: 000\,000\,00}
\setkomavar{firstfoot}{%
\parbox[t]{\textwidth}{\footnotesize
\begin{tabular
}[c]{l@{}}%
Ich\\
Strasse\\
Adresse
\end{tabular}
\hfill
\ifkomavarempty{frombank}{}{
\hfill
\begin{tabular
}[c]{l@{}}
\usekomavar{frombank}
\end{tabular}
}
}
}

\setkomavar{nexthead}{myheadings}

\setkomavar{place}{Ort}
\setkomavar{date}{\today}
\renewcommand{\enclname}{\textbf{Anlagen}}
\setkomavar{enclseparator}{:}
\pagestyle{scrheadings}
\begin{letter}{Empfängername\\Empfängerstraße\\PLZ Ort}
\KOMAoptions{%%
foldmarks=p,
}
\setkomavar{subject}{Betreff}

\opening{Sehr geehrte Damen und Herren,}


\closing{Mit freundlichen Grüßen,}
\end{letter}
\end{document}

_________________

Die Politiker lassen keine Gelegenheit verstreichen,
eine Gelegenheit verstreichen zu lassen.

Ulrich Beck, Weltinnenpolitik
Private Nachricht senden Benutzer-Profile anzeigen

Typo
Forum-Anfänger
Forum-Anfänger

Beiträge: 35
Anmeldedatum: 09.07.08
Wohnort: ---
Version: MiKTex 2.9
     Beitrag Verfasst am: 02.10.2011, 20:21     Titel: Re: scrlttr2: Fragen zu utf8, phonenamespereator,footsepline
  Antworten mit Zitat      
malformed hat Folgendes geschrieben:
Ich versuche nun noch, ein Minimalbeispiel zu machen, und hoffe, ihr könnt mir behilflich sein…


Löblich Wink

Zumindest ein paar Antworten auf viele Fragen:
Zitat:
Zunächst, wenn ich den Brief mit utf8 als inputenc mache, erhalte ich den Hinweis…

Ändere
Code • Öffne in Overleaf
\usepackage[latin1]{inputenc}

zu
Code • Öffne in Overleaf
\usepackage[utf8]{inputenc}


Zitat:
… die Doppelpunkte hinter der Bezeichnung zu unterdrücken?

Ändere Deine Telefonnummerangabe
Code • Öffne in Overleaf
%\setkomavar{fromphone}{0000000}
\setkomavar{phoneseparator}{~+49~123~456789}


Ansonsten schau Dich auch mal auf der KOMA-Script-Seite nach den dortigen Briefkopfbeispielen um. Vielleicht helfen die Dir schon weiter.
Private Nachricht senden Benutzer-Profile anzeigen

malformed
Forum-Fortgeschrittener
Forum-Fortgeschrittener

Beiträge: 65
Anmeldedatum: 05.12.10
Wohnort: ---
Version: Kile 2.1.0, pdfTeX 3.1415926-2.3-1.40.12 (TeX Live 2011), Kubuntu 11.10
     Beitrag Verfasst am: 03.10.2011, 13:42     Titel:
  Antworten mit Zitat      
Typo hat Folgendes geschrieben:

Ändere
Code • Öffne in Overleaf
\usepackage[latin1]{inputenc}

zu
Code • Öffne in Overleaf
\usepackage[utf8]{inputenc}


Genau dieser Wechsel aber ist genau das, was den Fehler verursacht - alle anderen Dokumente (Hausarbeiten et cetera) funktionieren mit utf8

Typo hat Folgendes geschrieben:

Ändere Deine Telefonnummerangabe
Code • Öffne in Overleaf
%\setkomavar{fromphone}{0000000}
\setkomavar{phoneseparator}{~+49~123~456789}

Dass dafür hat super funktioniert, vielen Dank =)
_________________

Die Politiker lassen keine Gelegenheit verstreichen,
eine Gelegenheit verstreichen zu lassen.

Ulrich Beck, Weltinnenpolitik
Private Nachricht senden Benutzer-Profile anzeigen

Typo
Forum-Anfänger
Forum-Anfänger

Beiträge: 35
Anmeldedatum: 09.07.08
Wohnort: ---
Version: MiKTex 2.9
     Beitrag Verfasst am: 03.10.2011, 14:09     Titel:
  Antworten mit Zitat      
malformed hat Folgendes geschrieben:
Typo hat Folgendes geschrieben:

Ändere
Code • Öffne in Overleaf
\usepackage[latin1]{inputenc}

zu
Code • Öffne in Overleaf
\usepackage[utf8]{inputenc}


Genau dieser Wechsel aber ist genau das, was den Fehler verursacht - alle anderen Dokumente (Hausarbeiten et cetera) funktionieren mit utf8

Hast Du das Dokument auch wirklich im UTF-8-Modus gespeichert? Ich verwendete bspw. WinEdt 6 und füge am Anfang meiner LaTeX-Dateien die Konfigurationszeile
Code • Öffne in Overleaf
% !Mode:: "TeX:UTF-8Very HappyE:Soft"

ein. Die erzwingt u.a. UTF-8 und - wenn die Datei bis dato nicht in dem Format vorlag - eine Konvertierung und auch eine Speicherung. Die von Dir erwähnte Aufnahme der "Umlaute und ß in Opening und Closing" setze ich für LaTeX-Dokumente nicht ein - es geht auch ohne.
Private Nachricht senden Benutzer-Profile anzeigen

malformed
Forum-Fortgeschrittener
Forum-Fortgeschrittener

Beiträge: 65
Anmeldedatum: 05.12.10
Wohnort: ---
Version: Kile 2.1.0, pdfTeX 3.1415926-2.3-1.40.12 (TeX Live 2011), Kubuntu 11.10
     Beitrag Verfasst am: 03.10.2011, 15:43     Titel:
  Antworten mit Zitat      
Hoi,

ich verwende Kile auf Kubuntu und bin eigentlich davon ausgegangen, dass es als utf8 gespeichert wird - aber da ich die Vorlage selbst editiert hatte, war das wohl nicht so… gelöst habe ich das ganze, indem ich den gesamten Code in ein leeres, neues Dokument kopiert und dass dann neu gespeichert, utf8 geht dann jetzt - vielen Dank…
_________________

Die Politiker lassen keine Gelegenheit verstreichen,
eine Gelegenheit verstreichen zu lassen.

Ulrich Beck, Weltinnenpolitik
Private Nachricht senden Benutzer-Profile anzeigen

Typo
Forum-Anfänger
Forum-Anfänger

Beiträge: 35
Anmeldedatum: 09.07.08
Wohnort: ---
Version: MiKTex 2.9
     Beitrag Verfasst am: 07.10.2011, 15:32     Titel:
  Antworten mit Zitat      
malformed hat Folgendes geschrieben:
vielen Dank…

Gern geschehen.
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de