goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 99338
Top-Poster: Johannes_B (5059)

Wir begrüßen unseren neuesten Benutzer Kayayay.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

\date wird ignoriert und \subject{} verursacht fehler

 

hdfritz
Forum-Newbie
Forum-Newbie

Beiträge: 3
Anmeldedatum: 13.01.11
Wohnort: Jena
Version: MikTex 2.9
     Beitrag Verfasst am: 13.01.2011, 14:43     Titel: \date wird ignoriert und \subject{} verursacht fehler
  Antworten mit Zitat      
Hallo,

ich habe zwei Probleme mit der automatischen Titelseitengenerierung...


Code • Öffne in Overleaf

\documentclass{scrreprt}


\usepackage[T1]{fontenc}


\titlehead{
     \centering Friedrich-Schiller-Universität Jena \\
                Biologisch-Pharmazeutische Fakultät\\
                %\includegraphics[width=4cm]{Bilder/UniLogo.png}
                }  
%\subject{Diplomarbeit}      
\title{Diplomarbeit\\Studien zur antionkogenen Wirkung multimerisierter Ras bindender Domänen}
\date{01.01.2011}    
\author{Angefertigt am:\date{\today}
      \\Vorgelegt von: XXXXXXX
      \\geb. am.XXXX in XXXXX
      }


\begin{document}

\maketitle

bla
\end{document}
 


1.

%\subject{Diplomarbeit} : wenn ich die Kommentierung inaktiviere, kommt ein fehler, der bei Kommentierung des Packages
\usepackage[T1]{fontenc}
wieder verschwindet....
Ich möchte aber das Package schon gerne benutzen. Wie kann ich das lösen?

und 2.

\date wird scheinbar komplett ignoriert. Ganz unten an der Titlepage kommt automatisch das heutige Datum. Es soll aber nach Angefertigt am:
erscheinen.
Private Nachricht senden Benutzer-Profile anzeigen E-Mail senden

Xenara
Forum-Meister
Forum-Meister

Beiträge: 682
Anmeldedatum: 25.11.09
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 13.01.2011, 14:50     Titel:
  Antworten mit Zitat      
Das kann ich nicht nachvollziehen, dein Beispiel funktioniert einwandfrei. Mit dem Code hier bekomme ich das Ergebnis im Anhang, so solls doch aussehen, oder?
Code • Öffne in Overleaf
\documentclass{scrreprt}


\usepackage[T1]{fontenc}


\titlehead{
     \centering Friedrich-Schiller-Universität Jena \\
                Biologisch-Pharmazeutische Fakultät\\
                %\includegraphics[width=4cm]{Bilder/UniLogo.png}
                }  
\subject{Diplomarbeit}      
\title{Diplomarbeit\\Studien zur antionkogenen Wirkung multimerisierter Ras bindender Domänen}
\date{01.01.2011}    
\author{Angefertigt am:\date{\today}
      \\Vorgelegt von: XXXXXXX
      \\geb. am.XXXX in XXXXX
      }


\begin{document}

\maketitle

bla
\end{document}
 


Vielleicht sind bei dir Pakete veraltet. Setze mal \listfiles noch vor \documentclass..., dann erscheint in der .log-Datei ein Abschnitt "File List", in dem alle verwendeten Pakete mit ihrer Versionsnummer aufgeführt werden. Bei mir sieht das für obiges Beispiel so aus:
Zitat:
*File List*
scrreprt.cls 2010/06/17 v3.06 KOMA-Script document class (report)
scrkbase.sty 2010/06/17 v3.06 KOMA-Script package (KOMA-Script-dependent bas
ics and keyval usage)
scrbase.sty 2010/06/17 v3.06 KOMA-Script package (KOMA-Script-independent b
asics and keyval usage)
keyval.sty 1999/03/16 v1.13 key=value parser (DPC)
scrlfile.sty 2009/03/25 v3.03 KOMA-Script package (loading files)
tocbasic.sty 2010/06/09 v3.06 KOMA-Script package (handling toc-files)
scrsize11pt.clo 2010/06/17 v3.06 KOMA-Script font size class option (11pt)
typearea.sty 2010/06/17 v3.06 KOMA-Script package (type area)
fontenc.sty
t1enc.def 2005/09/27 v1.99g Standard LaTeX file
t1cmss.fd 1999/05/25 v2.5h Standard LaTeX font definitions
***********

Mein System ist TeXLive2010 auf WinXP, sollte aber auf die Pakete keinen Einfluss haben.

Test-4.pdf
 Beschreibung:

Download
 Dateiname:  Test-4.pdf
 Dateigröße:  56.71 KB
 Heruntergeladen:  586 mal
Private Nachricht senden Benutzer-Profile anzeigen

hdfritz
Forum-Newbie
Forum-Newbie

Beiträge: 3
Anmeldedatum: 13.01.11
Wohnort: Jena
Version: MikTex 2.9
     Beitrag Verfasst am: 13.01.2011, 15:56     Titel:
  Antworten mit Zitat      
Danke für den Hinweis! Ich habe mittels Update Manager meine Packete aktualisiert und seitdem funktioniert die Sache mit dem \subject.

Das Problem mit dem Datum besteht aber immernoch - übrigens auch in deinem angehängten pdf...

Das aktuelle Datum soll nach

"angefertigt am: "

erscheinen, nicht ganz unten auf der Seite.

\listfiles sollte damit obsolet sein, ich hab die aktualisierte Log datei aber dennoch mal angehängt.
Private Nachricht senden Benutzer-Profile anzeigen E-Mail senden

CollmDante
Forum-Fortgeschrittener
Forum-Fortgeschrittener

Beiträge: 79
Anmeldedatum: 09.01.11
Wohnort: Wermsdorf
Version: texlive 2012
     Beitrag Verfasst am: 13.01.2011, 16:32     Titel:
  Antworten mit Zitat      
Auf die schnelle würde ich das so mit dem Datum versuchen
Code • Öffne in Overleaf
\documentclass{scrreprt}
\usepackage[T1]{fontenc}
%\usepackage[ngerman]{isodate}
%\numdate
\titlehead{
     \centering Friedrich-Schiller-Universität Jena \\
                Biologisch-Pharmazeutische Fakultät\\
                %\includegraphics[width=4cm]{Bilder/UniLogo.png}
                }  
\subject{Diplomarbeit}      
\title{Diplomarbeit\\Studien zur antionkogenen Wirkung multimerisierter Ras bindender Domänen}
\date{}%dieses Datum wird im Titel am Ende gesetzt    
\author{Angefertigt am:%\date{\today} setzt Datum für Titel auf aktuelles Datum und dieses da definiert ans Ende
       \today %aktuelles Datum;eventuell noch formatieren mit dem Paket   isodate
      \\Vorgelegt von: XXXXXXX
      \\geb. am.XXXX in XXXXX
      }


\begin{document}

\maketitle

bla
\end{document}
wobei mir persönlich, das ausblenden des Datums am Ende noch nicht so richtig gefällt.
Private Nachricht senden Benutzer-Profile anzeigen

hdfritz
Forum-Newbie
Forum-Newbie

Beiträge: 3
Anmeldedatum: 13.01.11
Wohnort: Jena
Version: MikTex 2.9
     Beitrag Verfasst am: 13.01.2011, 17:40     Titel:
  Antworten mit Zitat      
Danke für die Antwort. Jetzt funktionierts.
Ich verstehe aber nicht, warum: Wenn man bei meinem Minimalbeispiel

\author{Angefertigt am:\date{\today}

in \author{Angefertigt am: \today} ändert und kompiliert (falls man das so nennnt?) ignoriert latex das \date in der drüber nicht mehr - auch wenn man \today wieder löscht...

was passiert da?

Na ja jedenfalls funktioniert es jetzt. Vielen Dank.

@CollmDante: Ich such mir ja nicht aus, wie ich das zu formatieren habe Smile
Private Nachricht senden Benutzer-Profile anzeigen E-Mail senden

Syralist
Forum-Fortgeschrittener
Forum-Fortgeschrittener

Beiträge: 71
Anmeldedatum: 08.07.08
Wohnort: Bremen
Version: MikTeX 2.8
     Beitrag Verfasst am: 13.01.2011, 19:58     Titel:
  Antworten mit Zitat      
Der Befehl \date{} legt fest, was im Datumsfeld gesetzt werden soll, wenn \maketitle ausgeführt wird.
Im Gegensatz zu allen anderen Befehlen für die Titelseite ist \date{} aber in der Grundeinstellung nicht leer, sondern mit \today vordefiniert.
Wenn man also \date{} nicht angibt, setzt \maketitle immer das aktuelle Datum. Möchte man das verhindern, muss man \date{} explizit mit leeren Klammern aufrufen.
Also suchst du vielleicht folgende Lösung:
Code • Öffne in Overleaf
\documentclass{scrreprt}


\usepackage[T1]{fontenc}


\titlehead{
     \centering Friedrich-Schiller-Universität Jena \\
                Biologisch-Pharmazeutische Fakultät\\
                %\includegraphics[width=4cm]{Bilder/UniLogo.png}
                }  
\subject{Diplomarbeit}      
\title{Diplomarbeit\\Studien zur antionkogenen Wirkung multimerisierter Ras bindender Domänen}
\date{}    
\author{Angefertigt am:\today
      \\Vorgelegt von: XXXXXXX
      \\geb. am.XXXX in XXXXX
     
}


\begin{document}

\maketitle

bla
\end{document}


Ich hoffe ich konnte ein wenig Licht ins Dunkel bringen.
_________________

Ubuntu 11.10 / Windows 7
TexLive 2011 / MikTeX 2.8
vim / TeXworks 0.3
---
Dass jemand paranoid ist heißt nicht, dass er nicht verfolgt wird.
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de