goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 100388
Top-Poster: Johannes_B (5065)

Wir begrüßen unseren neuesten Benutzer mrtdlv.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Skim: Shortcut für SyncTeX

 

iTob
Forum-Meister
Forum-Meister


Beiträge: 1220
Anmeldedatum: 19.04.10
Wohnort: ---
Version: TeX Live auf OS X
     Beitrag Verfasst am: 26.09.2010, 17:58     Titel: Skim: Shortcut für SyncTeX
  Antworten mit Zitat      
Guten Abend,

also ich habe in Skim die Synchronisation aktiviert und auch das richtige Kommando angegeben (die Eingabe dieses Kommandos in die Konsole führt zum gewünschten Ergebnis), aber wenn ich die von Skim genannte Tastenkombination „cmd+shift+klick“ verwende, tut sich offensichtlich gar nix.
Woran könnte das liegen?

Der „anzuspringende“ Editor ist texmakerx, der die PDFs mit diesem Befehl erstellt:
Code
"/usr/texbin/pdflatex" -interaction=nonstopmode --shell-escape -synctex=1 %.tex

und sie dann auch wie gewünscht in Skim öffnet.

Der Befehl, mit dem Skim zurückspringen soll, ist dieser:
Code
/Applications/TeX/texmaker\(x\)/texmakerx.app/contents/macos/texmakerx

mit den Argumenten
Code
"%file" -line %line


vielen Dank und liebe Grüße!
Tobi
Private Nachricht senden Benutzer-Profile anzeigen

iTob
Forum-Meister
Forum-Meister


Beiträge: 1220
Anmeldedatum: 19.04.10
Wohnort: ---
Version: TeX Live auf OS X
     Beitrag Verfasst am: 28.09.2010, 17:09     Titel:
  Antworten mit Zitat      
benutzt denn keiner hier Skim??
Private Nachricht senden Benutzer-Profile anzeigen

phi
Moderator
Moderator

Beiträge: 420
Anmeldedatum: 06.02.09
Wohnort: ---
Version: MacTeX 2012
     Beitrag Verfasst am: 28.09.2010, 22:57     Titel:
  Antworten mit Zitat      
Ich verwende Skim, aber nicht TeXMakerX. Frag vielleicht mal an einem Ort nach, der sich direkt an OS-X-Benutzer richtet, z.B. der Mac-OS-X-TeX-Mailingliste.
Private Nachricht senden Benutzer-Profile anzeigen

iTob
Forum-Meister
Forum-Meister


Beiträge: 1220
Anmeldedatum: 19.04.10
Wohnort: ---
Version: TeX Live auf OS X
     Beitrag Verfasst am: 28.09.2010, 23:35     Titel:
  Antworten mit Zitat      
Verwendest du den auch SyncTeX? Wenn ja, mit welche Tastenkombination springst du von Skim zu deinem Editor?

Das Problem ist ja nich der TMX sondern Skim. Wenn ich den Befehl den Skim auslösen soll direkt in die Konsole tippe, passiert ja genau das, was passieren soll. Nur Skim reagiert eben scheinbar nicht auf den (in der Hilfe angegebenen) Shortcut...
Private Nachricht senden Benutzer-Profile anzeigen

phi
Moderator
Moderator

Beiträge: 420
Anmeldedatum: 06.02.09
Wohnort: ---
Version: MacTeX 2012
     Beitrag Verfasst am: 28.09.2010, 23:39     Titel:
  Antworten mit Zitat      
Die Tastenkombination ist Cmd+Umschalt+Mausklick, wie von dir gepostet. Ist vielleicht die *.synctex.gz-Datei nicht vorhanden oder befindet sich in einem anderen Verzeichnis? Ansonsten würde ich einfach mal ein Testskript als Editor in Skim angeben, welches einfach nur die übergebenen Befehlszeilenoptionen speichert.
Private Nachricht senden Benutzer-Profile anzeigen

iTob
Forum-Meister
Forum-Meister


Beiträge: 1220
Anmeldedatum: 19.04.10
Wohnort: ---
Version: TeX Live auf OS X
     Beitrag Verfasst am: 29.09.2010, 00:56     Titel:
  Antworten mit Zitat      
Die .gz-Datei wird im selben Ordner erstellt, wie die .tex-Datei, daran kann es also wohl eher nicht liegen...

phi hat Folgendes geschrieben:
Ansonsten würde ich einfach mal ein Testskript als Editor in Skim angeben, welches einfach nur die übergebenen Befehlszeilenoptionen speichert.

Wie meinst du das?
„Editor: Eigener“ setzten und dann nur ein Befehl wie „open "irgendeineDatei"“ das hab ich schon ohne Erfolg versucht. Stelle ich aber auf den (alten) TexMaker, dann öffnet sich dieser beim cmd-Umschalt-Klick...

Aber der Befehl, den ich für den tmx nutze ist der, den der Entwickler persönlich nennt, außer das ich den Pfad angepasst habe, weil der tmx bei mir in einem anderen Ordner liegt.
Original:
Code

Befehl: /applications/texmakerx.app/contents/macos/texmakerx
Argumente: "%file" -line %line

und mein pfadangepasster Befehl:
Code

Befehl: /Applications/TeX/texmaker\(x\)/texmakerx.app/contents/macos/texmakerx
Argumente wie zuvor


gute Nacht!
Tobi
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de