YAP Graphic conversion: $(Bindir) in yap.ini falscher Wert

Anzeigeprogramme für dvi, ps und pdf wie YAP, Adobe Reader, Ghostview u.a.
J.ST

YAP Graphic conversion: $(Bindir) in yap.ini falscher Wert

Beitrag von J.ST »

Hallo Zusammen,

habe meine alten EmTeX Dateien ausgepackt und versucht unter MikTex2.8 zum Laufen zu bringen. Eine der größten Hürden ist die damals von mir mit DVIWin als DVI-Viewer vorgenommene Einbindung von .TIF-Dateien. Ich habe mir gedacht, sollte ja vielleicht doch auch mit YAP hinzukriegen sein. Also folgendes Eingabefile angelegt und mit pdfLaTeX compiliert.

Code: Alles auswählen

\documentclass{article}
\pdfoutput=0
\usepackage{graphicx}
\DeclareGraphicsRule{.tif}{bmp}{}{#1}
\DeclareGraphicsExtensions{.tif}
\begin{document}
\begin{figure}[htbp]
\includegraphics[bb= 0 0 100pt 100pt,width=120mm,height=40mm]{TestXYZ.tif}
\caption{TestXYZ}
\label{TestXYZ}
\end{figure}
\end{document}
Compilierung funktioniert fehlerfrei, im Log-File erscheint bei der Grafik folgender Eintrag:
File: TestXYZ.tif Graphic file (type bmp)
<TestXYZ.tif> [1

Wenn ich die dvi-Datei dann mit YAP öffne (Render Methode=pk) kommt folgende Fehlermeldung:
Could not make Bitmap file
Data:
C:\TEMP\TestXYZ.tif

yap.ini ist die Originaldatei mit dem Eintrag für die tif-Datei:
.tif.bmp="$(bindir)\tifftopnm" "%i" | "$(bindir)\ppmtobmp" -windows > "%o"

Habe dann einmal ein bisschen mit yap.ini rumgespielt, um zu sehen, welches Kommando er für die Konvertierung ausführen will (einfach mit echo in eine Datei geschrieben). Dies sieht so aus:

C:\Documents and Settings\username\Application Data\MiKTeX\2.8\miktex\bin\tifftopnm" "C:\Temp\TestXYZ.tif" | "C:\Documents and Settings\username\Application Data\MiKTeX\2.8\miktex\bin\ppmtobmp" -windows > "C:\DOCUME~1\username\LOCALS~1\Temp\mik104A.tmp" "

In den Pfaden sind aber die Konverter nicht zu finden. Daher meine Frage:

Warum wird $(bindir) hier durch C:\Documents and Settings\username\Application Data\MiKTeX\2.8\miktex\bin ersetzt und nicht durch C:\Program Files\MiKTeX 2.8\miktex\bin wie bei mir erforderlich?

Ist dies ein Bug oder stimmt irgendwo etwas in meiner Configuration nicht?

Wäre nett, wenn mir da jemand helfen könnte.