Problem Auszeichnung des Abbildungsverzeichnis

Inhalt, Abbildungen, Tabellen, Quellcodes und andere Verzeichnisse


Katrin
Forum-Anfänger
Forum-Anfänger
Beiträge: 14
Registriert: Mo 19. Okt 2009, 19:54

Beitrag von Katrin »

huhu ihr beiden,

zunächst einfach danke für die rege anteilnahme an meinem problem.

@ schweinebacke: du hast zweimal recht.
1) ich habe rattes beispiel in mein minimalbeispiel integriert (ich wollte ja auch mein problem lösen) und da sollte das abbildungsverzeichnis natürlich drin bleiben -- schließlich löste es das problem aus; also habe ich diesen befehl von mir nicht rausgenenommen. da ich mein problem (zwar umständlich) gelöst hatte, habe ich nicht weiter gesucht;

2) chapter und section sind (s. o. minimalbeispiel) über automark vertauscht -- aus 'temporären' layoutgründen (ich lasse mir und meinem doktorvater das dokument zurzeit als "oneside" ausgeben -- und da ist es besser, als kolumnentitel den "section"-titel zu haben).

jetzt verstehe ich aber endlich wirklich, was ich 'falsch' gemacht bzw. übersehen habe.

habe natürlich gleich getestet und nun -- wenn ich meine automark-einstellung rausnehme -- klappt das auch ohne meinen etwas umständlichen lösungsweg.

Fazit: viel gelernt!

vielen dank an euch beide!

katrin

Schweinebacke

Beitrag von Schweinebacke »

Katrin hat geschrieben:2) chapter und section sind (s. o. minimalbeispiel) über automark vertauscht -- aus 'temporären' layoutgründen (ich lasse mir und meinem doktorvater das dokument zurzeit als "oneside" ausgeben -- und da ist es besser, als kolumnentitel den "section"-titel zu haben).
Das verstehe ich nicht. Solange Du die Option autooneside nicht verwendest, also die Beachtung des optionalen Arguments nicht abschaltest, brauchst Du die Vertauschung doch gar nicht:

Code: Alles auswählen

\documentclass[oneside]{scrbook}
\usepackage{scrpage2}
\ohead{\pagemark}
\chead{}
\ihead{\headmark}
\cfoot{}
\ifoot{}
\ofoot{}
\clearscrplain
\automark[section]{chapter}
\pagestyle{scrheadings}
\usepackage[ngerman]{babel}
\usepackage{blindtext}
\begin{document}
\Blinddocument
\end{document}
Die Vertauschung bringt doch außer unangenehmen Nebeneffekten wirklich nur im doppelseitigen Dokument etwas.

Katrin
Forum-Anfänger
Forum-Anfänger
Beiträge: 14
Registriert: Mo 19. Okt 2009, 19:54

Beitrag von Katrin »

Schweinebacke hat geschrieben:
Katrin hat geschrieben:2) chapter und section sind (s. o. minimalbeispiel) über automark vertauscht -- aus 'temporären' layoutgründen (ich lasse mir und meinem doktorvater das dokument zurzeit als "oneside" ausgeben -- und da ist es besser, als kolumnentitel den "section"-titel zu haben).
Das verstehe ich nicht. Solange Du die Option autooneside nicht verwendest, also die Beachtung des optionalen Arguments nicht abschaltest, brauchst Du die Vertauschung doch gar nicht:

Code: Alles auswählen

\documentclass[oneside]{scrbook}
\usepackage{scrpage2}
\ohead{\pagemark}
\chead{}
\ihead{\headmark}
\cfoot{}
\ifoot{}
\ofoot{}
\clearscrplain
\automark[section]{chapter}
\pagestyle{scrheadings}
\usepackage[ngerman]{babel}
\usepackage{blindtext}
\begin{document}
\Blinddocument
\end{document}
Die Vertauschung bringt doch außer unangenehmen Nebeneffekten wirklich nur im doppelseitigen Dokument etwas.

hej, ho schweinebacke,
Laut scrguide (S.233) ist automark so definiert:

Code: Alles auswählen

\automark[rechte Seite ]{linke Seite }
was für mich auch sinn macht. bei zweiseitiger ausgabe stände links das Kapitel (so wie es voreingestellt ist und du es oben im beispiel auch angibst) und auf der rechten seite die section;

interessant ist aber (ich hab das beispiel mal als doppelseitiges Dokument kompiliert --> Anhang) das sich das ergebnis anders darstellt!

entweder mein rechner ist "seitenverkehrt" eingestellt,... ich gucke spiegelverkehrt, oder ...
jedenfalls steht "chapter" hier rechts - nicht links, und "section" links - nicht rechts. auch die seitenzahlen stehen "innen" nicht außen... und der kolumnentitel außen.. obwohl es im code ja genau umgekehrt definiert ist (ohead=außen)

hier der quode zum dokument:

Code: Alles auswählen

\documentclass[twoside=true,headsepline]{scrbook} 
\usepackage{scrpage2} 
\ohead{\pagemark} 
\chead{} 
\ihead{\headmark} 
\cfoot{} 
\ifoot{} 
\ofoot{} 
\clearscrplain 
\automark[section]{chapter} 
\pagestyle{scrheadings} 
\usepackage[ngerman]{babel} 
\usepackage{blindtext} 
\begin{document} 
\Blinddocument 
\end{document}
da bei einseitigem druck nur die linke seite ausgegeben wird, hast du im ergebnis recht... aber ... irgedwie ist das ergebnis doch merkwürdig, oder?

:?:

grüße

katrin
Dateianhänge
TestText_Headings.pdf
(106.41 KiB) 642-mal heruntergeladen

Schweinebacke

Beitrag von Schweinebacke »

Wie kommst Du darauf, das da etwas vertauscht ist? Nehmen wir beispielsweise Seite 2: 2 ist gerade, also ist es eine linke Seite und die Seitenzahl steht ebenfalls links, also außen. Nehmen wir beispielsweise Seite 3: 3 ist ungerade, also eine rechte Seite und die Seitenzahl steht ebenfalls rechts, also außen.

Ich vermute mal, dass Du die korrekte Randverteilung bei doppelseitigen Dokumenten nicht verstanden hast. Lies mal Kapitel 2 der KOMA-Script-Anleitung und schau Dir auch die Abbildungen an, die es dort gibt.

Katrin
Forum-Anfänger
Forum-Anfänger
Beiträge: 14
Registriert: Mo 19. Okt 2009, 19:54

Beitrag von Katrin »

@schweinebacke

ups, da hast du recht... ich habe links für links genommen; okee.

grüße,

katrin

Antworten