goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 97973
Top-Poster: Johannes_B (5059)

Wir begrüßen unseren neuesten Benutzer GiFi.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Problem mit der Bibliothek

 

Matze E.
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 24.08.2009, 20:06     Titel: Problem mit der Bibliothek
  Antworten mit Zitat      
Hallo,

ich habe folgenden Code zur Dokumenteröffnung im TeXnicCenter:

Code • Öffne in Overleaf

%%
%% Dokumenteinstellungen
%%
\documentclass[12pt,german]{book}
\usepackage[T1]{fontenc}
\usepackage[latin1]{inputenc}
\usepackage{times}
\usepackage{geometry}
\geometry{verbose,a4paper,tmargin=4cm,bmargin=4cm,lmargin=2.8cm,rmargin=2.8cm}
\usepackage{babel}
\usepackage{graphicx}
\usepackage{url}
%\usepackage{ngerman}

%%
%% tex settings
%%
\setlength{\oddsidemargin}{0cm}
\setlength{\topmargin}{-1.5cm}
\setlength{\textheight}{22cm}
\setlength{\textwidth}{16cm}
\setlength{\headsep}{1cm}
\setlength{\parindent}{0ex}
\setlength{\parskip}{2.0ex plus 0.9ex minus 0.4ex}

\begin{document}
%%
%% Titelblatt,
\input{diplomarbeit_titelblatt}
%%

%% Inhaltsverzeichnis
%%
\tableofcontents


\listoffigures

\bibliographystyle{gerplain}
\addcontentsline{toc}{chapter}{Literaturverzeichnis}
\bibliography{diplomarbeit_literatur}
\end{document}

\end{document}
 


Wenn ich nun mein Projekt ausführen will, sprich Aktives Dokument erstellen und betrachten, kommt ein Dialog Fenster:

The required file
bibtex\bst\germbib\gerplain.bst
is missing. It is a part of following package
Name: germbib
Title: German variants of standard BibTeX styles
...

Ich habe schon alle Internetportale, die mir angezeigt werden ausprobiert, aber kann von dort, warum auch immer nicht runterladen. Also habe ich mir die Datei so besorgt. Wenn ich sie entpackt habe und dieser Installationsanweisung sage, dass sie aus dem directory entpacken soll, wo ich es hin extrahiert habe, bekomme ich nur folgende Fehlermeldung:

...\Diplomarbeit\germbib\germbib does not seem to be a local package repository.


Kann mir jemand helfen?

DonCube
Forum-Guru
Forum-Guru

Beiträge: 292
Anmeldedatum: 29.06.08
Wohnort: Bocholt
Version: MikTeX
     Beitrag Verfasst am: 25.08.2009, 09:59     Titel:
  Antworten mit Zitat      
Ich vermute mal du Nutzt MikTeX. Entpack die Datei einfach direkt in den entsprechenden Pfad deiner MikTeX Installation.

C:.....\MiKTeX 2.7\tex\latex

Dann solltest du noch zur Sicherheit über die Datenbank "refreshen" (sry deutsches Wort fällt mir gerade net ein) Das geht über die Miktex-Optionen unter:

C:....\MiKTeX 2.7\miktex\bin\mo.exe

Dort auf Refresh FNDB klicken. Dann sollte es eigentlich funktionieren.

Ahhhh Stop Kommando zurück ich war zu schnell mit der Antwort. Das obige gilt für *.sty also Style Dateien.

Für bst Dateien ist der Installationspfad wie dir Miktex shcon sagt:

C:.....\MiKTeX 2.7\bibtex\bst

Den entsprechenden Ordner musst du dann dort erstellen und die Datei reinpacken. Ein Refresh FNDB kann nötig sein. Aber da bin ich mir nicht sicher. Vielleicht klappts auch ohne.

Hoffe das hilft dir.

Gruß
DonCube
_________________

Schau mal hier rein goLaTeX-Wiki, und gaaaanz wichtig Minimalbeispiel
Private Nachricht senden Benutzer-Profile anzeigen

domwass
TeX-Entwickler
TeX-Entwickler


Beiträge: 621
Anmeldedatum: 26.08.08
Wohnort: ---
Version: MacTeX 2011 / LyX 2.0.3 / TeXShop 2.4.3
     Beitrag Verfasst am: 25.08.2009, 10:48     Titel:
  Antworten mit Zitat      
DonCube hat Folgendes geschrieben:
Ich vermute mal du Nutzt MikTeX. Entpack die Datei einfach direkt in den entsprechenden Pfad deiner MikTeX Installation.

C:.....\MiKTeX 2.7\tex\latex


Das ist eine ganz schlechte Idee, den texmf-Baum von MiKTeX zu benutzen, denn bei einer Neuinstallation kann dann alles flöten gehen. Besser ist es, einen lokalen Baum anzulegen, z.B. C:\localtexmf, und den dann bei MiKTeX options > Roots einzutragen.

Gruß,
Dominik.-
_________________

goLaTeX-Knigge | Minimalbeispiel | FAQs etc.
biblatex-Doku auf Deutsch
biblatex-Stile | »Bibliographien erstellen mit biblatex« (DTK-Artikel)
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de