Bibliographie wird nicht erstellt

Erstellung eines Literaturverzeichnisses mit BibTeX, Biber, BibLaTeX und Co.
Bieberli

Bibliographie wird nicht erstellt

Beitrag von Bieberli »

Guten Abend Zusammen

Ich habe heute mein neues Laptop eingerichtet und wie beim alten Laptop folgendes installiert:

TexStudio
MikeTex
JabRef

Dann meine Arbeit neu kompiliert

Es geht alles glatt nur wird die Bibliographie nicht im PDF erstellt und auch die Kürzel in \parencite{Kürzel} bleiben bestehen und werden nicht zu Autor/Jahr.

Die .bbl Datei wird ebenfalls nicht erstellt.


Ich habe die Einstellungen beim TexStudio verglichen mit denen welche ich auf dem alten Laptop habe und soweit ich sehe sind diese identisch.

Verwenden tue ich BibLaTex und damit Biber.

Mit folgendem Paket:

\usepackage[style=authoryear-ibid, maxcitenames=1, maxbibnames=10]{biblatex}

Hat jemensche eine Idee was es sein könnte? Ich vermute das ich irgendetwas nicht installiert habe....aber was?

Bieberli

Beitrag von Bieberli »

Ach installiert ist:

Basic MikeText 64 könnte dies das Problem sein?

Benutzeravatar
Johannes_B
Moderator
Moderator
Beiträge: 5080
Registriert: Do 1. Nov 2012, 14:55
Kontaktdaten:

Beitrag von Johannes_B »

Rufst du biber denn überhaupt auf? Drückst du eine Taste oder klickst etwas an?
TeXwelt - Fragen und Antworten Schaut vorbei und stellt Fragen.
LaTeX-Vorlagen?

Der Weg zum Ziel: Ruhe bewahren und durchatmen, Beiträge und unterstützende Links aufmerksam lesen, Lösungsansätze verstehen und ggf. nachfragen.

Bieberli

Beitrag von Bieberli »

Hallo Johannes

Biber wird ausgelöst.

Ich habe jetzt nochmals mit Minimalbeispielen gearbeitet und folgendes herausgefunden.

Zuerst einmal werden bei mir ca. 30 verschiedene Bib.Dateien eingebunden. Jede ist thematisch sortiert.

Wenn ich nur Einträge aus der Bib-Datei A,B,C nehme aber keine aus D dann geht es. (Und der entsprechende Pfad zur D ausblende)

Mehrere dieser 30 Bib-Dateien führen offenbar zu einen Fehler. Ich sehe aber keinen Unterschied zwischen ABC und D.

Hast du eine Idee auf was ich noch achten könnte?

Wie gesagt beim alten System hat das alles funktioniert....

Die Pfade zu ABC und D! werden auch erkannt.

Bieberli

Beitrag von Bieberli »

Wenn ich einzelne Literatureinträge dann von D nach A nehme dann stellt es auch die Einträge aus D dar.

lg

Gast

Beitrag von Gast »

biber gibt normalerweise auf dem Terminal und in der blg-Datei Auskunft über Fehler. Ansonsten kann man natürlich die Methode aus der Minimalbeispiel-Anleitung auch auf die bib-Datei D anwenden, wenn du sicher bist, dass die Ursache darin zu finden ist. So sollte es recht einfach sein, den Fehler in dieser Datei zu finden.

Wenn du schon sicher bist, dass es an der einen Datei liegt, sollte es auch einfach sein, zuerst ein Minimalbeispiel nur mit dieser einen Datei zu erstellen.

Du kannst auch die konstruktive Methode nutzen: eine neue, leere Datei Dneu erstellen und nach und nach die Einträge aus D hinein kopieren, bis der Fehler auftritt. Aber das ist meist langsamer als die destruktive Methode, da die Halbierungssuche eben sehr schnell ist.

Bieberli

Beitrag von Bieberli »

Lieber Gast

Das wollte ich dann auch so machen.

Aber was mich wunder nimmt ist die Frage wieso das jetzt überhaupt auftritt nach der Neuinstellation.

Das einzelne bib-Dateien einen Fehler enthalten der dieses Verhalten auslöst kenne ich..


Aber komisch ist es das es beim alten Laptop ja nicht auftritt und ich die Datei ganz normal erstellen kann :(

MoeWe
Forum-Century
Forum-Century
Beiträge: 208
Registriert: Fr 30. Aug 2019, 15:35
Kontaktdaten:

Beitrag von MoeWe »

Wenn Du MikTeX neu installiert hast, dann kann es schon sein, dass Du jetzt eine neuere Version von biblatex und Biber hast als vorher. Es kommt manchmal vor, dass Biber etwas strenger wird mit den Dingen, die er akzeptiert (z.B. muss seit einiger Zeit die deklarierte oder geratene Zeichencodierung wirklich mit der echten Codierung übereinstimmen, da gab es früher ein paar Ausnahmen; große Freude bereiten auch immer wieder unnötige Klammern in Namensfeldern), es könnte sich aber natürlich auch um einen einfachen Bug handeln.

Leider ist es ohne die .blg-Datei und die .log-Datei müßig, zu diskutieren, woran es liegen kann. In den Dateien müssten Hinweise zu finden sein, die Dir weiterhelfen können.

Bieberli

Beitrag von Bieberli »

Ihr habt mich auf die Spur gebracht


Folgende Punkte haben für Probleme gesorgt:

- Wenn ein Wort {Sooo} war --> Mochte es nicht
- Darwin's --> Also ein Apastroph mochte es nicht
- Ich habe ein Komma, am Schluss, --> Mochte die neue Version auch nicht

Wenn man diese Einträge entfernt klappt es.

MoeWe
Forum-Century
Forum-Century
Beiträge: 208
Registriert: Fr 30. Aug 2019, 15:35
Kontaktdaten:

Beitrag von MoeWe »

Ohne exakte Beispiele ist das leider nicht ganz nachvollziehbar. Aber nur damit zukünftige Leser nicht auf die falsche Fährte gelockt werden:

Im Allgemeinen hat Biber kein Problem mit vernünftig gesetzten geschweiften Klammern. In der Vergangenheit (und auch aktuell, wenn auch etwas begrenzter) gab es allerdings Probleme mit sehr exzessiver Klammerung in Namensfeldern. In anderen Feldern habe ich schon lange keine Probleme mehr gesehen, die zu Kompilationsfehlern führen sollten. Zu Klammern in Namen siehe https://github.com/plk/biber/issues/297 und alle dort verlinkten Beiträge.

Ein Apostroph sollte an sich kein Problem sein. Zu Problemen kann es kommen, wenn es sich bei dem Apostroph nicht um ' (U+0027 APOSTROPHE) handelt, sondern um ein spezielleres Unicode-Zeichen handelt, mit dem entweder LaTeX nicht umgehen kann oder dessen Codierung nicht mit der von Biber erwarteten Codierung übereinstimmt.

Bei dem Komma verstehe ich leider nicht, worum es geht. Es ist immer in Ordnung nach einem Feld ein Komma zu setzen, z.B.

Code: Alles auswählen

@article{sigfridsson,
  author       = {Sigfridsson, Emma and Ryde, Ulf},
  title        = {Comparison of methods for deriving atomic charges from the
                  electrostatic potential and moments},
  journaltitle = {Journal of Computational Chemistry},
  date         = 1998,
  volume       = 19,
  number       = 4,
  pages        = {377-395},
  doi          = {10.1002/(SICI)1096-987X(199803)19:4<377::AID-JCC1>3.0.CO;2-P},
}
aber es war noch nie richtig, nach der schließenden Klammer am Ende eines Eintrags ein Komma zu setzen. Einen Fehler kann ich damit aber nicht provozieren.

Kommas in Namensfeldern sollten aber schon richtig gesetzt sein, inkorrekte Dinge wie

Code: Alles auswählen

author  = {Humphrey Appleby, James Hacker, Bernard Woolley, Anne Hacker},
gefallen Biber gar nicht.

Antworten