Literaturverzeichnis will nicht

Erstellung eines Literaturverzeichnisses mit BibTeX, Biber, BibLaTeX und Co.
mato37
Forum-Anfänger
Forum-Anfänger
Beiträge: 11
Registriert: Do 27. Feb 2020, 18:07

Literaturverzeichnis will nicht

Beitrag von mato37 »

Moin liebes Forum,

ich habe ein kleines Problem mit meinem Literaturverzeichnis und zwar wird es mir nicht angezeigt, obwohl ich keine Fehler sehe ...
Vielleicht seht ihr ja welche?

Den Bibstyle usw habe ich in der Main folgender Maßen definiert

Code: Alles auswählen


%bibstyle
\usepackage[style=authoryear-comp, maxbibnames=9, maxcitenames=2, backend=biber]{biblatex}
\DefineBibliographyStrings{ngerman}{andothers = {{et\al\adddot}},} %macht aus u.a. et al.
\addbibresource{lit.bib}
\renewcommand*{\nameyeardelim}{\addcoma\space}

Hier ein kleiner Auszug aus meiner lit.bib

Code: Alles auswählen

% QUELLE 4

%Infos zur Panke

@ONLINE {Panke,
    author = {M. Wielinski},
    title  = {Panke 2015},
    year   = {2009},
    url    = {https://berlin.nabu.de/stadt-und-natur/naturschutz-berlin/gewaesserschutz/wasserrahmenrichtlinie/index.html}
}

%Quelle 5

%Gewässertyp Panke

@ONLINE {UBA_ZUST,
    author = Umweltbundesamt Abteilung II 2, J. Arle, K. Blondzik, U. Claussen, A. Duffek, S. Grimm, F. Hilliges, B. Kirschbaum, I. Kirst, D. Koch, J. Koschorreck, P. Lepom, W. Leujak, V. Mohaupt, S. Naumann, U. Pirntke, J. Rechenberg, P. Schilling, A. Ullrich, J. Wellmitz, S. Werner, R. Wolter,
    title  = Gewässer in Deutschland: Zustand und Bewertung,
    month  = aug,
    year   = 2017",
    url    = "https://isis.tu-berlin.de/pluginfile.php/1423882/mod_resource/content/1/UBA_upload.pdf"
}
Zitiert habe ich mit \cite{MDPI} und eingefügt habe ich das Literaturverzeichnis mit \printbibliography, wobei er mir in der Zeile sagt, dass er keine Bibliography hat (empty).

Vielen Dank schonmal für eure Hilfe!

ps: im Anhang habe ich noch meine Main und die lit.bib eingebunden

VG Malte
Dateianhänge
lit.txt
(4.08 KiB) 15-mal heruntergeladen
main.txt
(2.23 KiB) 19-mal heruntergeladen

Gast

Beitrag von Gast »

Die gezeigte Quelle 4 dürfte in Ordnung sein, bei der gezeigten Quelle 5 fehlt aber die komplette Klammerung der Werte. Wenn das in der echten Datei genauso ist, ist es kein Wunder, wenn es nicht funktioniert. In der blg-Datei dürften dann auch durchaus Fehler dazu gemeldet werden.

Bartman
Forum-Meister
Forum-Meister
Beiträge: 2118
Registriert: Do 16. Jul 2009, 21:41
Wohnort: Hessische Provinz

Beitrag von Bartman »

Die Autorennamen werden nicht durch and getrennt. Bei \addcoma und \al gibt es Tippfehler.

mato37
Forum-Anfänger
Forum-Anfänger
Beiträge: 11
Registriert: Do 27. Feb 2020, 18:07

Beitrag von mato37 »

Anonymous hat geschrieben:Die gezeigte Quelle 4 dürfte in Ordnung sein, bei der gezeigten Quelle 5 fehlt aber die komplette Klammerung der Werte. Wenn das in der echten Datei genauso ist, ist es kein Wunder, wenn es nicht funktioniert. In der blg-Datei dürften dann auch durchaus Fehler dazu gemeldet werden.
Hey,
danke für deine Antwort! Das war tatsächlich die einzige Quelle, bei der ich das vergessen hatte zu korrigieren.
Habe es jetzt berichtigt und schwupps hat es geklappt.

Kann ich irgendwie noch ein Leerzeichen zwischen die Quellenangaben bekommen?

Danke für deine Hilfe :)

mato37
Forum-Anfänger
Forum-Anfänger
Beiträge: 11
Registriert: Do 27. Feb 2020, 18:07

Beitrag von mato37 »

Bartman hat geschrieben:Die Autorennamen werden nicht durch and getrennt. Bei \addcoma und \al gibt es Tippfehler.
Wo genau sind die Tippfehler?

Bartman
Forum-Meister
Forum-Meister
Beiträge: 2118
Registriert: Do 16. Jul 2009, 21:41
Wohnort: Hessische Provinz

Beitrag von Bartman »

Den ersten Befehl kannst Du mithilfe der Paketdokumentation selbst berichtigen. Außerdem darfst Du bei einer aktuellen Version des Pakets biblatex für diese Einstellung den Befehl \DeclareDelimFormat nutzen.

Im zweiten Fall meinst du wahrscheinlich et\ al\adddot. Für die Zuweisung an die Option andothers gibt es nicht nur in diesem Forum reichlich Beispiele.

Antworten