goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 101297
Top-Poster: Johannes_B (5069)

Wir begrüßen unseren neuesten Benutzer Johannes2001.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Nicht anzeige der Bibliographie mit nur Warnings

 

Padawan
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 07.12.2019, 11:44     Titel: Nicht anzeige der Bibliographie mit nur Warnings
  Antworten mit Zitat      
Hallo Leute,

habe folgenden Code geschrieben:
Code
\documentclass[a4paper,
   twoside,                     % Doppelseiten
   headsepline=true,            % Trennline zum Seitenkopf  
   footsepline=true,            % Trennline zum Seitenfuß
   headings=normal
   listof=totoc,               % Verzeichnisse im Inhaltsverzeichnis aufführen
   bibliography=totoc,         % Literaturverzeichnis im Inhaltsverzeichnis aufführen
   listof=entryprefix
]
{scrartcl}

%% Deutsche Anpassungen %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
\usepackage[ngerman]{babel}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}

\usepackage{lmodern}

%% Bibliographiestil %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
\usepackage[
   backend = biber,
   natbib  = true,
   style  = alphabetic,
   sorting = nyt
]{biblatex}
\addbibresource{Literatur}
\usepackage{csquotes}


\begin{document}
\cite{GoldsteinE.Bruce2015W:dG}
\cite{Hön2019:Farbwahrnehmung}
\cite{Hön2019:Bewegungswahrnehmung}
\cite{Schultz:Gestaltgesetze}
\newpage

\nocite{*} % adds all entries in the bib file to the bibliography
\printbibliography[nottype = online, title = Literaturverzeichnis]
\printbibliography[
   type       = online,            % Put only references of the type "online" here.
   title      = {Online-Quellen},   %Setzt den Titel für den subbibliograpy          
   heading   = subbibliography
]

\end{document}


Dazu hatte ich folgende .bib Datei geschrieben:
Code
@book{GoldsteinE.Bruce2015W:dG,
   series = {Springer Lehrbuch
},
   isbn = {9783642550737},
   year = {2015},
   title = {Wahrnehmungspsychologie: der Grundkurs},
   edition = {9. Aufl.},
   publisher = {Addison-Wesley},
   language = {ger},
   author = {Goldstein, E. Bruce},
   keywords = {Wahrnehmungspsychologie}
}

@unpublished{Hön2019:Farbwahrnehmung,
   title = {Farbwahrnehmung
},
   author = {Angelika Hö},
   language = {german},
   location = Berlin,
   date = {2019-11-21},
   howpublished = Vorlesungsfolie,
   note = {Zugegriffen am: 21.11.2019}
}

@unpublished{Hön2019:Bewegungswahrnehmung,
   title = {Bewegungswahrnehmung
},
   author = {Angelika Hö},
   language = {german},
   location = Berlin,
   date = {2019-11-28},
   howpublished = Vorlesungsfolie,
   note = {Zugegriffen am: 28.11.2019}
}

@online{Schultz:Gestaltgesetze,
   author = {Birgit Schultz
},
   organization =  {Marketing-Zauber},
   url    = {https://marketing-zauber.de/gestaltgesetze/},
   title = {Gestaltgesetze: Deine geheimen Zutaten für besseres Design!},
   date   = {2019-04-27},
   language = german,
   note = {Zugegriffen am: 05.12.2019},
}
 


Dazu bekomme ich folgende fehlermeldungen:
Code
LaTeX Warning: Citation 'GoldsteinE.Bruce2015W:dG' on page 1 undefined on input
 line 31.


LaTeX Warning: Citation 'H\GenericError {(inputenc)                }{Package in
putenc Error: Invalid UTF-8 byte "F6
}{See the inputenc package documentation fo
r explanation.
}{The document does not appear to be in UTF-8 encoding.\MessageBr
eak Try adding \UseRawInputEncoding as the first line of the file\MessageBreak
or specify an encoding such as \usepackage [latin1]{inputenc
}\MessageBreak in t
he document preamble.\MessageBreak Alternatively' on page 1 undefined on input
line 32.


LaTeX Warning: Citation 'save the file in UTF-8 using your editor or another to
ol}n2019:Farbwahrnehmung' on page 1 undefined on input line 32.


LaTeX Warning: Citation 'H\GenericError {(inputenc)                }{Package in
putenc Error: Invalid UTF-8 byte "F6
}{See the inputenc package documentation fo
r explanation.
}{The document does not appear to be in UTF-8 encoding.\MessageBr
eak Try adding \UseRawInputEncoding as the first line of the file\MessageBreak
or specify an encoding such as \usepackage [latin1]{inputenc
}\MessageBreak in t
he document preamble.\MessageBreak Alternatively' on page 1 undefined on input
line 33.


LaTeX Warning: Citation 'save the file in UTF-8 using your editor or another to
ol}n2019:Bewegungswahrnehmung' on page 1 undefined on input line 33.


LaTeX Warning: Citation 'Schultz:Gestaltgesetze' on page 1 undefined on input l
ine 34.


Overfull \hbox (2188.98663pt too wide) in paragraph at lines 31--35
[]\T1/lmr/m/n/10.95 [[]] [[];
 [
]


Overfull \hbox (36.15657pt too wide) in paragraph at lines 31--35
[
]\T1/lmr/m/n/10.95 ]
 []


Overfull \hbox (2013.82222pt too wide) in paragraph at lines 31--35
\T1/lmr/m/n/10.95 [[
];
 [
]


Overfull \hbox (72.12708pt too wide) in paragraph at lines 31--35
[
]\T1/lmr/m/n/10.95 ]
 []

[1

{C:/Users/.../AppData/Local/MiKTeX/2.9/pdftex/config/pdftex.map}
]

LaTeX Warning: Empty bibliography on input line 38.


Package biblatex Warning: Type 'online' not found on input line 39.


LaTeX Warning: Empty bibliography on input line 39.

(Probe.aux)

LaTeX Warning: There were undefined references.


Package biblatex Warning: Please (re)run Biber on the file:
(biblatex)                Probe
(biblatex)                and rerun LaTeX afterwards.
 


Die Bibliographie wird erst garnicht angezeigt.
ich hoffe Ihr könnt mir weite helfen.

Lg
Padawan

MoeWe
Forum-Century
Forum-Century

Beiträge: 136
Anmeldedatum: 30.08.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 07.12.2019, 13:12     Titel:
  Antworten mit Zitat      
Die Warnung
Code
LaTeX Warning: Citation 'H\GenericError {(inputenc)                }{Package in
putenc Error: Invalid UTF-8 byte "F6
}{See the inputenc package documentation fo
r explanation.
}{The document does not appear to be in UTF-8 encoding.\MessageBr
eak Try adding \UseRawInputEncoding as the first line of the file\MessageBreak
or specify an encoding such as \usepackage [latin1]{inputenc
}\MessageBreak in t
he document preamble.\MessageBreak Alternatively' on page 1 undefined on input
line 32.

sieht etwas suspekt aus. Eigentlich sollte da stattdessen
Code
LaTeX Warning: Citation 'Hön2019:Farbwahrnehmung' on page 1 undefined on input
 line 32.

stehen.

Die Tatsache, dass die Meldung sich am ö zerschießt, lässt auf ein Codierungsproblem schließen. Sind alle Dateien wirklich UTF-8-codiert wie angegeben? https://texwelt.de/fragen/2656/wie-.....odierung-in-meinem-editor

Generell würde ich bei der Nutzung von pdfLaTeX (also wenn man nicht XeLaTeX oder LuaLaTeX nutzt) noch von nicht-ASCII-Zeichen in internen Labeln wie dem entry key absehen. In der letzten Zeit ist LaTeX da deutlich besser geworden und in einem kleinen Beispiel eben funktionierte im Grunde alles wie gewünscht, aber verlassen würde ich mich darauf bei den nicht-Unicode-fähigen Engines nicht.

Wenn also nichts geht, probiers mal mit Hoen2019:Farbwahrnehmung etc.

Wie immer bei Problemen mit dem Literaturverzeichnis bietet es sich an, nach Änderungen alle temporären Dateien (besonders .aux, .bbl, .bcf, ...) zu löschen und neu mit LaTeX, Biber, LaTeX, LaTeX zu kompilieren.

Die Kombination
Code
   style  = alphabetic,
   sorting = nyt

find ich persönlich nicht so sinnvoll, da sie in bestimmten Sonderfällen dazu führen kann, dass die alphabetischen Label nicht mehr alphabetisch sortiert im Verzeichnis auftauchen. Das kann Deine Leser verwirren, denn sie haben ja nur das Label und keine zusätzlichen Informationen über die vollen Namen.

\addbibresource{Literatur} müsste
Code
\addbibresource{Literatur.bib}

heißen, denn bei \addbibresource muss die Dateiendung mit angegeben werden. Das ist im Gegensatz zu BibTeXs \bbliography, das auch von biblatex als veralteter Befehl unterstützt wird, wo die Dateiendung nicht angegeben werden darf.

Statt edition = {9. Aufl.}, ist meist
Code
   edition = {9},
schöner.

language = {ger}, wäre wohl besser
Code
language = {german},
aber die meisten wollen das eh nicht im Verzeichnis sehen.

location = Berlin, funktioniert nur, wenn Du einen @string namens Berlin definiert hast, wahrscheinlich willst Du lieber
Code
location = {Berlin},
Dito howpublished = Vorlesungsfolie,

Bei biblatex nutzt man statt note = {Zugegriffen am: 05.12.2019}, besser das Feld urldate, zumindest, wenn der Eintrag eine URL hat
Code
@online{Schultz:Gestaltgesetze,
  author       = {Birgit Schultz
},
  organization =  {Marketing-Zauber},
  url          = {https://marketing-zauber.de/gestaltgesetze/},
  urldate      = {2019-12-05},
  title        = {Gestaltgesetze: Deine geheimen Zutaten für besseres Design!},
  date         = {2019-04-27},
  language     = {german},
}



edit ich sehe gerade, dass ein Nutzer mit gleichem Namen vor Kurzem folgendes Problem https://golatex.de/fehlermeldung-be.....tf8-kodierung-t22495.html mit sehr ähnlichen Symptomen hatte: Die gelesene Datei scheint einfach nicht valides UTF-8 zu sein.
Private Nachricht senden Benutzer-Profile anzeigen

MoeWe
Forum-Century
Forum-Century

Beiträge: 136
Anmeldedatum: 30.08.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 07.12.2019, 14:04     Titel:
  Antworten mit Zitat      
Aha! Laut https://de.wikipedia.org/wiki/ISO_8859-1#ISO/IEC_8859-1 ist die Position F6, die in der Warnung mit Invalid UTF-8 byte "F6 erwähnt wird, in latin1 aka ISO/IEC 8859-1 mit dem kleinen ö belegt. Diese Position ist in UTF-8 aber nicht zugelassen: https://de.wikipedia.org/wiki/UTF-8....._Bytes_und_ihre_Bedeutung

Das heißt mit sehr hoher Wahrscheinlichkeit, dass Deine Datei zwar LaTeX mit \usepackage[utf8]{inputenc} erzählt, dass sie UTF-8-codiert ist, sie in Wirklichkeit aber latin1-codiert ist.

Es gibt zwei mögliche Lösungen:
  1. Konvertiere Deine Datei zu UTF-8. Behalte dabei unbedingt eine Kopie der Originaldatei und beachte, dass das bloße Umstellen der Codierung im Editor unter Umständen nicht reicht, um eine schon vorhandene Datei umzucodieren.
  2. Sag LaTeX mit
    Code
    \usepackage[latin1]{inputenc}
    statt \usepackage[utf8]{inputenc} die Wahrheit.


Da UTF-8 heutzutage aber die Standardcodierung schlechthin ist, tendiere ich stark zu Nummer 1.
Private Nachricht senden Benutzer-Profile anzeigen

Padawan
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 07.12.2019, 14:32     Titel:
  Antworten mit Zitat      
Danke für deine Antwort.
Alle Dateien sind bei mir utf8 Kodiert.
Habe deine Punkte aufgegriffen und umgesetzt. Die Warnungen kommen dennoch raus, ohne dass die Quellen ausgegeben werden.

MoeWe
Forum-Century
Forum-Century

Beiträge: 136
Anmeldedatum: 30.08.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 07.12.2019, 14:49     Titel:
  Antworten mit Zitat      
Ja, die anderen Änderungsvorschläge waren nicht gedacht, das Problem zu lösen.

Wie ich in meinem Beitrag oben schrieb, weist alles darauf hin, dass Deine Dateien nicht valide UTF-8-codiert sind. Es sieht eher nach Latin-1 aus. Kannst Du unabhängig von Deinem aktuellen Editor überprüfen, dass die Dateien wirklich UTF-8-codiert sind? Wenn Du z.B. auf Windows TeXStudio oder TeXmaker nutzt, mach die Datei mal mit Notepad++ auf und sieh rein. Ansonsten gibt es andere Möglichkeiten zum Testen https://stackoverflow.com/q/3710374 oder https://unix.stackexchange.com/q/11602. Es sein angemerkt, dass es im Prinzip nicht möglich ist, die echte Codierung einer beliebigen Textdatei herauszufinden. Man kann nur durch gute "Gegenbeispiele" bestimmte Codierungen ausschließen. In dem Beispiel hier ist F6 für ö ein sehr gutes Indiz, dass es sich nicht um UTF-8 handeln kann (egal, was der Editor behauptet), denn F6 ist eine invalide Bytefolge in UTF-8 (wie erwähnt nutzen aber bestimmte 8-Bit-Codierungen wie Latin-1 F6 um das ö zu codieren).
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2020 goLaTeX.de