goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 99619
Top-Poster: Johannes_B (5059)

Wir begrüßen unseren neuesten Benutzer Kaleun.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Abbildungsnummer werden nicht immer angezeigt

 

faf32005
Forum-Anfänger
Forum-Anfänger

Beiträge: 10
Anmeldedatum: 18.12.08
Wohnort: Holzheim
Version: ---
     Beitrag Verfasst am: 24.06.2009, 19:07     Titel: Abbildungsnummer werden nicht immer angezeigt
  Antworten mit Zitat      
Hallo,

ich habe ein Problem mit der Nummerierung meiner Abbildungen. Bei einigen wird im erstellten pdf die Nummerierung richtig dargestellt, bei den meisten aber nicht.

richtig wäre so:
Abbildung A.1

falsch:
Abbildung A

Beispiel:
Der Code
Code

\documentclass[a4paper,   listof=totoc,]{scrreprt}
\usepackage{graphicx}
\usepackage[ngerman]{babel}  
\usepackage[latin1]{inputenc}  
\usepackage[german]{varioref}
\usepackage[babel,german=quotes]{csquotes}  
\usepackage[T1]{fontenc}  
\usepackage{lmodern}
\usepackage{hyperref}

\begin{document}
Bilder eines A-Frames befindet sich im Anhang \Vref{Fotos_Fiebig} (Abbildungen \ref{a_frame_aussen} und \ref{a_frame_innen}).
\end{document}
 

liefert bei mir die Ausgabe:
Bilder eines A-Frames befindet sich im Anhang A auf Seite xy (Abbildungen A.1 und A).

Ich wünsche mir aber die Ausgabe: Abbildungen A.1 und A.2

Wo liegt hier der Fehler?

Danke+Grüße
_________________

faf32005
Private Nachricht senden Benutzer-Profile anzeigen

Stefan Kottwitz
Admin
Admin


Beiträge: 1966
Anmeldedatum: 08.07.08
Wohnort: Hamburger Netzwerk-Spezialist
Version: TeX Live 2019
     Beitrag Verfasst am: 24.06.2009, 22:03     Titel: Re: Abbildungsnummer werden nicht immer angezeigt
  Antworten mit Zitat      
Hallo,

faf32005 hat Folgendes geschrieben:

... liefert bei mir die Ausgabe:
Bilder eines A-Frames befindet sich im Anhang A auf Seite xy (Abbildungen A.1 und A).


ich erhalte diese Ausgabe nicht, obiger Code liefert Warnungen wegen undefinierter Verweise. Der Codeauszug oben ist nicht repräsentativ, poste besser ein Beispiel, das Du getestet hast und das die genannte Ausgabe auch wirklich liefert, damit wir es testen und korrigieren können.

Viele Grüße,

Stefan
Private Nachricht senden Benutzer-Profile anzeigen

faf32005
Forum-Anfänger
Forum-Anfänger

Beiträge: 10
Anmeldedatum: 18.12.08
Wohnort: Holzheim
Version: ---
     Beitrag Verfasst am: 25.06.2009, 11:24     Titel: Re: Abbildungsnummer werden nicht immer angezeigt
  Antworten mit Zitat      
Hallo,

danke für die Antwort. Ich habe ein Minibeispiel in eine zip-Datei im Anhang.

Ich hoffe Ihr könnt mir weiterhelfen. Mein Abgabetermin rückt immer näher.

Danke+Grüße
Florian

Minibeispiel.zip
 Beschreibung:

Download
 Dateiname:  Minibeispiel.zip
 Dateigröße:  129.36 KB
 Heruntergeladen:  549 mal

_________________

faf32005
Private Nachricht senden Benutzer-Profile anzeigen

KOMA
TeX-Entwickler
TeX-Entwickler


Beiträge: 2637
Anmeldedatum: 04.07.08
Wohnort: ---
Version: Ich bin hier nicht mehr zu erreichen!
     Beitrag Verfasst am: 25.06.2009, 12:03     Titel:
  Antworten mit Zitat      
Das Minimalbeispiel ist kein Minimalbeispiel. Zum einen werden Pakete geladen, die für das Beispiel unerheblich sind, zum anderen besteht es unnötig aus mehreren Dateien.

Ein vollständiges Minimalbeispiel wäre beispielsweise:
Code
\documentclass{report}
\usepackage[demo]{graphicx}
\usepackage[ngerman]{babel}
\begin{document}
\listoffigures
\appendix
\chapter{Test}
Bilder eines A-Frames befindet sich im Anhang~\ref{Fotos} (Abbildungen~\ref{aussen_A-Frame} und \ref{innen_A-Frame})

\chapter{Grafiken und Bilder}\label{Fotos}
\begin{figure}
  \begin{center}
    \includegraphics[width=.75\textwidth]{fhlogo}
    \caption{A-Frame aussen}
    \label{aussen_A-Frame}
  \end{center}
\end{figure}
\begin{figure}
  \begin{center}
    \includegraphics[width=.75\textwidth]{fhlogo}
    \label{innen_A-Frame}
    \caption{A-Frame innen}  
  \end{center}
\end{figure}
\end{document}

Das wäre dann auch so klein gewesen, dass man es problemlos direkt in den Beitrag setzen kann, statt es als Anhang in einem Archiv einzufügen. Außerdem sieht man daran auch sofort, was der Unterschied zwischen den beiden Abbildungen im Quellcode ist: die Position der \label-Anweisung.

Nebenbei bemerkt solltest Du dringend l2tabu (siehe meine Signatur) lesen!
_________________

goLaTeX-Knigge (mit Themen Minimalbeispiel und So stellst Du Deine Frage richtig)
DE-TeX-FAQ, UK-FAQ, l2kurz, l2tabu, CTAN, The TeX Catalogue
KOMA-Script
Ich bin hier nicht mehr zu erreichen!

Zuletzt bearbeitet von KOMA am 25.06.2009, 12:17, insgesamt einmal bearbeitet
Private Nachricht senden Benutzer-Profile anzeigen
Verschoben: 25.06.2009, 12:05 Uhr von KOMA
Von Allgemein nach Tabellen und Grafiken

faf32005
Forum-Anfänger
Forum-Anfänger

Beiträge: 10
Anmeldedatum: 18.12.08
Wohnort: Holzheim
Version: ---
     Beitrag Verfasst am: 25.06.2009, 12:09     Titel:
  Antworten mit Zitat      
Danke für die freundliche Hilfe.
_________________

faf32005
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de