goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 100358
Top-Poster: Johannes_B (5064)

Wir begrüßen unseren neuesten Benutzer Jonas94.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Probleme mit Leerzeichen im Literaurverzeichnis beim urldate

 

MaxG
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 02.09.2019, 19:32     Titel: Probleme mit Leerzeichen im Literaurverzeichnis beim urldate
  Antworten mit Zitat      
Hallo,

ich hoffe mir kann jemand Helfen ich suche seit Stunden eine Lösung für folgendes Problem. Ich muss in meiner Masterarbeit nach Havard Zitieren und da wird für Internetquellen das Abrufdatum benötigt. Dieses muss in eckigen Klammern stehen und ohne Leerzeichen nach der ersten Klammer. Den Text habe ich schon wegbekommen aber nicht das Leerzeichen

Hier ein Minimalbeispiel
Code

\documentclass[12pt,a4paper,headsepline,plainheadsepline,hidelinks]{scrartcl}
\usepackage[ngerman]{babel}  

%Literaturverzeichnis Einstellungen
\usepackage[
firstinits=false,
uniquename=false,
backend=biber,
style=authoryear-ibid,
natbib=true,
urldate=short
]{biblatex}
\addbibresource{test.bib}
\DeclareDelimFormat{finalnamedelim}{\addspace\&\space}
\DeclareFieldFormat{urldate}{\mkbibbrackets{\bibstring{urlseen}\space#1}}
\DefineBibliographyStrings{german}{%
urlseen = {},
}
\DeclareDelimFormat{nameyeardelim}{\space}

\renewcommand*{\postnotedelim}{\addcolon\space}
\DeclareFieldFormat{postnote}{\mknormrange{#1}}

\begin{document}

Das ist ist Test fuer die Litaratur \citep{ADAC}


   \newpage
   \pagestyle{plain}

\printbibliography
\newpage



\end{document}
 


Angaben im Literaturverzeichnis

Code

@webpage{ADAC,
   Date-Added = {2019-05-24 21:52:55 +0200
},
   Date-Modified = {2019-05-24 21:54:49 +0200},
   urldate = {2019-05-09},
   Author = {ADAC},
   Month = {?},
   Url = {http://www.adac.de/infotestrat/adac-im-einsatz/motorwelt/Autokosten_so_teuer_wie_noch_nie. aspx},
   Year = {2010}}
 


[img]https://ibb.co/5sXV0fZ[/img]

In dem Bild kann man es sehen das vor der 09 noch ein Leerzeichen ist welches nicht da sein sollte

Bartman
Forum-Meister
Forum-Meister


Beiträge: 1955
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: ---
     Beitrag Verfasst am: 02.09.2019, 19:58     Titel:
  Antworten mit Zitat      


Entferne den Befehl für urlseen doch einfach, wenn Du ihn nicht brauchst. Als Folge dieser Entscheidung solltest Du natürlich auch das durch \space eingefügte Leerzeichen herausnehmen.

Code
\begin{filecontents}{\jobname.bib}
@online{ADAC,
   urldate = {2019-05-09
},
   Author = {ADAC},
   Url = {http://www.adac.de/infotestrat/adac-im-einsatz/motorwelt/Autokosten_so_teuer_wie_noch_nie.aspx},
   Date = {2010}
}
\end{filecontents}

\documentclass[fontsize=12pt,headsepline,plainheadsepline]{scrartcl}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage[ngerman]{babel}

%Literaturverzeichnis Einstellungen
% firstinits ist schon seit drei Jahren (v3.3) veraltet
\usepackage[
    style=authoryear-ibid,
    natbib,
    urldate=short
]{biblatex}

\addbibresource{\jobname.bib}

\DeclareDelimFormat{finalnamedelim}{\addspace\&\space}
\DeclareFieldFormat{urldate}{\mkbibbrackets{#1}}% <- geändert
\DeclareDelimFormat{nameyeardelim}{\addspace}

\renewcommand*{\postnotedelim}{\addcolon\space}
%\DeclareDelimFormat{postnotedelim}{\addcolon\space}% seit der biblatex-Version 3.13
\DeclareFieldFormat{postnote}{\mknormrange{#1}}

\begin{document}
Das ist ist Test fuer die Litaratur \citep{ADAC}
\printbibliography
\end{document}


Zuletzt bearbeitet von Bartman am 02.09.2019, 22:29, insgesamt 3-mal bearbeitet
Private Nachricht senden Benutzer-Profile anzeigen

MaxG
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 02.09.2019, 20:04     Titel:
  Antworten mit Zitat      
Ohman das war dumm. Danke trotzdem hat sehr gut geklappt

Bartman
Forum-Meister
Forum-Meister


Beiträge: 1955
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: ---
     Beitrag Verfasst am: 02.09.2019, 22:08     Titel:
  Antworten mit Zitat      
Falls Du den Befehl \citep noch nicht so oft in Deinem Werk benutzt hast, dann könntest Du ihn durch \autocite ersetzen. Dieser Befehl benötigt die Option natbib nicht und ist wegen des gewählten Stils auf \parencite eingestellt.
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de