l3backend-pdfmode.def Fehlermeldung

Fragen und Probleme, die nicht den obigen Kategorien zugeordnet werden können


MarieHB
Forum-Anfänger
Forum-Anfänger
Beiträge: 35
Registriert: Di 2. Feb 2016, 11:36

l3backend-pdfmode.def Fehlermeldung

Beitrag von MarieHB »

Hallo,

ich möchte einen Code (der auf einem anderen PC einwandfrei funtioniert) übersetzen lassen und bekomme andauernd folgende Fehlermeldung:

File:""C:\Users\Dell\AppData\Local\Programs\MiKTeX 2.9\tex/latex/l3kernel\expl3.sty"


Type:"Error"

Line: "line 282"

Messsage:"! LaTeX Error: File `l3backend-pdfmode.def' not found.Type X to quit or <RETURN> to proceed,or enter new name. (Default extension: def)Enter file name:! Emergency stop.<read > }"

Das Dokument sieht so aus:

\documentclass[a4paper,11pt,roman]{moderncv}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[ngerman]{babel}
\usepackage{eurosym} % €-Zeichen
%\definecolor{color1}{rgb}{0.50,0.33,0.80}% purple
\moderncvstyle{casual} % oder {classic} oder {banking}
\moderncvcolor{blue}
\usepackage{pdfpages}
\usepackage{graphicx}
\firstname{Vorname}
\familyname{Nachname}
\address{Straße}{Ort}
\phone{Telefonnummer}

\fax{Faxnummer}
\email{EMail}

\photo[5cm][0.5cm]{Gesicht.jpg}
%\extrainfo{}
%\title{Lebenslauf} %Beigestelltes Zitat: \quote{Zitat}

\begin{document}
\includepdf[pages=1]{Deckblatt.pdf}
\recipient{A}{A \newline A \newline A \vspace{5\baselineskip}}
\date{\today}
\opening{Sehr...,}
\closing{Mit freundlichen Grüßen\vspace{3\baselineskip}}
\makelettertitle
A.
\newline \\
\makeletterclosing
\newpage
\includepdf[pages=1]{1.pdf}
\includepdf[pages=2]{1.pdf}
\includepdf[pages=3]{1.pdf}
\includepdf[pages=1]{369.pdf}
\includepdf[pages=1]{urkunde.pdf}
\includepdf[pages=1]{B.pdf}
\includepdf[pages=2]{B.pdf}
\includepdf[pages=1]{Ba.pdf}
\includepdf[pages=1]{Ai.pdf}
\includepdf[pages=3]{Ai.pdf}
\includepdf[pages=4]{Ai.pdf}
\includepdf[pages=2]{A.pdf}
%\includepdf[pages=1]{Ab.pdf}
%\includepdf[pages=2]{Ab.pdf}
\includepdf[pages=1]{AU.pdf}
\includepdf[pages=1]{In.pdf}

% ... Anlagen ...
\end{document}

Vielen Dank für eure Hilfe!

Gast

Beitrag von Gast »

Aktualisiere MikTeX über die MikTeX Console in Admin- und User-Modus (Admin-Modus nur, wenn Du eine Mehrbenutzerinstallation hast), am besten zwei mal, um sicherzugehen, dass alles richtig aktualisiert wurde. Installiere dann mit der MikTeX Console das Paket l3backend, falls es noch nicht vorhanden ist.

MarieHB
Forum-Anfänger
Forum-Anfänger
Beiträge: 35
Registriert: Di 2. Feb 2016, 11:36

Beitrag von MarieHB »

Danke.

Hab ich beides gemacht (siehe beigefügten Screenshot).

Einen Aktualisierungsbutton hab ich nicht gesehen. Habe aber nach Updates gesucht.

Sogar neu gestartet. Die Fehlermeldung bleibt. :o(

Was mach ich falsch?
Dateianhänge
Unbenannt.PNG
Unbenannt.PNG (59.25 KiB) 308 mal betrachtet

Benutzeravatar
u_fischer
Forum-Meister
Forum-Meister
Beiträge: 4017
Registriert: Do 22. Nov 2012, 11:09
Kontaktdaten:

Beitrag von u_fischer »

Gehe mal in die miktex console, sowohl user als auch admin modus und benütze menu tasks-> refresh file name database.

Wenn das Problem danach immer noch besteht, kompiliere ein kleines Dokument:

\documentclass{article}\usepackage{expl3}\begin{document} hallo \end{document}.

und zeige dessen log-Datei.

MarieHB
Forum-Anfänger
Forum-Anfänger
Beiträge: 35
Registriert: Di 2. Feb 2016, 11:36

Beitrag von MarieHB »

Jetzt funktioniert alles :)

Ich habe parallel meinem Antivirenprogramm noch gesagt, dass es MikTex und TexMaker in Ruhe lassen soll. Das hat da anscheinend auch noch was blockiert....


Danke euch allen!

Antworten