goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 100386
Top-Poster: Johannes_B (5065)

Wir begrüßen unseren neuesten Benutzer blacksh33p.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

komacv: headline nur auf zweiter Seite

 

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 02.08.2019, 12:18     Titel: komacv: headline nur auf zweiter Seite
  Antworten mit Zitat      
Guten Tag!

Ich möchte bei meinem Lebenslauf, dass nur auf der zweiten Seite eine Kopfzeile eingeblendet wird, in der meine Name und der akademische Titel enthalten sind.

Ich habe es bereits hinbekommen, dass die Kopfzeile wie gewünscht auf allen Seiten erscheint. Weiterhin habe ich im Netz einen Hinweis mit einer if-Abfrage gefunden. Damit ist es zwar möglich, dass auf der ersten Seite keine Kopfzeile angezeigt wird, allerdings ist dann der Seiteninhalt nach unten verschoben, so als sei die Kopfzeile lediglich unsichtbar.

Hier mein MWE, bei dem auf jeder Seite eine Kopfzeile angezeigt wird.

Code
\PassOptionsToPackage{expansion=true, protrusion=true}{microtype}
\documentclass[
DIV=11,
fontsize=12,
paper=a4,
headsepline=true,
]{komacv}
\usepackage[ngerman]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}

\renewcommand*{\title}{CV}% PDF metadata
\renewcommand*{\firstname}{Max}
\renewcommand*{\familyname}{Muster}
\renewcommand*{\acadtitle}{B.\,Sc.}
\renewcommand*{\addressstreet}{Musterstraße 1}
\renewcommand*{\addresscity}{12345 Musterhausen}
\renewcommand*{\address}[2]{\addressstreet{#1}\addresscity{#2}}
\renewcommand*{\mobile}{0123-456789}
\renewcommand*{\phonenr}{98766-1234567}
\renewcommand*{\email}{max.muster@email.de}
\photo[]{4.3cm}{example-image-a}

\pagestyle{scrheadings}
\clearscrheadfoot
\ohead{\acadtitle~\firstname~\familyname}
\setkomafont{pagehead}{\Large}
\addtokomafont{headsepline}{\color{blue}}
\KOMAoptions{headsepline=1pt}

\begin{document}
\maketitle
\section{Beispiel}
\cvitem{Beispiel}{blabla}{}
\cvitem{Beispiel
}{blabla}{}

\section{Beispiel
}
\cvitem{Beispiel}{blabla}{}
\cvitem{Beispiel
}{blabla}{}

\section{Beispiel
}
\cvitem{Beispiel}{blabla}{}
\cvitem{Beispiel
}{blabla}{}

\section{Beispiel
}
\cvitem{Beispiel}{blabla}{}
\cvitem{Beispiel
}{blabla}{}

\section{Beispiel
}
\cvitem{Beispiel}{blabla}{}
\cvitem{Beispiel
}{blabla}{}

\section{Beispiel
}
\cvitem{Beispiel}{blabla}{}
\cvitem{Beispiel
}{blabla}{}

\section{Beispiel
}
\cvitem{Beispiel}{blabla}{}
\cvitem{Beispiel
}{blabla}{}

\end{document
}
 


Danke für eure Hilfe!

Bartman
Forum-Meister
Forum-Meister


Beiträge: 1959
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: ---
     Beitrag Verfasst am: 02.08.2019, 15:17     Titel:
  Antworten mit Zitat      
Code
\documentclass[
    DIV=11,
    headsepline=1pt
]{komacv}
\KOMAoptions{fontsize=12}
\usepackage{lmodern}% https://texwelt.de/wissen/fragen/5537
\usepackage[ngerman]{babel}
\usepackage{expl3}

% Quelle: https://tex.stackexchange.com/a/62224
\ExplSyntaxOn
\cs_new_eq:NN \Copy \prg_replicate:nn
\ExplSyntaxOff

\renewcommand*{\title}{CV}% PDF metadata
\renewcommand*{\firstname}{Max}
\renewcommand*{\familyname}{Muster}
\renewcommand*{\acadtitle}{B.\,Sc.}
\renewcommand*{\addressstreet}{Musterstraße 1}
\renewcommand*{\addresscity}{12345 Musterhausen}
\renewcommand*{\address}[2]{\addressstreet{#1}\addresscity{#2}}
\renewcommand*{\mobile}{0123-456789}
\renewcommand*{\phonenr}{98766-1234567}
\renewcommand*{\email}{max.muster@email.de}
\photo{4.3cm}{example-image-a}

\ohead{\acadtitle~\firstname~\familyname}
\setkomafont{pagehead}{\Large}
\addtokomafont{headsepline}{\color{blue}}

\begin{document}
\thispagestyle{plain}% In diesem Fall geht auch empty.
\maketitle
\Copy{7}{
    \section{Beispiel
}
    \cvitem{Beispiel}{blabla}{}
    \cvitem{Beispiel
}{blabla}{}
}
\end{document}
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 03.08.2019, 09:41     Titel:
  Antworten mit Zitat      
Vielen Dank, so klappt es. Ich habe aber noch eine Verständnisfrage:

Wenn ich bei der headsepline-Anweisung keine Liniendicke angebe, dann sitzt die Kopfzeile viel weiter unten. Woran liegt das?

esdd
Forum-Meister
Forum-Meister

Beiträge: 2475
Anmeldedatum: 07.02.10
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 04.08.2019, 13:24     Titel:
  Antworten mit Zitat      
Anonymous hat Folgendes geschrieben:

Wenn ich bei der headsepline-Anweisung keine Liniendicke angebe, dann sitzt die Kopfzeile viel weiter unten. Woran liegt das?


Sowohl die KOMA-Script-Klassen als auch das Paket scrlayer-scrpage stellen eine Option headsepline bereit.

Die Paketoption hat dabei die Syntax headsepline=dicke:breite, versteht aber auch die Werte true und false. Wird die Paketoption ohne Wertzuweisung angegeben oder mit headsepline=true, dann werden für dicke und breite Standardwerte angenommen, also .4pt bzw. die Breite der Kopfzeile.

Die Klassenoption versteht dagegen nur Ein-Aus-Werte. Wird nur headsepline als Klassenoption angegeben, dann entspricht das headsepline=true für die Klasse. Die Klassenoption headsepline=true setzt aber außerdem automatisch die Option headinclude=true, d.h. die Kopfzeile wird bei der nächsten Berechnung des Satzspiegels als Bestandteil des Textkörpers betrachtet.

Gibst Du beim Laden von komacv die Option headsepline an, dann wird sie von dieser Klasse als Option auch an die darunter liegende KOMA-Script Klasse weitergegeben, weshalb auch headinclude=true gesetzt wird. Die KOMA-Script Klasse lädt dann typearea und führt automatisch eine Satzspiegelberechnung durch.

Gibst Du dagegen beim Laden von komacv beispielsweise headsepline=1pt an, ist das nur noch eine Option von scrlayer-scrpage, die die Berechnung des Satzspiegels nicht beeinflusst.

PS: Bitte beachte, was der Status »Rückfrage« bedeutet.
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 05.08.2019, 13:10     Titel:
  Antworten mit Zitat      
Vielen Dank!

Jetzt arbeite ich schon Jahre lang mit Latex und ich komme mir noch immer wie ein totaler Anfänger vor Embarassed

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de