goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 99328
Top-Poster: Johannes_B (5059)

Wir begrüßen unseren neuesten Benutzer chrmo.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Literaturverzeichnis Zitate anpassen

 

csat6359
Forum-Newbie
Forum-Newbie

Beiträge: 3
Anmeldedatum: 14.06.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 14.06.2019, 11:01     Titel: Literaturverzeichnis Zitate anpassen
  Antworten mit Zitat      
Guten Tag,
ich habe ein Problem in meinen Literaturverzeichnis. Ich zitiere mit apa, allerdings werden mir im Literaturverzeichnis nie die Angaben bezüglich editor, series und number angezeigt, wodurch meine Zitate falsch sind.

Zum Beispiel:

@misc{FidoraMichaelandFratzscherMarcelandThimannChristian.2006,
author = {Fidora, Michael and Fratzscher, Marcel and Thimann, Christian},
date = {2006},
title = {Home bias in global bond and equity markets: The role of real exchange rate volatility},
url = {https://www.ecb.europa.eu/pub/pdf/scpwps/ecbwp685.pdf},
address = {Frankfurt am Main},
number = {685},
series = {European Central Bank Working Paper Series}
}

Ausgabe:
Fidora, M., Fratzscher, M. & Thimann, C. (2006). Home bias in global bond andequity markets: The role of real exchange rate volatility. Frankfurt am Main.Zugriff unter https://www.ecb.europa.eu/pub/pdf/scpwps/ecbwp685.pdf

Sollte aber so aussehen:
Fidora, M., Fratzscher, M. & Thimann, C. (2006). Home bias in global bond and equity markets: The role of real exchange rate volatility (European Central Bank Working Paper Series Nr. 685), Frankfurt am Main. Verfügbar unter https://www.ecb.europa.eu/pub/pdf/scpwps/ecbwp685.pdf

Hier wird series und number ausgelassen. Bei anderen Zitaten passiert mir dasselbe beim Editor. Kann mir vielleicht jemand weiterhelfen?
Private Nachricht senden Benutzer-Profile anzeigen
Verschoben: 14.06.2019, 11:44 Uhr von Johannes_B
Von MiKTeX nach Literaturverzeichnis

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 14.06.2019, 15:26     Titel:
  Antworten mit Zitat      
Wir wissen nicht, womit du dein Verzeichnis erzeugst und ob du APA wirklich brauchst: InfoMinimalbeispiel.

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 14.06.2019, 17:06     Titel:
  Antworten mit Zitat      
Hier bietet sich statt dem generischen Typ @misc der Typ @report an, der ist genau für solche Working Papers/Research Reports/White Papers/Graue Literatur anbietet.

Unter der Annahme, dass Du für Deine APA-Bibliographie biblatex-apa verwendest, könnte der Eintrag in etwa so aussehen
Code • Öffne in Overleaf
\documentclass[ngerman]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{csquotes}

\usepackage[style=apa, backend=biber]{biblatex}

\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@report{fft,
  author   = {Fidora, Michael and Fratzscher, Marcel
              and Thimann, Christian
},
  date     = {2006},
  title    = {Home Bias in Global Bond and Equity Markets},
  subtitle = {The Role of Real Exchange Rate Volatility},
  url      = {https://www.ecb.europa.eu/pub/pdf/scpwps/ecbwp685.pdf},
  address  = {Frankfurt am Main},
  number   = {685},
  type     = {European Central Bank Working Paper Series}
}
\end{filecontents}

\addbibresource{\jobname.bib}
\addbibresource{biblatex-examples.bib}

\begin{document}
\cite{sigfridsson,fft}
\printbibliography
\end{document}

csat6359
Forum-Newbie
Forum-Newbie

Beiträge: 3
Anmeldedatum: 14.06.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 17.06.2019, 15:59     Titel:
  Antworten mit Zitat      
Okay, vielen Dank! Es hat zwischenzeitlich geholfen, allerdings funktioniert mein jegliche Zitate und Quellenangaben jetzt nicht mehr. Die Zitate im Text werden mir fett ausgegeben (z.B. Tesar.1995 anstatt Tesar und Werner (1995)) Im Quellenverzeichnis ist keine einzige Quelle. Bin am verzweifeln, muss irgendetwas aus Versehen geändert haben und es lässt sich nicht mehr die alte Version herstellen.

\documentclass[12pt]{article}
\setcounter{secnumdepth}{0}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[german]{babel}
\usepackage[dvipsnames]{xcolor}
\usepackage[a4paper, top=25mm, left=35mm, right=15mm, bottom=25mm, bindingoffset=5mm]{geometry}
\usepackage[onehalfspacing]{setspace}

\usepackage[babel, german=quotes]{csquotes}
\usepackage[babel,german=guillemets]{csquotes}
\usepackage[backend=biber, style=apa, maxbibnames=9, maxcitenames=2, citestyle=authoryear]{biblatex}
\DeclareLanguageMapping{german}{german-apa}
\addbibresource{Bib.bib}
\setlength{\bibitemsep}{1em}

\begin{document}
\newpage
\medskip
\addcontentsline{toc}{section}{Literatur}
\bibliographystyle{apacite}
\printbibliography
\end{document}



Die Bibangaben befinden sich in Bib.bib.
Private Nachricht senden Benutzer-Profile anzeigen

u_fischer
Forum-Meister
Forum-Meister


Beiträge: 3935
Anmeldedatum: 22.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 17.06.2019, 16:01     Titel:
  Antworten mit Zitat      
biblatex braucht biber, nicht bibtex.
_________________

Ulrike Fischer
www.troubleshooting-tex.de
Private Nachricht senden Benutzer-Profile anzeigen

csat6359
Forum-Newbie
Forum-Newbie

Beiträge: 3
Anmeldedatum: 14.06.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 17.06.2019, 16:26     Titel:
  Antworten mit Zitat      
ich habe biber verwendet
Private Nachricht senden Benutzer-Profile anzeigen

u_fischer
Forum-Meister
Forum-Meister


Beiträge: 3935
Anmeldedatum: 22.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 17.06.2019, 16:39     Titel:
  Antworten mit Zitat      
Dann zeige den Inhalt der blg-Datei.
_________________

Ulrike Fischer
www.troubleshooting-tex.de
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 17.06.2019, 21:09     Titel:
  Antworten mit Zitat      
Der gezeigte Code ist so nicht lauffähig und verursacht schon echte Fehler, bevor es mit biblatex richtig los geht.

Du lädst csquotes zweimal aber mit unterschiedlichen Optionen
Code • Öffne in Overleaf
\usepackage[babel, german=quotes]{csquotes}
\usepackage[babel,german=guillemets]{csquotes}

Da ist LaTeX etwas überfordert und beschwert sich
Code • Öffne in Overleaf
! LaTeX Error: Option clash for package csquotes.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...                                              
                                                 
l.12 \usepackage
                [backend=biber, style=apa, maxbibnames=9, maxcitenames=2, ci...

Die Lösung ist es, sich für eine der beiden Optionen zu entscheiden (also german=quotes oder german=guillemets), ferner heißt die Option babel heute autostyle. Ersetze also die zwei Zeilen durch
Code • Öffne in Overleaf
\usepackage[autostyle, german=guillemets]{csquotes}

(wahlweise auch mit quotes statt guillemets, wobei german=quotes der Voreinstellung entspricht und weggelassen werden kann).

Code • Öffne in Overleaf
\usepackage[backend=biber, style=apa, maxbibnames=9, maxcitenames=2, citestyle=authoryear]{biblatex}

beinhaltet keine Fehler, ist aber merkwürdig.
Mit style=apa bestellst Du Zitate und Literaturverzeichnis nach den Vorgaben der APA. Dann lädst Du aber Optionen und gar einen anderen Zitierstil (citestyle=authoryear), die die APA-Vorgaben im Detail dann nicht mehr erfüllen. Wenn Du APA willst, lad nur
Code • Öffne in Overleaf
\usepackage[backend=biber, style=apa]{biblatex}

wenn nicht, möchte ich dringen raten, style=apa sein zu lassen, dann wäre eher etwas wie
Code • Öffne in Overleaf
\usepackage[backend=biber, style=authoryear, maxbibnames=9, maxcitenames=2]{biblatex}

angebracht.

Die Zeile
Code • Öffne in Overleaf
\DeclareLanguageMapping{german}{german-apa}

ist auf aktuellem Systemen nicht mehr nötig, sie wird nur auf veralteten Systemen (wie es bei Overleaf läuft) gebraucht.

Es sei angemerkt, dass german (auch in \usepackage[german]{babel}) noch die Regeln der alten Rechtschreibung implementiert, für die neue Rechtschreibung nach 1996 solltest Du ngerman nutzen.

Code • Öffne in Overleaf
\newpage
\medskip
\addcontentsline{toc}{section}{Literatur}

Mutet etwas abenteuerlich an. Warum ein \medskip nach dem \newpage?
Wenn Du das Literaturverzeichnis ins Inhaltsverzeichnis eintragen möchtest, nutze einfach
Code • Öffne in Overleaf
\printbibliography[heading=bibintoc]


Die Verwendung von \bibliographystyle mit biblatex ist inkorrekt, da die Stile über die Ladeoptionen von biblatex ausgewählt werden. \bibliographystyle ist ein Befehl von BibTeX, er erzeugt einen Fehler bei der Verwendung von biblatex
Code • Öffne in Overleaf
! Package biblatex Error: '\bibliographystyle' invalid.

See the biblatex package documentation for explanation.
Type  H <return>  for immediate help.
 ...                                              
                                                 
l.19 \bibliographystyle{apacite}


Besser sähe der Code also so aus (besser ist hier relativ, ich habe die fragwürdigen Randeinstellungen dringelassen, ebenso onehalfspacing, \setcounter{secnumdepth}{0}; persönlich würde ich das so nicht nutzen, aber wahrscheinlich hast Du Vorgaben ...).
Wenn Du noch ein veraltetes System nutzt, brauchst Du eventuell doch noch \DeclareLanguageMapping{ngerman}{ngerman-apa}.
Code • Öffne in Overleaf
\documentclass[12pt]{article}
\setcounter{secnumdepth}{0}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[ngerman]{babel}
\usepackage[dvipsnames]{xcolor}
\usepackage[a4paper, top=25mm, left=35mm, right=15mm, bottom=25mm, bindingoffset=5mm]{geometry}
\usepackage[onehalfspacing]{setspace}

\usepackage[autostyle, german=guillemets]{csquotes}
\usepackage[backend=biber, style=apa]{biblatex}

\addbibresource{biblatex-examples.bib}
\setlength{\bibitemsep}{1em}

\begin{document}
\autocite{sigfridsson}

\printbibliography[heading=bibintoc]
\end{document}


Probier es mal mit dem Dokument. Bitte zeig uns die .blg-Datei (das ist eine normale Textdatei, aber unter Windows wird sie möglicherweise als "Leistungsüberwachungs"/"Performance Monitor"-Datei erkannt - Du kannst sie trotzdem mit Deinem Lieblings-Texteditor öffnen; eventuell musst Du die Dateiendungen einblenden lassen, um sie besser zu finden), sowie alle relevanten Teile der .log-Datei.

Du solltest Fehler niemals ignorieren und über sie hinweggehen. Auch Warnungen sollten idealerweise vermieden werden.

Wenn Du Dein echtes Dokument noch einmal probieren möchtest, lösche erst alle temporären Dateien (.aux, .bbl, .bcf, ...) und kompilieren dann mit LaTeX, Biber, LaTeX, LaTeX erneut. Im ersten Aufruf von LaTeX dürfen keine Fehler mehr gemeldet werden, erst dann kannst Du zu Biber übergehen.

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de