goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 98880
Top-Poster: Johannes_B (5059)

Wir begrüßen unseren neuesten Benutzer marge.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

scrlttr2 - Cover Letter (Englisch)

 

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 08.06.2019, 13:46     Titel: scrlttr2 - Cover Letter (Englisch)
  Antworten mit Zitat      
Guten Tag!

Ich möchte mit der scrlttr2-Klasse ein englisches Anschreiben verfassen. Prinzipiell funktioniert das auch sehr gut, nur drei kleine Probleme bleiben offen. Leider konnte ich die mit der Koma-Script Dokumentation nicht lösen (was aber auch am enormen Umfang und meiner Unwissenheit liegen könnte Smile ).

Hier mal ein Minimalbeispiel:

Code • Öffne in Overleaf
\documentclass[11pt,
            paper=a4,
           
]{scrlttr2}
\usepackage{marvosym}
\usepackage{xcolor}
\KOMAoptions{%
 fromalign=right,%
 fromrule=afteraddress,%
 fromphone=true,%
 fromemail=true,%
 fromurl=false,%
 fromlogo=false,%
 foldmarks=false,%
 backaddress=false,%
 addrfield=true,%
 footsepline=false,
 headsepline=false,
 enlargefirstpage=true,
 pagenumber=footleft,
 firstfoot=false,
}
\addtokomafont{fromrule}{\color{blue}}
\makeatletter
\@setplength[1]{toaddrhpos}{\oddsidemargin}
\@addtoplength[1]{toaddrhpos}{1in}
\@setplength[1]{firstheadhpos}{\oddsidemargin}
\@addtoplength[1]{firstheadhpos}{1in}
\@setplength[1]{firstheadwidth}{\textwidth}
\@setplength{sigbeforevskip}{0cm}
\@setplength{toaddrvpos}{2cm}
\@setplength{refvpos}{7cm}
\@setplength{fromrulethickness}{1pt}
\makeatother

\usepackage[british]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[babel, english=british]{csquotes}
\usepackage{microtype}

\setkomavar{fromname}{Max Mustermann}
\setkomavar{fromaddress}{Musterstraße 1 \\
                   12345 Musterstadt
}

\setkomavar{fromphone}[\Telefon\enskip]{12345-6789}
\setkomavar{fromemail}[\Letter\enskip]{max.muster@email.de}
\setkomavar{date}{\today}

\KOMAoptions{DIV=last}

\begin{document}
\begin{letter}{Empfänger}
\setkomavar{toname}{Muster GmbH\\HR}
\setkomavar{toaddress}{Musterring 15 \\ 54321 Musterhausen}
\setkomavar{subject}{Betreff\\ (Referenz: 12345)}

\opening{Dear Sir or Madam}

blablabla

\closing{Yours sincerely}


\end{letter}
\end{document}


1. das "th" hinter dem Tag soll nicht angezeigt werden. Ist anscheinend eine veraltete Schreibweise.

2. Das Datum soll rechtsbündig zwischen Absender- und Empfängeradresse stehen. Gibt es dafür einen einfachen Schalter oder muss man das händisch dort hin bewegen?

3. Der Betreff soll nach der Anrede stehen, gleiche Frage wie beim Datum.

Danke!

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 08.06.2019, 14:20     Titel:
  Antworten mit Zitat      
Ok, den Schalter für den Betreff habe ich gefunden Smile, der Rest bleibt offen.

esdd
Forum-Meister
Forum-Meister

Beiträge: 2458
Anmeldedatum: 07.02.10
Wohnort: Stutensee
Version: MiKTeX 2.9
     Beitrag Verfasst am: 08.06.2019, 17:36     Titel:
  Antworten mit Zitat      
Das th nach dem Tag kommt von Deiner Spracheinstellung für babel. Eventuell magst Du lieber die australian Version:

Code • Öffne in Overleaf
\documentclass{scrlttr2}

\usepackage[australian,main=british]{babel}
\AtBeginLetter{\dateaustralian}

\begin{document}
\begin{letter}{Empfänger}
\opening{Dear Sir or Madam}
\closing{Yours sincerely}
\end{letter}
\end{document}


Für dieKOMA-Script Variable date ist die Verwendung des aktuellen Datums übrigens voreingestellt.

Die Positionierung Deines Datums ist dagegen schwieriger. Du kannst zunächst mit der Option

Code • Öffne in Overleaf
refline=nodate


die Ausgabe des Datums in der Referenzzeile unterdrücken. Um das Datum an der gewünschten Stelle einzufügen, lässt sich vom Prinzip her

Code • Öffne in Overleaf
\setkomavar{location}{\raggedleft\usekomavar{date}}


nutzen. Aber wenn Du das in Dein Beispiel einfügst, überlappt sich das Datum mit der Kopfzeile. Grund dafür ist zum einen die Höhe der Kopfzeile und zum anderen Deine Positionierung des Adressfeldes - das überlappt ebenfalls mit der Kopfzeile. Wenn die Empfängeradresse zwei Zeilen mehr hat, wird das unübersehbar.

Du kannst die Positionen von Adressfeld und Absenderergänzung anzeigen lassen:

Code • Öffne in Overleaf
\LoadLetterOption{visualize}
\showfields{address,location}
 


Vielleicht magst Du die Pseudolänge toaddrvpos anpassen. Mit der Option

Code • Öffne in Overleaf
addrfield=topaligned


kannst Du die Adresse im Adressfeld oben (aber unterhalb der nicht ausgegebenen Rücksendeadresse) ausrichten. Ach und am besten ist Du ergänzt noch refline bei den anzuzeigenden Brieffeldern, nicht dass eine lange Adresse dann in diese hineinragt. Außerdem ließen sich noch die Positionen von Kopf- (head) und Fußzeile (foot) anzeigen.

Die aktuelle KOMA-Script Version stellt jetzt übrigens auch \setplength und \addtoplength bereit.
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 09.06.2019, 11:53     Titel:
  Antworten mit Zitat      
Ich würde mir übrigens überlegen, ob es nicht besser ist, das Datum explizit anzugeben, statt das Datum des LaTeX-Laufs zu verwenden. Bei Briefen halte ich es für nicht günstig, wenn in drei Monaten bei demselben Brief ein anderes Datum aus dem Quelltext entsteht.

BTW: Kann es sein, dass in scrlttr2 bei den Sprachen ein Fehler ist? Das numerische Datum für australian wird offenbar nicht gesetzt. Stattdessen wird dort ein numerisches Datum für australien gesetzt. Tippfehler?

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 09.06.2019, 12:06     Titel:
  Antworten mit Zitat      
Anonymous hat Folgendes geschrieben:
Tippfehler?

Autor sagt: "Ja."

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 10.06.2019, 11:17     Titel:
  Antworten mit Zitat      
Danke für eure Hilfe!

Da es für das Datum anscheinend keinen einfachen Schalter gibt, habe ich jetzt die Pseudolängen so angepasst, dass das Datum an der gewünschten Stelle steht.

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de