Dinbrief und tikz

Schriftbild, Absätze und Auflistungen einstellen
Investment
Forum-Newbie
Forum-Newbie
Beiträge: 6
Registriert: Mo 20. Jun 2016, 16:10

Dinbrief und tikz

Beitrag von Investment »

Hallo zusammen,

beim compilieren vom gleich zu lesenden Code werden unterschiedliche Ergebnisse (lokale Installation vs. Overleaf) erzielt, welche sich wie folgt darstellen.

Sobald im Dinbrief das Package "tikz" eingebunden wird, liefert die lokale Installation von MiKTeX (absolut jungfräulich und ohne Modifikationen) gegenüber dem Online-Interpreten "Overleaf" als Ergebnis lediglich die Linien (der Text fehlt). Eine Betrachtung der eingebundenen Schriften via Adobe Reader (Einstellungen bzw. STRG-D und dann den Reiter "Schriften" ausgewählt) liefert jeweils identische Ausgaben. Allein die Dateigröße lässt darauf schließen, dass in der lokalen Installation beim Einbinden des zusätzlichen Pakets "tikz" etwas fehlt.
Wodurch kann ein solches Verhalten entstanden sein (Updates wurden direkt nach der Erstinstallation via der MiKTex Konsole integriert und stellen die einzigen Anpassungen dar) und wie lässt sich ggf. das Verhalten positiv korrigieren? Besten Dank im Voraus.

Code: Alles auswählen

\documentclass[12pt]{dinbrief}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{libertine}
\usepackage{german}
%\usepackage{tikz}

\address
{
	eigene Adresse
}

\backaddress{Rückadresse}
\signature{Name}
\place{Ort}

\begin{document}
	\begin{letter}
		{
			Zieladresse
		}

		\subject{Betreff}

		\opening{Anrede}

			alles erkennbar, solange "tikz" außen vor bleibt.
		\closing{Gruß}

	\end{letter}
\end{document}
Gib
Dateianhänge
document2. - ohne tikz Text lesbar.pdf
(83.6 KiB) 50-mal heruntergeladen
document2 - tikz geladen ohne Schrift .pdf
(84.12 KiB) 62-mal heruntergeladen

Gast

Beitrag von Gast »

Mit TeX Live 2019 (Updatestand ist heute Nacht) gibt es keine Probleme. Trotzdem sei auf zwei Dinge hingewiesen:

Zum einen sollte man german besser nicht mehr verwenden. Das Paket ändert direkt catcodes, so dass später geladene Pakete ebenso wie Definitionen in der Dokumentpräambel ins Straucheln kommen können. Es wird auch seit Jahren nicht mehr gepflegt. Deshalb ist babel mit Option german die bessere Lösung. Falls nicht ein historischer Text gesetzt werden soll, ist in der Regel sogar Option ngerman die bessere Wahl.

dinbrief wird schon seit vielen Jahren nicht mehr gewartet. Der eigentliche Maintainer, ein DANTE-Urgestein, ist leider inzwischen verstorben. In der Klasse gibt es ein paar Code-Eigentümlichkeiten, die noch auf LaTeX 2.09 zurück gehen. So wird beispielsweise \enddocument in einer Art und Weise umdefiniert, die nicht wirklich unproblematisch ist.

Wenn sich also nicht jemand findet, der die Klasse mal gründlich überarbeitet, würde ich eher davon abraten.

Gast

Beitrag von Gast »

Bei mir wird in Okular und Evince übrigens auch dein Beispiel "ohne Schrift" mit Schrift/Text angezeigt.

esdd
Forum-Meister
Forum-Meister
Beiträge: 2481
Registriert: So 7. Feb 2010, 16:36

Beitrag von esdd »

Mit MiKTeX (letztes Update gestern) kann ich das auch nicht reproduzieren. Außerdem wird bei mir sowohl mit Sumatra als auch Adobe Reader der Text in beiden von Dir angehangenen Dateien angezeigt.

Investment
Forum-Newbie
Forum-Newbie
Beiträge: 6
Registriert: Mo 20. Jun 2016, 16:10

Beitrag von Investment »

Eure Antwortzeiten sind ja extrem kurz. Respekt! Sehr gut.
In einem Online-Betrachter (Insign) kommt es bei der als fehlerhaft deklarierten Datei zu folgender unerwünschter Ausgabe. Nur dort wird der Unterschied visuell wahrgenommen. Ansonsten spricht nur die verminderte Dateigröße für etwaige Fehler hinsichtlich der Darstellung.

Bzgl. des Pakets "german" - danke für den Hinweis. Dies steht so noch im Originalquelltext. Von mir genutzt wird generell \usepackage[ngerman]{babel}.

Gibt es aufgrund der neuen Darstellung noch Ideen, weshalb es dazu kommt?
Dateianhänge
2019-06-03_09h14_21.png
2019-06-03_09h14_21.png (55.89 KiB) 171 mal betrachtet

Antworten