cite biblatex

Erstellung eines Literaturverzeichnisses mit BibTeX, Biber, BibLaTeX und Co.
jan_org
Forum-Anfänger
Forum-Anfänger
Beiträge: 34
Registriert: Di 26. Mär 2019, 14:16

cite biblatex

Beitrag von jan_org »

Um für jedes Chapter eine Bibliography verwenden zu können sowie der Möglichkeit, einen kompletten Eintrag im Fließtext zu zitieren, verwende ich biblatex wie folgt:

Code: Alles auswählen

\documentclass[12pt,a4paper]{report}

\usepackage[style=chicago-authordate, natbib=true, refsection=chapter, backend=biber]{biblatex}
\addbibresource{doc.bib}

\begin{document}

\chapter{1}
\cite{yellen84}\\ 
\citep{yellen84}\\
\fullcite{yellen84}\\
\printbibliography[heading=subbibliography]
\chapter{2}
\cite{acemoglu02}\\
\citep{acemoglu02}\\
\fullcite{acemoglu02}
\printbibliography[heading=subbibliography]
\end{document}
Problem ist, dass bei der Verwendung von \cite{} nicht Autor (Jahr), sondern Autor Jahr im Dokument ausgegeben wird.

Anbei noch die doc.bib

Code: Alles auswählen

@article{acemoglu02,
 author = {Daron Acemoglu},
 journal = {Journal of Economic Literature},
 number = {1},
 pages = {7-72},
 title = {Technical Change, Inequality, and the Labor Market},
 volume = {40},
 year = {2002},
}

@article{yellen84,
Author = {Janet L. Yellen},
Title = {Efficiency Wage Models of Unemployment},
Journal = {American Economic Review},
Volume = {74},
Number = {2},
Year = {1984},
pages = {200-205}
}

Gast

Beitrag von Gast »

Für Zitate im Format "Autor (Jahr)" in Author-Jahr-Stilen gibt es den Befehl \textcite. Im natbib-Kompatibilitätsmodus kannst Du auch \citet stattdessen nutzen.

Es wird übrigens empfohlen, diese Stile des Pakets biblatex-chicago nicht über \usepackage{biblatex} zu laden, sondern über das Wrapper-Paket \usepackage{biblatex-chicago}. Der natbib-Kompatibilitätsmodus funktioniert dann aufgrund der Implementation in biblatex-chicago aber nur, wenn die Option ohne Wert angegeben wird also natbib statt natbib=true. Ich bin aber eh ein Freund der biblatex-Namen und schreibe daher \parencite statt \citep.

Code: Alles auswählen

\documentclass[12pt,a4paper]{report}

\usepackage[authordate, refsection=chapter, backend=biber]{biblatex-chicago}
\addbibresource{biblatex-examples.bib}

\begin{document}

\chapter{1}
\cite{sigfridsson}

\textcite{sigfridsson}

\parencite{sigfridsson}

\fullcite{sigfridsson}

\printbibliography[heading=subbibliography]

\chapter{2}
\cite{worman}

\textcite{worman}

\parencite{worman}

\fullcite{worman}

\printbibliography[heading=subbibliography]
\end{document}

jan_org
Forum-Anfänger
Forum-Anfänger
Beiträge: 34
Registriert: Di 26. Mär 2019, 14:16

Beitrag von jan_org »

Hierzu eine Rückfrage.

Wenn ich im "echten" Dokument compiliere, kommen einige Fehlermeldungen. Ohne biblatex wird jedoch Output erzeugt. Nutze ich nun biblatex, passiert gar nichts mehr.

Gast

Beitrag von Gast »

Funktioniert das gezeigte Beispiel, wenn Du es exakt so in einem neuen, leeren Order kompilierst?

Lösche die temporären Dateien Deines echten Dokuments (.aux, .bbl, .bcf, ...) und kompiliere mit LaTeX, Biber, LaTeX, LaTeX. Welche Fehlermeldungen bekommst Du? (Bitte kopiere den relevanten Ausschnitt aus der .log-Datei oder die ganze .blg-Datei.) Wenn Du schon im ersten LaTeX-Lauf einen Fehler bekommst, dann solltest Du den beseitigen, bevor Du mit den anderen Schritten weitermachst.

Wie genau nutzt Du biblatex in Deinem echten Dokument? Kannst Du uns ein Minimalbeispiel zeigen?

jan_org
Forum-Anfänger
Forum-Anfänger
Beiträge: 34
Registriert: Di 26. Mär 2019, 14:16

Beitrag von jan_org »

Ein Eintrag in der Bibtex-Datenbank war der Übeltäter

Antworten