goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 99374
Top-Poster: Johannes_B (5059)

Wir begrüßen unseren neuesten Benutzer naderda.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

LaTeX Warning: Citation `Blazek 1996' on page 1 undefined

 

Maria-73
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 08.04.2019, 21:37     Titel: LaTeX Warning: Citation `Blazek 1996' on page 1 undefined
  Antworten mit Zitat      
Hallo zusammen,
ich habe das Problem, das ich immer wieder diese Fehlermeldungen bekomme:

"Citation `Blazek 1996' on page 1 undefined" (line 20)
"Empty `thebibliography' environment or \BreakBibliography before end of `thebibliography' environment" (line 3)
"There were undefined references." (line 1)

Und das bei diesem LaTeX-Dokument:

Code • Öffne in Overleaf

\documentclass[11pt,a4paper,bibliography=totoc]{scrreprt}

\usepackage[left=2cm,right=2cm,top=2cm,bottom=2cm]{geometry}
\usepackage[ngerman]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{blindtext}

\usepackage[pdfborder={0 0 0}]{hyperref}

\usepackage{graphicx}

\setlength{\parindent}{0px}


\begin{document}
\sffamily

\blindtext
\cite{Blazek 1996}

\bibliographystyle{plain}
\bibliography{Quellen}


\end{document}
 


Meine Referenzen habe ich unter Quellen.bib im selben Ordner gespeichert.
Meine Referenzen sehen im Übrigen so aus:

Code • Öffne in Overleaf

@Book{Blazek 1996,
  title     = {Rosa Zeiten für rosa Liebe - Zur Geschichte der Homosexualität
},
  publisher = {Fischer},
  year      = {1996},
  author    = {Helmut Blazek},
}

@Book{Linnhoff 1976,
  title     = {Weibliche Homosexualität - zwischen Anpassung und Emanzipation
},
  publisher = {Kiepenheuer \& Witsch},
  year      = {1976},
  author    = {Ursula Linnhoff},
}

@Book{Kunst 2007,
  title     = {Wenn Jungen Jungen und Mädchen Mädchen lieben - Alles rund um Homosexualität
},
  publisher = {Ueberreuter},
  year      = {2007},
  author    = {Marie-Luise Kunst},
}
 


Ich weiß einfach nicht mehr weiter. Ich habe schon versucht die bib Datei zu Kompilieren. Das hat auch in sofern funktioniert das jetzt angezeigt wird das ein Literaturferzeichnis erstellt werden soll (das heißt die Überschrift ist da).

Grüße und Danke
Maria

Bartman
Forum-Meister
Forum-Meister


Beiträge: 1833
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: ---
     Beitrag Verfasst am: 08.04.2019, 21:47     Titel:
  Antworten mit Zitat      
Leerzeichen sind meines Wissens in den Schlüsseln für Literatureinträge nicht erlaubt.

Außerdem: https://komascript.de/faq_parindent
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 08.04.2019, 21:47     Titel:
  Antworten mit Zitat      
Hast Du überhaupt bibtex aufgerufen. Denn eigentlich sollte der Aufruf von bibtex eine sehr klare Fehlermeldung ergeben:
Code • Öffne in Overleaf
White space in argument---line 22 of file test.aux
 : \citation{Blazek
 :                  1996
}
 


Damit sollte dann klar sein, dass Leerzeichen im key eine Datenbankeintrags nicht erlaubt sind:
Code • Öffne in Overleaf
\begin{filecontents*}{\jobname.bib}
@Book{Blazek1996,
  title     = {Rosa Zeiten für rosa Liebe - Zur Geschichte der Homosexualität
},
  publisher = {Fischer},
  year      = {1996},
  author    = {Helmut Blazek},
}

@Book{Linnhoff1976,
  title     = {Weibliche Homosexualität - zwischen Anpassung und Emanzipation
},
  publisher = {Kiepenheuer \& Witsch},
  year      = {1976},
  author    = {Ursula Linnhoff},
}

@Book{Kunst2007,
  title     = {Wenn Jungen Jungen und Mädchen Mädchen lieben - Alles rund um Homosexualität
},
  publisher = {Ueberreuter},
  year      = {2007},
  author    = {Marie-Luise Kunst},
}

\end{filecontents*}

\documentclass[11pt,a4paper,bibliography=totoc]{scrreprt}

\usepackage[left=2cm,right=2cm,top=2cm,bottom=2cm]{geometry}
\usepackage[ngerman]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{blindtext}

\usepackage[pdfborder={0 0 0}]{hyperref}

\usepackage{graphicx}

%\setlength{\parindent}{0px}% Das unbedingt bleiben lassen! → https://komascript.de/faq_parindent


\begin{document}
\sffamily% Das ist hier auch Unfug! Wenn das ganze Dokument serifenlos sein
         % soll, dann \renewcommand{\familydefault}{\sfdefault} in die
         % Dokumentpräambel einfügen.

\blindtext
\cite{Blazek1996}

\bibliographystyle{plain}
\bibliography{\jobname}


\end{document}
 

Unbedingt auch die neu hinzugefügten Kommentare beachten!

BTW: Der Stil plain ist eigentlich nicht für Einträge in Deutsch geeignet. Auch daher empfehle ich die Verwendung von biblatex und biber statt bibtex. Siehe dazu die wichtigen Hinweise (TOP-Thema in diesem Forum).

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de