goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 98391
Top-Poster: Johannes_B (5059)

Wir begrüßen unseren neuesten Benutzer lanus111.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

biblatex-chem lässt sich nicht nutzen

 

LaTeXN00b
Forum-Newbie
Forum-Newbie

Beiträge: 3
Anmeldedatum: 27.03.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 27.03.2019, 00:53     Titel: biblatex-chem lässt sich nicht nutzen
  Antworten mit Zitat      
Hallo,

ich habe den ganzen Tag herum probiert und diverse Forenposts gelesen, jedoch finde ich keine Lösung für mein Problem.

Ich möchte \bibliographystyle mit Hilfe des biblatex-chem- Packages ändern, jedoch erhalte ich jedes Mal Fehlermeldungen.

Ich nutze als Datenbank JabRef im biblatex-modus und als Editor TeXmaker. Als Packagemanager nutze ich MiKTeX, über den ich auch biblatex-chem heruntergeladen habe.

Die Fehlermeldung ist:
Code • Öffne in Overleaf

"! LaTeX Error: File `style=chem-angew.sty' not found.
Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: sty)
Enter file name:
! Emergency stop.
<read *>
l.13 \usepackage{style=chem-angew}{
biblatex
}
*** (cannot \read from terminal in nonstop modes)"
 


Meine Präambel sieht so aus:
Code • Öffne in Overleaf

\documentclass[12pt,a4paper]{article}
\usepackage[utf8]{inputenc}
\usepackage[german]{babel}
\usepackage{mathptmx}
\usepackage[T1]{fontenc}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{graphicx}
\usepackage{lmodern}
\usepackage[version=4]{mhchem}
\usepackage[onehalfspacing]{setspace}
\usepackage{style=chem-angew}{biblatex} %aus der pdf zum package kopiert
 


Um das Literaturverzeichnis zu erstellen nutze ich einfach \bibliography{Literatur.bib}.
Mein Literaturverzeichnis sieht so aus:
Code • Öffne in Overleaf

% Encoding: UTF-8

@Book{Atkins1990,
  author    = {Atkins, Peter W. and Trapp, Charles A. and De Paula, Julio and Giunta, Carmen
},
  title     = {Physikalische Chemie [Hauptbd.]},
  year      = {1990},
  edition   = {2., korr. Nachdr. d. 1. Aufl.},
  series    = {Physikalische Chemie},
  publisher = {Weinheim [u.a.] : Wiley-VCH},
  isbn      = {3-527-25913-9},
  keywords  = {Physikalische Chemie},
}

@Comment{jabref-meta: databaseType:biblatex;}
 


Ich habe mir schon den Leitfaden zur Erstellung von Literaturverzeichnissen durchgelesen, doch ich komme auf keine Lösung des Problems. Muss vielleicht.sty als default extension geändert werden?

Ich hoffe, dass mein Problem nicht zu Trivial ist.

Mit freundlichen Grüßen,
LaTeXN00b (Florian)
Private Nachricht senden Benutzer-Profile anzeigen

Bartman
Forum-Meister
Forum-Meister


Beiträge: 1729
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: ---
     Beitrag Verfasst am: 27.03.2019, 02:57     Titel:
  Antworten mit Zitat      
style ist eine Option des Pakets biblatex. Optionen werden in eckigen Klammern angegeben.

Zu der Option german beim Laden von babel: Du möchtest die alte Rechtschreibung benutzen?

Meines Wissens setzt sich das zuletzt geladene Schriftpaket durch, d. h. lmodern statt mathptmx.

amssymb lädt amsfonts.

Lies bitte wenigstens den Anfang des Abschnitts 3.7.1 Resources in der Dokumentation von biblatex. Dein weiterhin gültiger, aber veralteter, Befehl erwartet nur den Dateinamen ohne die Endung.
Private Nachricht senden Benutzer-Profile anzeigen

LaTeXN00b
Forum-Newbie
Forum-Newbie

Beiträge: 3
Anmeldedatum: 27.03.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 27.03.2019, 17:39     Titel:
  Antworten mit Zitat      
Ich hatte auch zu erst
Code • Öffne in Overleaf
 \usepackage[style=chem-angew]{biblatex}
, aber da habe ich die jetzige Fehlermeldung erhalten und dachte, dass das in Klammern müsste. Die Fehlermeldung lautet":
! Package biblatex Error: File 'Versuch.bbl' not created by biblatex.
See the biblatex package documentation for explanation.
Type H <return> for immediate help." Außerdem erhalte ich die Warnung "empty bibliography" bei der Line in der \printbibliography steht und

"Package biblatex Warning: Please (re)run Biber on the file:
(biblatex) Versuch
(biblatex) and rerun LaTeX afterwards." Jedoch weiß ich nicht wie ich das machen soll.

Ich habe im biblatex-Handbuch unter 3.12.1 Überblick geschaut, aber ich sehe nicht, wie ich das Problem damit lösen kann, denn ich habe den Editor auf biber %, anstatt BibTeX % eingestellt und im Ordner befindet sich auch die entsprechende .bcf- Datei ist im Ordner auch enthalten, damit biber laufen kann.

Entsprechend Abschnitt 3.7 habe ich auch die bibliography geändert mit dem Befehl \addbibliography{Literatur.bib} in der Präambel und \printbibliography an der entsprechenden Stelle.


Zu den Sprachen: Ich habe das mit dem Assistenten erstellt und der hat wohl german anstatt ngerman erstellt, was ich geändert habe.

Bei lmodern vs. mathptmx hast du wohl recht. Jedoch habe ich noch mal in amsfonts nachgeschaut und so wie ich das sehe soll das package zusammen mit amssymb genutzt werden, da amssymb die mathematischen Symbole liefert.

Da aber scheinbar mathptmx die Schriftart im Text und den mathematischen Bereichen vorgeben kann, habe ich die ams-packages und lmodern entfernt. Mein code sieht nun so aus:
Code • Öffne in Overleaf

\documentclass[12pt,a4paper]{article}
\usepackage[utf8]{inputenc}
\usepackage[ngerman]{babel}
\usepackage{csquotes}
\usepackage[T1]{fontenc}
\usepackage{graphicx}
\usepackage{mathptmx}
\usepackage[version=4]{mhchem}
\usepackage[style=chem-angew]{biblatex}
\addbibresource{Literatur.bib}
\usepackage[onehalfspacing]{setspace}
...
\newpage
\printbibliography
 


Ich danke dir jetzt schon für deine Hilfe.
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 27.03.2019, 18:10     Titel:
  Antworten mit Zitat      
Lösch einfach mal die Datei Versuch.bbl (und am besten auch noch die .aux und .bcf-Dateien). Kompiliere dann nochmal mit LaTeX, Biber, LaTeX, LaTeX neu. (Natürlich mit der richtigen Syntax \usepackage[style=chem-angew]{biblatex}.)

Code • Öffne in Overleaf
! Package biblatex Error: File 'Versuch.bbl' not created by biblatex.

bedeutet, dass bereits eine .bbl-Datei (also eine Datei, die für LaTeX lesbare Bibliographie-Informationen enthält) vorhanden ist, die aber nicht für biblatex gedacht ist. Das kann z.B. vorkommen, wenn Du von BibTeX zu biblatex umsteigst, ohne die temporären Dateien zu löschen. Ein Fehler dieser Art kann aber auch vorkommen, wenn eine eigentlich für biblatex bestimmte .bbl geändert oder beschädigt wurde. In den meisten Fällen sollte es genügen, die Datei zu löschen und dann von Biber ordnungsmäßig neu erstellen zu lassen.

Wenn das Problem dauernd auftritt, dann müssten wir uns das genauer ansehen.

LaTeXN00b
Forum-Newbie
Forum-Newbie

Beiträge: 3
Anmeldedatum: 27.03.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 27.03.2019, 18:27     Titel: Problem gelöst
  Antworten mit Zitat      
Habe alle Dateien, bis auf die bib,tex und pdf gelöscht und siehe da, es funktioniert auch ohne Warunungsmeldungen.

Vielen Dank für die Hilfe. Very Happy
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de